aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-19 15:51:45 +0300
committerprspkt <prspkt@protonmail.com>2019-06-19 15:53:14 +0300
commit53c97fb0323349d9930cecfd40120f7e1b3f3223 (patch)
tree6c2d4d48b0447962466bbdf7a979eb71f6218b9b /testing
parent7b62746ed3d230e27322a7ab49f7ce8165e982bc (diff)
downloadaports-53c97fb0323349d9930cecfd40120f7e1b3f3223.tar.bz2
aports-53c97fb0323349d9930cecfd40120f7e1b3f3223.tar.xz
testing/py3-incoming: upgrade to 0.3.1
* Add checkdepends and run test suite
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-incoming/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/testing/py3-incoming/APKBUILD b/testing/py3-incoming/APKBUILD
index 38a239bc90..34e85ad538 100644
--- a/testing/py3-incoming/APKBUILD
+++ b/testing/py3-incoming/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-incoming
_pkgname=incoming
-pkgver=0.2.6
+pkgver=0.3.1
pkgrel=0
pkgdesc="A Python JSON validation framework"
url="https://github.com/vaidik/incoming"
@@ -10,6 +10,7 @@ arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
+checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -20,8 +21,12 @@ build() {
python3 setup.py build
}
+check() {
+ python3 setup.py test
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="82902dc2adfba274497d51baebf577978c4c6a8ab5bf89b54c9b47abe0936f4cd8755c33451429049cc907f23e06b8bd51dbd3fadab4d42fff795a46b020f428 incoming-0.2.6.tar.gz"
+sha512sums="5018e919485450fd8e361d8d505ead8c5fd0c99e0349feecf372697e866eb53f6dca6186a49244b20b61ddb65f754d58b6c0e11aa0ae95e8c98f35983a691cb8 incoming-0.3.1.tar.gz"