aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-05-02 00:01:43 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-10 19:39:08 +0000
commit7453a724f9e7d31d989c624d98eae8de69873d29 (patch)
treea53e33cf632cd049beb7c87b3a27b35faaabce81 /testing
parentb995ba418f12a756881f6f9228c326dd7fc00a57 (diff)
downloadaports-7453a724f9e7d31d989c624d98eae8de69873d29.tar.bz2
aports-7453a724f9e7d31d989c624d98eae8de69873d29.tar.xz
testing/amtk: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/amtk/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/amtk/APKBUILD b/testing/amtk/APKBUILD
new file mode 100644
index 0000000000..08b1ac12ff
--- /dev/null
+++ b/testing/amtk/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=amtk
+pkgver=5.0.0
+pkgrel=0
+pkgdesc="Actions, Menus and Toolbars Kit for GTK+ applications"
+url="https://wiki.gnome.org/Projects/Amtk"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="gtk+3.0-dev glib-dev gobject-introspection-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/amtk/${pkgver%.*}/amtk-${pkgver}.tar.xz"
+builddir="$srcdir/amtk-$pkgver"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="86433a7b314bfbdd00cd53a7223561645b0ebd40ec519f97b61e8df073b88c76425182ad71a49794090a51eddf68b81f4c7d88c4bf6a618311aa92908f5bea73 amtk-5.0.0.tar.xz"