aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-02-21 23:12:24 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-02-21 23:13:01 +0100
commit753b0965d13f776141816e9fbacd56f172c65cdb (patch)
tree8597313d094b621b8114839987903ef085ae737d /testing
parentef20ca123b791a292581494501ec7d6725e1bcae (diff)
downloadaports-753b0965d13f776141816e9fbacd56f172c65cdb.tar.bz2
aports-753b0965d13f776141816e9fbacd56f172c65cdb.tar.xz
testing/ruby-rugged: skip flawed test that fails on some builders
Diffstat (limited to 'testing')
-rw-r--r--testing/ruby-rugged/APKBUILD2
-rw-r--r--testing/ruby-rugged/skip-test_read_global_config_file.patch13
2 files changed, 15 insertions, 0 deletions
diff --git a/testing/ruby-rugged/APKBUILD b/testing/ruby-rugged/APKBUILD
index 49e66ebfc1..9ca70e2945 100644
--- a/testing/ruby-rugged/APKBUILD
+++ b/testing/ruby-rugged/APKBUILD
@@ -14,6 +14,7 @@ source="$_gemname-$pkgver.tar.gz::https://github.com/libgit2/$_gemname/archive/v
fix-extconf-version-check.patch
libgit2-fixture-dir.patch
skip-test_discover_false.patch
+ skip-test_read_global_config_file.patch
fix-for-returning-enumerators.patch"
builddir="$srcdir/$_gemname-$pkgver"
@@ -55,4 +56,5 @@ sha512sums="555fbfdc5b941212d7e47e4dcf2d39a6207c316ee4ce7e0f11c16929aae166a31d71
c55c71d93f2d0430b83bdf8da6ef1754a519c190c0bbaf02ceb96f2b3f20616fe2ec6cb48eabfa2c87cbaf0cbdf4489a54e76080b8c5a8f4a7307019dd2aebe3 fix-extconf-version-check.patch
0c749aeb8d6a29aed51737bab09c7b0a6669ac691461758c856ede5d8510ad6edfa284cddd1b54982bf614a45ba817b70e838e071889a9b05e1b0580111ec826 libgit2-fixture-dir.patch
33464eeefc7669fe3bf5f47c4016cacdcba4f7455ed22b441383b49721870072b5095dbb68832cdb933a7659a415476db64b579a98c888b83900d092bb8b54be skip-test_discover_false.patch
+b9e028f18830e447773e895046eb03489e94bb5a76fede51f93545ed67f7249ed8f37ed4bb832eb68a2db281ff3e2b84dab8b72bb21eea4b835b0f1ce23943c3 skip-test_read_global_config_file.patch
5b5dd9dc7d9d142bf4e8fd0a4ff78ae006ecba416bd71bfc51f0d7565755047d64fd59bef03c9cd7f8be1347df8214e0a6ce57512981de31cc88baedb4ac3f7a fix-for-returning-enumerators.patch"
diff --git a/testing/ruby-rugged/skip-test_read_global_config_file.patch b/testing/ruby-rugged/skip-test_read_global_config_file.patch
new file mode 100644
index 0000000000..d3a3310c3f
--- /dev/null
+++ b/testing/ruby-rugged/skip-test_read_global_config_file.patch
@@ -0,0 +1,13 @@
+It seems that this test fails when user.name is NOT set in ~/.gitconfig
+on the build system.
+
+--- a/test/config_test.rb
++++ b/test/config_test.rb
+@@ -17,6 +17,7 @@
+ end
+
+ def test_read_global_config_file
++ skip 'This test is flawed, it runs on real FS, i.e. it is not isolated'
+ config = Rugged::Config.global
+ refute_nil config['user.name']
+ assert_nil config['core.bare']