aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-24 19:13:31 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-09-29 14:07:37 +0000
commit78db7c5562738e8376f7763dd9f45e96da33410c (patch)
tree58e71a21e2fbde87eec54a35bfc6712ff2836c3c /testing
parentde0851fb97a4e89a534699165ea234b5977e29da (diff)
downloadaports-78db7c5562738e8376f7763dd9f45e96da33410c.tar.bz2
aports-78db7c5562738e8376f7763dd9f45e96da33410c.tar.xz
testing/py-pyrss2gen: new aport
A generator for RSS2 using a Python data structure http://dalkescientific.com/Python/PyRSS2Gen.html
Diffstat (limited to 'testing')
-rw-r--r--testing/py-pyrss2gen/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-pyrss2gen/APKBUILD b/testing/py-pyrss2gen/APKBUILD
new file mode 100644
index 0000000000..d1a5612353
--- /dev/null
+++ b/testing/py-pyrss2gen/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-pyrss2gen
+_pkgname=PyRSS2Gen
+pkgver=1.1
+pkgrel=0
+pkgdesc="A generator for RSS2 using a Python data structure"
+url="http://dalkescientific.com/Python/PyRSS2Gen.html"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="3529f831c6a4ed717b55315974e16317 PyRSS2Gen-1.1.tar.gz"
+sha256sums="7960aed7e998d2482bf58716c316509786f596426f879b05f8d84e98b82c6ee7 PyRSS2Gen-1.1.tar.gz"
+sha512sums="23079bdd6a54c0c5f27f0ade81b8ac1a28031779b9952e2d2f16d5100fa0f58c1f6b0a3f02a5e2c7d2d0e309c369a5f518ebcafb77f17c3d2f639b997d13fbd4 PyRSS2Gen-1.1.tar.gz"