aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-08-21 10:51:41 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-08-21 10:51:41 +0200
commita4811031179509d1b28b805fbe4ab4709379224b (patch)
tree89979cdffcf7d61df722b57394092b6d6119965e /testing
parentc88599220e0595ceb6135edb62ccfdddd88e28ea (diff)
downloadaports-a4811031179509d1b28b805fbe4ab4709379224b.tar.bz2
aports-a4811031179509d1b28b805fbe4ab4709379224b.tar.xz
testing/xfce4-stopwatch-plugin: fix plugindir
Diffstat (limited to 'testing')
-rw-r--r--testing/xfce4-stopwatch-plugin/APKBUILD8
-rw-r--r--testing/xfce4-stopwatch-plugin/plugindir.patch14
2 files changed, 19 insertions, 3 deletions
diff --git a/testing/xfce4-stopwatch-plugin/APKBUILD b/testing/xfce4-stopwatch-plugin/APKBUILD
index d8dd6ce82c..b849741302 100644
--- a/testing/xfce4-stopwatch-plugin/APKBUILD
+++ b/testing/xfce4-stopwatch-plugin/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname="xfce4-stopwatch-plugin"
pkgver="0.3.1"
-pkgrel=0
+pkgrel=1
pkgdesc="Stopwatch plugin for the Xfce panel"
url="https://goodies.xfce.org/projects/panel-plugins/xfce4-stopwatch-plugin"
arch="all"
@@ -9,7 +9,8 @@ license="BSD"
makedepends="xfce4-panel-dev libxfce4ui-dev gtk+3.0-dev"
options="!check" # no testsuite
subpackages="$pkgname-lang"
-source="http://archive.xfce.org/src/panel-plugins/xfce4-stopwatch-plugin/${pkgver%.*}/xfce4-stopwatch-plugin-$pkgver.tar.bz2"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-stopwatch-plugin/${pkgver%.*}/xfce4-stopwatch-plugin-$pkgver.tar.bz2
+ plugindir.patch"
builddir="$srcdir/xfce4-stopwatch-plugin-$pkgver"
build() {
@@ -27,4 +28,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="f90b6728a4b0589230ccdbdc2beaebd4cde69895c68911d0417fe34a924f05612c65f0337865d5c83b28dd172c7ab56a462d60a425d5377bdbc82d69967d6860 xfce4-stopwatch-plugin-0.3.1.tar.bz2"
+sha512sums="f90b6728a4b0589230ccdbdc2beaebd4cde69895c68911d0417fe34a924f05612c65f0337865d5c83b28dd172c7ab56a462d60a425d5377bdbc82d69967d6860 xfce4-stopwatch-plugin-0.3.1.tar.bz2
+4f81ca4d032e7bc08366b69d771ad27047d3a5a390e9883cc883833adb6a4575d76f3530f114f7878ac517a5062460f4de74bd685f178815e63bb9d03e8c8d5a plugindir.patch"
diff --git a/testing/xfce4-stopwatch-plugin/plugindir.patch b/testing/xfce4-stopwatch-plugin/plugindir.patch
new file mode 100644
index 0000000000..02eec18a31
--- /dev/null
+++ b/testing/xfce4-stopwatch-plugin/plugindir.patch
@@ -0,0 +1,14 @@
+temp workaround
+diff --git a/panel-plugin/Makefile.in b/panel-plugin/Makefile.in
+index 25a3cdd..c1dda42 100644
+--- a/panel-plugin/Makefile.in
++++ b/panel-plugin/Makefile.in
+@@ -394,7 +394,7 @@ stopwatch_VALABUILTSOURCES = $(stopwatch_VALASOURCES:.vala=.c)
+ #
+ # Plugin
+ #
+-plugindir = $(libexecdir)/xfce4/panel/plugins
++plugindir = $(libdir)/xfce4/panel/plugins
+ plugin_LTLIBRARIES = libstopwatch.la
+ libstopwatch_la_SOURCES = \
+ $(stopwatch_VALABUILTSOURCES)