aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@mirantis.com>2016-07-01 11:16:12 +0200
committerBartłomiej Piotrowski <bpiotrowski@mirantis.com>2016-07-01 11:18:42 +0200
commitae4cd0e2fdf75d20a9ed58b618f1b202fd0d0db5 (patch)
tree1b0e066c46973f9ffe49ae709098ace1085a26c7 /testing
parentba7e4d67e88cb81e85801d2e48dd17d231aad8e1 (diff)
downloadaports-ae4cd0e2fdf75d20a9ed58b618f1b202fd0d0db5.tar.bz2
aports-ae4cd0e2fdf75d20a9ed58b618f1b202fd0d0db5.tar.xz
testing/cjdns: new aport
Cjdns implements an encrypted IPv6 network using public-key cryptography for address allocation and a distributed hash table for routing. This provides near-zero-configuration networking, and prevents many of the security and scalability issues that plague existing networks. https://github.com/cjdelisle/cjdns
Diffstat (limited to 'testing')
-rw-r--r--testing/cjdns/APKBUILD45
-rw-r--r--testing/cjdns/cjdns.post-install5
2 files changed, 50 insertions, 0 deletions
diff --git a/testing/cjdns/APKBUILD b/testing/cjdns/APKBUILD
new file mode 100644
index 0000000000..328b3c86a8
--- /dev/null
+++ b/testing/cjdns/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=cjdns
+pkgver=17.4
+pkgrel=0
+pkgdesc='A routing engine designed for security, scalability, speed and ease of use'
+url='https://github.com/cjdelisle/cjdns'
+arch=all
+license='GPL3'
+depends=
+makedepends='bash nodejs-lts python linux-headers libseccomp-dev'
+install="$pkgname.post-install"
+subpackages="$pkgname-doc"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/cjdelisle/${pkgname}/archive/cjdns-v${pkgver}.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgname-v$pkgver"
+
+build() {
+ cd "$builddir"
+ CJDNS_RELEASE_VERSION="${pkgver}" bash 'do'
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 cjdroute "$pkgdir/usr/bin/cjdroute"
+ install -Dm755 contrib/openrc/cjdns "$pkgdir/etc/init.d/cjdns"
+
+ install -Dm644 doc/man/cjdroute.conf.5 \
+ "${pkgdir}/usr/share/man/man5/cjdroute.conf.5"
+ install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" \
+ doc/admin-api.md \
+ doc/configure.md \
+ doc/djc_layer_model.md \
+ doc/nat-gateway.md \
+ doc/network-services.md \
+ doc/non-root-user.md \
+ doc/security_specification.md \
+ doc/shorewall_and_vpn_gateway_howto.md \
+ doc/tunnel.md
+}
+
+md5sums="e74f25941879e807086a8b70771fcf60 cjdns-17.4.tar.gz"
+sha256sums="2f30aa4d2cc96a6c1f00e873df19b7b213cca1af716d74a091f59aa98b5758c4 cjdns-17.4.tar.gz"
+sha512sums="16f13d39b09b8388a2814e234c1f866d87c6699d215cce78885258224c9a5969720e436f960b8b160d47eb403622d81947234323c8b4734a9cc68de247b314de cjdns-17.4.tar.gz"
diff --git a/testing/cjdns/cjdns.post-install b/testing/cjdns/cjdns.post-install
new file mode 100644
index 0000000000..0e091e941c
--- /dev/null
+++ b/testing/cjdns/cjdns.post-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+umask 007
+[ ! -f /etc/cjdroute.conf ] && \
+ cjdroute --genconf > /etc/cjdroute.conf