aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-10 22:18:22 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-10 17:53:39 -0300
commitd00898d0f9daa896324ac075a4a6699972cc207c (patch)
treec07aa6f77b79c0aabb01e8d630782745b933ba9d /testing
parentc74b2faac8e4e4ea10cce00f7cc997ba2af12e89 (diff)
downloadaports-d00898d0f9daa896324ac075a4a6699972cc207c.tar.bz2
aports-d00898d0f9daa896324ac075a4a6699972cc207c.tar.xz
testing/epiphany: upgrade to 3.34.0
Diffstat (limited to 'testing')
-rw-r--r--testing/epiphany/APKBUILD8
-rw-r--r--testing/epiphany/disable-faulty-test.patch27
2 files changed, 3 insertions, 32 deletions
diff --git a/testing/epiphany/APKBUILD b/testing/epiphany/APKBUILD
index 54b4471e2f..5990d36aee 100644
--- a/testing/epiphany/APKBUILD
+++ b/testing/epiphany/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=epiphany
-pkgver=3.32.4
+pkgver=3.34.0
pkgrel=0
pkgdesc="A simple, clean, beautiful view of the web"
options="!check" # Location entry test fails on builders
@@ -14,8 +14,7 @@ makedepends="meson iso-codes-dev gtk+3.0-dev gsettings-desktop-schemas-dev
libsoup-dev libxml2-dev nettle-dev sqlite-dev webkit2gtk-dev gcr-dev itstool"
checkdepends="appstream-glib desktop-file-utils xvfb-run"
subpackages="$pkgname-lang $pkgname-doc"
-source="https://download.gnome.org/sources/epiphany/${pkgver%.*}/epiphany-${pkgver}.tar.xz
- disable-faulty-test.patch"
+source="https://download.gnome.org/sources/epiphany/${pkgver%.*}/epiphany-$pkgver.tar.xz"
build() {
meson \
@@ -36,5 +35,4 @@ package() {
DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="34f9f4267862b494cbeb225ce63cd7767851f1cca16b4c8e03057b074999954477f2ed891c60f20910abcc7a553371f8f03e59fc9da4cf459dd5cbfde8a6d67c epiphany-3.32.4.tar.xz
-ab8ceffd38a00217704bb9e0e0e514cb2aecc4ace2e8caf0f8cb8bf6468e347ed5cb4e87f0120a86e25f9a0b8fa58de499e9a2e1c2d8f5386c9189ba9752e211 disable-faulty-test.patch"
+sha512sums="a29cf1cc5fd7f2fdfd316c18b8c9e8801610bb2c221d814fcd4150c3ebde3e09a58d7ce51582db7ca48c13b4dbce89fa3ee2483bba7d0e1ff3f03b97e85b9aa4 epiphany-3.34.0.tar.xz"
diff --git a/testing/epiphany/disable-faulty-test.patch b/testing/epiphany/disable-faulty-test.patch
deleted file mode 100644
index 285c102121..0000000000
--- a/testing/epiphany/disable-faulty-test.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-See: https://gitlab.gnome.org/GNOME/epiphany/issues/829
---- a/tests/meson.build
-+++ b/tests/meson.build
-@@ -150,14 +150,15 @@
- env: envs,
- )
-
-- web_app_utils_test = executable('test-ephy-web-app-utils',
-- 'ephy-web-app-utils-test.c',
-- dependencies: ephymain_dep
-- )
-- test('Web app utils test',
-- web_app_utils_test,
-- env: envs
-- )
-+ # FIXME: https://gitlab.gnome.org/GNOME/epiphany/issues/829
-+ # web_app_utils_test = executable('test-ephy-web-app-utils',
-+ # 'ephy-web-app-utils-test.c',
-+ # dependencies: ephymain_dep
-+ # )
-+ # test('Web app utils test',
-+ # web_app_utils_test,
-+ # env: envs
-+ # )
-
- # FIXME: https://bugzilla.gnome.org/show_bug.cgi?id=780280
- # web_view_test = executable('test-ephy-web-view',