aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-27 12:00:43 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-27 07:12:58 -0300
commitd1610e68fac044b9a492aaebfd1601c5d32cb20f (patch)
tree25994d96383acd1e28d7523e9573c07009b0f598 /testing
parente7de287a2c0f402b5ffff5df0ad3dc6024a5becf (diff)
downloadaports-d1610e68fac044b9a492aaebfd1601c5d32cb20f.tar.bz2
aports-d1610e68fac044b9a492aaebfd1601c5d32cb20f.tar.xz
community/latte-dock: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/latte-dock/APKBUILD35
-rw-r--r--testing/latte-dock/fix-build.patch12
2 files changed, 0 insertions, 47 deletions
diff --git a/testing/latte-dock/APKBUILD b/testing/latte-dock/APKBUILD
deleted file mode 100644
index be46e5b0cf..0000000000
--- a/testing/latte-dock/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=latte-dock
-pkgver=0.9.2
-pkgrel=0
-arch="all !ppc64le !s390x" # Limited by libksysguard -> qt5-qtwebengine
-url="https://store.kde.org/p/1169519/"
-pkgdesc="A dock based on Plasma Frameworks"
-license="LGPL-2.0-or-later AND GPL-2.0-or-later"
-depends="kactivities"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev libksysguard-dev
- kactivities-dev karchive-dev kcoreaddons-dev kguiaddons-dev kcrash-dev
- kdbusaddons-dev kdeclarative-dev kglobalaccel-dev ki18n-dev kiconthemes-dev
- knewstuff-dev knotifications-dev plasma-framework-dev kwayland-dev
- kwindowsystem-dev kxmlgui-dev xcb-util-dev plasma-desktop-dev"
-source="https://download.kde.org/stable/latte-dock/latte-dock-$pkgver.tar.xz"
-subpackages="$pkgname-lang"
-
-build() {
- cmake \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
- make
-}
-
-check() {
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
-}
-
-package() {
- DESTDIR="$pkgdir" make install
-}
-
-sha512sums="3537ec6b9503802a7efbbea7ae6ddf864188ba3b73c8121b434efc527f3c3e8d8f5e68447541a867b4422ccc5e3d2af85f491807a597bdb747960e8ab983bebd latte-dock-0.9.2.tar.xz"
diff --git a/testing/latte-dock/fix-build.patch b/testing/latte-dock/fix-build.patch
deleted file mode 100644
index a1af493354..0000000000
--- a/testing/latte-dock/fix-build.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index deadb48..fcf6d67 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -76,7 +76,5 @@ add_subdirectory(icons)
- add_subdirectory(plasmoid)
- add_subdirectory(shell)
-
--ki18n_install(${CMAKE_CURRENT_BINARY_DIR}/po)
--
- find_package(KF5I18n CONFIG REQUIRED)
- ki18n_install(po)