aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-01 22:11:27 +0300
committerprspkt <prspkt@protonmail.com>2019-07-01 22:20:34 +0300
commite80906ed09420e912749e6bc50be06afcd0ffc49 (patch)
treeebebe0c7ca5879f2b22d694155ac28abc472d3e7 /testing
parenteb30277a219f9ba37469f718cb7d1e5a72920e2b (diff)
downloadaports-e80906ed09420e912749e6bc50be06afcd0ffc49.tar.bz2
aports-e80906ed09420e912749e6bc50be06afcd0ffc49.tar.xz
testing/py-firmata: drop python2
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-firmata/APKBUILD (renamed from testing/py-firmata/APKBUILD)34
1 files changed, 8 insertions, 26 deletions
diff --git a/testing/py-firmata/APKBUILD b/testing/py3-firmata/APKBUILD
index a0fb0a7951..294a17e3c0 100644
--- a/testing/py-firmata/APKBUILD
+++ b/testing/py3-firmata/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-firmata
+pkgname=py3-firmata
_pkgname=pyFirmata
pkgver=1.0.3
pkgrel=1
@@ -8,44 +8,26 @@ pkgdesc="Python interface for the Firmata procotol"
url="https://github.com/tino/pyFirmata"
arch="noarch"
license="MIT"
-depends="python2 python3 py-serial"
+depends="python3 py3-serial"
depends_dev=""
-makedepends="python2-dev python3-dev py-setuptools"
+makedepends="py3-setuptools"
install=""
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
options="!check" # upstream provides no testsuite
_builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces=py-firmata # Backwards compatibility
+provides=py-firmata=$pkgver-r$pkgrel # Backwards compatibility
+
build() {
cd "$_builddir"
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
cd "$_builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="9a5986d417447503c39e0497881592cecc38b423c55a627a38b398952cec7469e143ecbf1a82f9cd20ad93c7956ec06553f28e708419f05bb3c1d120961aa1b9 pyFirmata-1.0.3.tar.gz"