aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorHolger Jaekel <holger.jaekel@gmx.de>2019-11-23 22:50:59 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-15 17:03:56 +0100
commit231f7cf8d8f4a1b9080884a0dfe28dbebd1f757c (patch)
tree4cf38493ea90ce5714e6f41c0c56ea2aa2f8344b /testing
parent15e888119bc29a6944c0d4437662138678390e70 (diff)
downloadaports-231f7cf8d8f4a1b9080884a0dfe28dbebd1f757c.tar.bz2
aports-231f7cf8d8f4a1b9080884a0dfe28dbebd1f757c.tar.xz
testing/xerces-c: enable on all platforms
Diffstat (limited to 'testing')
-rw-r--r--testing/xerces-c/APKBUILD45
1 files changed, 28 insertions, 17 deletions
diff --git a/testing/xerces-c/APKBUILD b/testing/xerces-c/APKBUILD
index 4dea346ad7..dc240a0dda 100644
--- a/testing/xerces-c/APKBUILD
+++ b/testing/xerces-c/APKBUILD
@@ -2,33 +2,44 @@
# Maintainer: Andrew Bell <andrew.bell.ia@gmail.com>
pkgname=xerces-c
pkgver=3.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="A validating XML parser written in a portable subset of C++"
url="https://xerces.apache.org/index.html"
-arch="x86 x86_64"
+arch="all"
license="Apache-2.0"
makedepends="
- cmake
- linux-headers
- "
+ cmake
+ curl-dev
+ icu-dev
+ "
subpackages="$pkgname-samples $pkgname-doc $pkgname-dev"
_pkgver=${pkgver//./_}
-_srcname="Xerces-C_${_pkgver}"
-source="https://github.com/apache/xerces-c/archive/${_srcname}.tar.gz"
+_srcname="Xerces-C_$_pkgver"
+source="https://github.com/apache/xerces-c/archive/$_srcname.tar.gz"
builddir="$srcdir/$pkgname-$_srcname"
build() {
- mkdir build && cd build
- cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE=Release
- make
+ mkdir build && cd build
+
+ local thread_support=-Dthreads:BOOL=ON
+ case "$CARCH" in
+ s390x) thread_support=-Dthreads:BOOL=OFF ;;
+ esac
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="$pkgdir"/usr \
+ $thread_support \
+ -Dnetwork-accessor=curl \
+ -Dmessage-loader=icu \
+ -Dtranscoder=icu
+ cmake --build .
}
package() {
- cd "$builddir"/build
- make DESTDIR="$pkgdir" install
+ cd "$builddir"/build
+ cmake --build . --target install --config Release
}
samples() {
@@ -39,7 +50,7 @@ samples() {
}
check() {
- cd "$builddir"/build
- make test
+ cd "$builddir"/build
+ ctest
}
sha512sums="66f60fe9194376ac0ca99d13ea5bce23ada86e0261dde30686c21ceb5499e754dab8eb0a98adadd83522bda62709377715501f6dac49763e3a686f9171cc63ea Xerces-C_3_2_2.tar.gz"