aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorPaul Bredbury <brebs@sent.com>2019-03-20 21:23:09 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-03 09:19:01 +0000
commitbc948f396a0595a876c99e0db06a6b495654cfe7 (patch)
tree3ca173437bbe4d69c5a9225fa0fa766de45b5c13 /testing
parentfa934d5d7233a27d709caa4a3cc1b7650588824a (diff)
downloadaports-bc948f396a0595a876c99e0db06a6b495654cfe7.tar.bz2
aports-bc948f396a0595a876c99e0db06a6b495654cfe7.tar.xz
testing/cherrytree: upgrade to 0.38.8
Use patch instead of sed, for clarity.
Diffstat (limited to 'testing')
-rw-r--r--testing/cherrytree/APKBUILD15
-rw-r--r--testing/cherrytree/update-desktop-database-removal.patch10
2 files changed, 15 insertions, 10 deletions
diff --git a/testing/cherrytree/APKBUILD b/testing/cherrytree/APKBUILD
index 1507efd44c..52f9d7b84b 100644
--- a/testing/cherrytree/APKBUILD
+++ b/testing/cherrytree/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Paul Bredbury <brebs@sent.com>
pkgname=cherrytree
-pkgver=0.38.7
+pkgver=0.38.8
pkgrel=0
pkgdesc="Hierarchical note-taking app featuring rich text"
url="https://www.giuspen.com/cherrytree/"
@@ -9,17 +9,11 @@ license="GPL-3.0-or-later"
depends="py-dbus py-gtk py-pygtksourceview2"
makedepends="gettext"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://www.giuspen.com/software/$pkgname-$pkgver.tar.xz"
+source="https://www.giuspen.com/software/$pkgname-$pkgver.tar.xz
+ update-desktop-database-removal.patch"
options="!check" # No test suite
builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- default_prepare
-
- # Run by desktop-file-utils.trigger instead
- sed -e "/subprocess.*update-desktop-database/d" -i setup.py
-}
-
build() {
cd "$builddir"
python2 setup.py build
@@ -30,4 +24,5 @@ package() {
python2 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="3b52b0a5f1bc7d2aa5eb7622c31ded85f7cf1c0361f9bfa1842c7a07f8f3fb694b27f8d6fe8486482bf293b0300a383cf02ba2dc79d520a1862ae439a17cc371 cherrytree-0.38.7.tar.xz"
+sha512sums="0ba188c93ce8c3eee73f7c8622872305df95c2c545d1bfd486af744229d6edc166ac6a9e10621d059a245d01b5458ad6dd8efdfdb9265cef0028f2426cfd1f72 cherrytree-0.38.8.tar.xz
+d56dbb037c9205d038892bd4d7fd48ff4406162a1114ab7b9991b76f974fb683e1d3ddc3bfaa37214269c032c2908ec00e5ad17e2c6439a280eff8881e291428 update-desktop-database-removal.patch"
diff --git a/testing/cherrytree/update-desktop-database-removal.patch b/testing/cherrytree/update-desktop-database-removal.patch
new file mode 100644
index 0000000000..80275f2302
--- /dev/null
+++ b/testing/cherrytree/update-desktop-database-removal.patch
@@ -0,0 +1,10 @@
+Run by Alpine's desktop-file-utils.trigger instead
+
+diff -Naur a/setup.py b/setup.py
+--- a/setup.py 2019-01-02 08:01:06.000000000 +0000
++++ b/setup.py 2019-03-20 21:12:53.570596428 +0000
+@@ -205,4 +205,3 @@
+ },
+ distclass=CherryTreeDist
+ )
+- subprocess.call("update-desktop-database")