aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2019-04-19 23:24:14 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-21 15:20:54 +0000
commitcdc764ead1256a06f99e58dbac253bc4937924b5 (patch)
treed7153fbc6ae9a431a81256fdd08672776c40f294 /testing
parent1a43c5ab09b5f83bb206f07dc1bc47b146726410 (diff)
downloadaports-cdc764ead1256a06f99e58dbac253bc4937924b5.tar.bz2
aports-cdc764ead1256a06f99e58dbac253bc4937924b5.tar.xz
testing/perl-crypt-openssl-x509: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-crypt-openssl-x509/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/perl-crypt-openssl-x509/APKBUILD b/testing/perl-crypt-openssl-x509/APKBUILD
new file mode 100644
index 0000000000..3dfcb819b0
--- /dev/null
+++ b/testing/perl-crypt-openssl-x509/APKBUILD
@@ -0,0 +1,34 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-crypt-openssl-x509
+_pkgreal=Crypt-OpenSSL-X509
+pkgver=1.812
+pkgrel=0
+pkgdesc="Perl extension to OpenSSL's X509 API."
+url="https://metacpan.org/release/Crypt-OpenSSL-X509/"
+arch="all"
+license="GPL PerlArtistic"
+cpanmakedepends="openssl-dev"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/J/JO/JONASBN/Crypt-OpenSSL-X509-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="716ee6dc0b0027e6d00a8d7f72c58309f540d8c9ef079aca9c8354f41a50a196ccaa7acb7a8d5b35074cb0a779015b74880f2e88ac9f8a28f79f307223d14474 Crypt-OpenSSL-X509-1.812.tar.gz"