aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-09-16 22:25:25 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-26 19:29:04 +0000
commit5d3214f674b56aa5e6beebe7059ae505457b19f3 (patch)
tree69e845a9c218cc07cbe05ceea1b325d59559e773 /testing
parentb332397d8a0ccc8d60bb3c4cd092117a829a4122 (diff)
downloadaports-5d3214f674b56aa5e6beebe7059ae505457b19f3.tar.bz2
aports-5d3214f674b56aa5e6beebe7059ae505457b19f3.tar.xz
testing/py-telegram-bot: upgrade to 11.1.0 & modernize
Diffstat (limited to 'testing')
-rw-r--r--testing/py-telegram-bot/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/testing/py-telegram-bot/APKBUILD b/testing/py-telegram-bot/APKBUILD
index 8e9832d26a..c4b66f6019 100644
--- a/testing/py-telegram-bot/APKBUILD
+++ b/testing/py-telegram-bot/APKBUILD
@@ -2,16 +2,16 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py-telegram-bot
_pkgname=${pkgname/py/python}
-pkgver=10.0.2
+pkgver=11.1.0
pkgrel=0
pkgdesc="A Python wrapper around the Telegram Bot API"
url="https://github.com/python-telegram-bot/python-telegram-bot"
arch="noarch"
license="LGPL-3.0-or-later"
-depends="py-futures py-certifi"
-depends_dev=""
+depends="py-certifi"
+#checkdepends="pytest py-cffi py-cryptography py-future py-pathlib2"
+options="!check" # few requirements-dev.txt packages missing in alpine
makedepends="python2-dev python3-dev py2-setuptools"
-install=""
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="$pkgname-$pkgver.zip::https://github.com/$_pkgname/$_pkgname/archive/v$pkgver.zip"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -28,7 +28,7 @@ package() {
_py2() {
replaces="$pkgname"
- depends="${depends//py-/py2-}"
+ depends="py2-futures ${depends//py-/py2-}"
_py python2
}
@@ -47,4 +47,4 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="a16877752caa1fc658f2a44f9e61f798f1a4e6770fa09a04d88c9bdb368bbe95a37a34e0de2c7acafb9e1c24963861d55d1bdbfded07dc0ba54d49854fb5ce10 py-telegram-bot-10.0.2.zip"
+sha512sums="2f9f13dfd784a48e05537a3038057ca4f03d075132af2bd3cc8a67e4f6bd1a8c361afd4f508529a5031938b005a2b1442085c84b353e58d39a99292c6d037730 py-telegram-bot-11.1.0.zip"