aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMarvin Steadfast <marvin@xsteadfastx.org>2019-03-22 08:52:45 +0100
committerprspkt <prspkt@protonmail.com>2019-03-25 18:52:44 +0200
commit7f8798afe4790a6a19d977b3775cf7dcfdfaf1a4 (patch)
tree20bbb31d757ac0315908664693952aed254db7f3 /testing
parent7055d2145820464d2728453a788d001925c19f99 (diff)
downloadaports-7f8798afe4790a6a19d977b3775cf7dcfdfaf1a4.tar.bz2
aports-7f8798afe4790a6a19d977b3775cf7dcfdfaf1a4.tar.xz
testing/rofi: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/rofi/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/rofi/APKBUILD b/testing/rofi/APKBUILD
new file mode 100644
index 0000000000..788870f812
--- /dev/null
+++ b/testing/rofi/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Marvin Steadfast <marvin@xsteadfastx.org>
+# Maintainer: Marvin Steadfast <marvin@xsteadfastx.org>
+pkgname=rofi
+pkgver=1.5.2
+pkgrel=0
+pkgdesc="A window switcher, application launcher and dmenu replacement"
+url="https://github.com/DaveDavenport/rofi"
+arch="all"
+license="MIT"
+makedepends="bash bison cairo-dev flex glib-dev i3wm-dev librsvg-dev libxcb-dev
+ libxkbcommon-dev pango-dev startup-notification-dev xcb-util-dev
+ xcb-util-wm-dev xcb-util-xrm-dev"
+checkdepends="check-dev xkeyboard-config"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/davatorium/rofi/releases/download/$pkgver/rofi-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver/"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="8fbbcaa040148d204878380f7cb96fa31228f72b68a97a5bcf8d8cd69740f6b185f5e5d2bc2e1d35e267a84b21576eb356c33be827fd1b767460665493360c16 rofi-1.5.2.tar.xz"