aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-20 00:31:38 +0300
committerprspkt <prspkt@protonmail.com>2019-06-20 01:02:40 +0300
commit8b203561f3c62d6f269b8febde0205522c47a35d (patch)
tree17b743b169b935064a6868a37dd1b2e62ab85af7 /testing
parentcef7ce2f8e12c551b8d04a245fd5746c5e37739b (diff)
downloadaports-8b203561f3c62d6f269b8febde0205522c47a35d.tar.bz2
aports-8b203561f3c62d6f269b8febde0205522c47a35d.tar.xz
testing/py-blessings: drop python2
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-blessings/APKBUILD (renamed from testing/py-blessings/APKBUILD)28
1 files changed, 4 insertions, 24 deletions
diff --git a/testing/py-blessings/APKBUILD b/testing/py3-blessings/APKBUILD
index f23118644b..199e986918 100644
--- a/testing/py-blessings/APKBUILD
+++ b/testing/py3-blessings/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-blessings
+pkgname=py3-blessings
_pkgname=blessings
pkgver=1.7
pkgrel=2
@@ -8,40 +8,20 @@ pkgdesc="Wrapper around terminal coloring, styling and positioning"
url="https://github.com/erikrose/blessings"
arch="noarch"
license="MIT"
-depends=""
-makedepends="py-setuptools python2-dev python3-dev"
-subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
+depends="py3-six"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="66a8e7af6a8807c8be68f4d71db25ca6c26f46ddfa9a7e4792a2f73033df81d8392633ff75e6fa131039d9136030844ed93b11316b9f7e2e6ea77675f2f3e528 blessings-1.7.tar.gz"