aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-24 09:41:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-24 09:41:22 +0000
commit8efc2b84f3607bd0fcd164ad0aaa1c42783f6cb1 (patch)
tree01d8542f08c3a38a65ec4d3aef817931ade9efed /testing
parenteb8d770a77408f127ff2fa138aad5cb07dde8d08 (diff)
downloadaports-8efc2b84f3607bd0fcd164ad0aaa1c42783f6cb1.tar.bz2
aports-8efc2b84f3607bd0fcd164ad0aaa1c42783f6cb1.tar.xz
main/collectd: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/collectd/APKBUILD83
-rw-r--r--testing/collectd/collectd.initd20
2 files changed, 0 insertions, 103 deletions
diff --git a/testing/collectd/APKBUILD b/testing/collectd/APKBUILD
deleted file mode 100644
index 617accbd9d..0000000000
--- a/testing/collectd/APKBUILD
+++ /dev/null
@@ -1,83 +0,0 @@
-# Contributor:
-# Maintainer:
-pkgname=collectd
-pkgver=4.9.1
-pkgrel=3
-pkgdesc="The system statistics collection daemon"
-url="http://collectd.org"
-license="GPL"
-depends=
-makedepends="pkgconfig curl-dev net-snmp-dev postgresql-dev perl-dev
- libgcrypt-dev mysql-dev zlib-dev openssl-dev"
-install=
-subpackages="$pkgname-dev $pkgname-doc $pkgname-perl $pkgname-snmp $pkgname-curl
- $pkgname-write_http $pkgname-nginx $pkgname-apache $pkgname-postgresql
- $pkgname-mysql $pkgname-network"
-
-source="http://collectd.org/files/collectd-$pkgver.tar.bz2
- collectd.initd"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
-
- # we need -lm
- sed -i -e 's/^collectd_LDADD = \(.*\)/collectd_LDADD = -lm \1/' \
- -e 's/^collectd_nagios_LDADD = \(.*\)/collectd_nagios_LDADD = -lm \1/' src/Makefile.in
-
- # disable -Werror
- sed -i -e 's/-Werror//' src/owniptc/Makefile.in
-
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc/collectd \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstate=/var \
- || return 1
- make || return 1
- # disable network plugin by default since its in a subpackage
- sed -i -e 's/^LoadPlugin network/#LoadPlugin network/' \
- src/collectd.conf
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install
-
- find "$pkgdir" -name perllocal.pod -delete
- install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
-}
-
-perl() {
- pkgdesc="perl bindings to collectd"
- depends="perl"
- install -d "$subpkgdir"/usr/lib/ "$subpkgdir"/usr/share
- mv "$pkgdir"/usr/lib/perl* "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/share/perl* "$subpkgdir"/usr/share/
-}
-
-_plugin() {
- local mod=$1
- local desc=${2:-$mod}
- pkgdesc="$desc pluin for collectd"
- depends="collectd"
- install -d "$subpkgdir"/usr/lib/collectd
- mv "$pkgdir"/usr/lib/collectd/$mod.so "$subpkgdir"/usr/lib/collectd/
-}
-
-snmp() { _plugin snmp; }
-curl() { _plugin curl; }
-write_http() { _plugin write_http; }
-nginx() { _plugin nginx; }
-apache() { _plugin apache; }
-postgresql() { _plugin postgresql; }
-mysql() { _plugin mysql; }
-network() { _plugin network; }
-
-md5sums="5753496651c8c84afaea1fe290876bfc collectd-4.9.1.tar.bz2
-13a36ae2f92634b5619ab94224e1b77d collectd.initd"
diff --git a/testing/collectd/collectd.initd b/testing/collectd/collectd.initd
deleted file mode 100644
index de5705a032..0000000000
--- a/testing/collectd/collectd.initd
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/sbin/runscript
-
-DAEMON=/usr/sbin/collectd
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting collectd"
- start-stop-daemon --start --exec $DAEMON -- $collectd_options
- eend $?
-}
-
-stop () {
- ebegin "Stopping collectd"
- start-stop-daemon --stop --exec $DAEMON
- eend $?
-}
-