aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-11-12 14:44:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-12 15:12:54 +0000
commit959d90e891d4978c2627eb252511c85c0f3c726f (patch)
treec123b69b9fbde7d926250bb8716dfc3905d760b4 /testing
parent60b6ba6e58c8028e8025c790b062f7c2569674e0 (diff)
downloadaports-959d90e891d4978c2627eb252511c85c0f3c726f.tar.bz2
aports-959d90e891d4978c2627eb252511c85c0f3c726f.tar.xz
testing/mgba: rebuild against ffmpeg 4, disable python
disable python due to build failure
Diffstat (limited to 'testing')
-rw-r--r--testing/mgba/APKBUILD15
-rw-r--r--testing/mgba/mgba-qt5.11.patch35
2 files changed, 43 insertions, 7 deletions
diff --git a/testing/mgba/APKBUILD b/testing/mgba/APKBUILD
index 2b2d06fc17..c7f17f4e6e 100644
--- a/testing/mgba/APKBUILD
+++ b/testing/mgba/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Alexander Edland <alpine@ocv.me>
pkgname=mgba
pkgver=0.6.3
-pkgrel=1
+pkgrel=2
pkgdesc="Game Boy Advance Emulator"
url="https://github.com/mgba-emu/mgba"
arch="all !s390x"
@@ -11,12 +11,13 @@ makedepends="cmake qt5-qtmultimedia-dev qt5-qtbase-dev qt5-qttools-dev
sdl-dev libzip-dev zlib-dev libpng-dev ffmpeg-dev imagemagick-dev
libepoxy-dev cmocka-dev libedit-dev py3-virtualenv python3-dev"
checkdepends="py3-cffi py3-cached-property"
-subpackages="$pkgname-doc $pkgname-py:_py $pkgname-qt:_qt"
+subpackages="$pkgname-doc $pkgname-qt:_qt"
source="mgba-$pkgver.tar.gz::https://github.com/mgba-emu/mgba/archive/$pkgver.tar.gz
http://gbdev.gg8.se/files/roms/blargg-gb-tests/cpu_instrs.zip
test-py.sh
no-rpath.patch
python3.patch
+ mgba-qt5.11.patch
mgba-qt.desktop"
builddir="$srcdir/mgba-$pkgver"
@@ -33,7 +34,6 @@ build() {
-DCMAKE_INSTALL_LIBDIR:PATH=/usr/lib \
-DBUILD_TEST:BOOL=ON \
-DBUILD_SUITE:BOOL=ON \
- -DBUILD_PYTHON:BOOL=ON \
..
make
}
@@ -44,10 +44,10 @@ check() {
# test python bindings by executing an open source ROM
# for DMG-01 (OG gameboy) and exporting a png screenshot
- PYTHONPATH="$PWD/$(echo python/lib.linux-*-3.*)" \
- LD_LIBRARY_PATH="$builddir/build" \
- ZIPFILE="$srcdir/cpu_instrs.zip" \
- "$startdir/test-py.sh"
+# PYTHONPATH="$PWD/$(echo python/lib.linux-*-3.*)" \
+# LD_LIBRARY_PATH="$builddir/build" \
+# ZIPFILE="$srcdir/cpu_instrs.zip" \
+# "$startdir/test-py.sh"
}
package() {
@@ -92,4 +92,5 @@ ea4a1de976e2188c3720d7b8e6f75f67feaede37473826343f9b0a03fe76405e84305384ceee1bc5
239d985e6379495569bcc5c9fe15ab913585029d9979cc6b2cdd23ff49cb1426f9b90c763b3314cac888c599951e54c2584ee69280158b615aa64ad188f1e1ad test-py.sh
8fefd97e66b63bc660abab2a5d0f29b96b41022e12e53af9841c97dd8d74dddde9c1ac7b56a7f5d7346aa42671767ce3794ecccf66142262116e740a21f6ef03 no-rpath.patch
7e2ac69620f0118d429afbb6ae905be1e81c80c5eb83118b74ab65f3db81f25823098475d32add624e4424fdac0f882f18c4b42673719eb278160805330148c8 python3.patch
+eb3095f1cdde968bbde3c83c84fee9f773d138806c15302492e0d37fd67c13783dbd9d63b306d969ca444152e1e3d342ba59e160bfc78dc123d1fd1f3f90c19b mgba-qt5.11.patch
f77d1e3a35521f29e9caaebb6b010e497602a467963b95b155f67d39c129d8a1bd6acdbce1a10bf25e68ac38de0e4079deb92c710afccc8a2c4841820d3f9119 mgba-qt.desktop"
diff --git a/testing/mgba/mgba-qt5.11.patch b/testing/mgba/mgba-qt5.11.patch
new file mode 100644
index 0000000000..338bb50c8f
--- /dev/null
+++ b/testing/mgba/mgba-qt5.11.patch
@@ -0,0 +1,35 @@
+From 7f41dd354176b720c8e3310553c6b772278b9dca Mon Sep 17 00:00:00 2001
+From: Vicki Pfau <vi@endrift.com>
+Date: Fri, 25 May 2018 18:04:16 -0700
+Subject: [PATCH] Qt: Fix build with Qt 5.11
+
+---
+ src/platform/qt/LoadSaveState.cpp | 1 +
+ src/platform/qt/Window.h | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/src/platform/qt/LoadSaveState.cpp b/src/platform/qt/LoadSaveState.cpp
+index 538254ff6..d9db6a7d3 100644
+--- a/src/platform/qt/LoadSaveState.cpp
++++ b/src/platform/qt/LoadSaveState.cpp
+@@ -10,6 +10,7 @@
+ #include "GamepadButtonEvent.h"
+ #include "VFileDevice.h"
+
++#include <QAction>
+ #include <QDateTime>
+ #include <QKeyEvent>
+ #include <QPainter>
+diff --git a/src/platform/qt/Window.h b/src/platform/qt/Window.h
+index baca971ea..2d9d139cc 100644
+--- a/src/platform/qt/Window.h
++++ b/src/platform/qt/Window.h
+@@ -5,6 +5,7 @@
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+ #pragma once
+
++#include <QAction>
+ #include <QDateTime>
+ #include <QList>
+ #include <QMainWindow>
+