aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-02-09 14:31:37 +0100
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-02-09 14:31:47 +0100
commitbbe29b224c90849313f212e74f0c88afc88fda87 (patch)
treecbc12b2f5d53c2743bcfb604c1656e80679a7755 /testing
parent451d701692ebbb31b206fdf89d25c6699b8aba48 (diff)
downloadaports-bbe29b224c90849313f212e74f0c88afc88fda87.tar.bz2
aports-bbe29b224c90849313f212e74f0c88afc88fda87.tar.xz
testing/php-zend-opcache: PHP >=5.5 has built-in opcode caching by Zend
Diffstat (limited to 'testing')
-rw-r--r--testing/php-zend-opcache/APKBUILD39
-rw-r--r--testing/php-zend-opcache/opcache.ini11
2 files changed, 0 insertions, 50 deletions
diff --git a/testing/php-zend-opcache/APKBUILD b/testing/php-zend-opcache/APKBUILD
deleted file mode 100644
index 1401c2f6e3..0000000000
--- a/testing/php-zend-opcache/APKBUILD
+++ /dev/null
@@ -1,39 +0,0 @@
-# Contributor: V.Krishn <vkrishn4@gmail.com>
-# Maintainer:
-pkgname=php-zendopcache
-pkgver=7.0.1
-pkgrel=0
-pkgdesc="Zend OPcache for PHP"
-url="https://github.com/zend-dev/ZendOptimizerPlus"
-arch="all"
-license="PHP"
-depends="php"
-makedepends="php-dev autoconf pcre-dev"
-subpackages=""
-source="saveas-https://github.com/zend-dev/ZendOptimizerPlus/archive/v7.0.1.tar.gz/$pkgname-$pkgver.tar.gz
-opcache.ini"
-_builddir="$srcdir/ZendOptimizerPlus-$pkgver"
-
-build() {
- cd "$_builddir"
- phpize || return 1
- ./configure --enable-opcache \
- --with-php-config=/usr/bin/php-config
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make INSTALL_ROOT=$pkgdir install || return 1
- install -D -m644 "$srcdir"/opcache.ini "$pkgdir"/etc/php/conf.d/opcache.ini
- extension_dir=`grep '^extension_dir' /usr/bin/php-config | awk -F'=' '{print $2}' | replace "'" ""`
- sed -i -e "s|{{extension_dir}}|$extension_dir|" \
- "$pkgdir"/etc/php/conf.d/opcache.ini || return 1
-}
-
-md5sums="c5d41c2404916e5aaceff5c7f7d887ce php-zendopcache-7.0.1.tar.gz
-b80548491db141fb5d7a823445ec2ba9 opcache.ini"
-sha256sums="0c024bc21a0e8a0c5b786ad346bbbe503a10b2ba6892ee5aa729e227e7c0700e php-zendopcache-7.0.1.tar.gz
-31437112d2e8a5458bed5f582c552ad411c317b4a75459a7eded3c4d309d39f6 opcache.ini"
-sha512sums="6954d542b74c78c14ca95b6e27ba21b248c09273273dba3ff2d4805dfc8e9ecc829ef709ec70e5a25c034880a254f5702a65a0dd31b55fe25b1343d389d53374 php-zendopcache-7.0.1.tar.gz
-c0ee1cdb37bd505300d67e395a3de1ad5d8eb25868018a05ab4dafce742a6ace88d5b08646cd35488a0266bcacef8e35cc4486484f6e5f5bce32cb133377f4a8 opcache.ini"
diff --git a/testing/php-zend-opcache/opcache.ini b/testing/php-zend-opcache/opcache.ini
deleted file mode 100644
index a0f12025dd..0000000000
--- a/testing/php-zend-opcache/opcache.ini
+++ /dev/null
@@ -1,11 +0,0 @@
-[OPcache]
-;Recommended configuration options for best performance.
-;zend_extension="{{extension_dir}}/opcache.so"
-;opcache.enable=1
-;opcache.memory_consumption=128
-;opcache.interned_strings_buffer=8
-;opcache.max_accelerated_files=4000
-;opcache.revalidate_freq=60
-;opcache.fast_shutdown=1
-;opcache.enable_cli=1
-