aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-06-16 12:19:44 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-06-16 12:19:44 +0000
commitfd6f66ca788471a9446350261d7bd1b48af94388 (patch)
tree138ae7b14b43d295ff9605964d067df38f72de84 /testing
parentb0825c6fc161b4791934185ee28a681462adb6f7 (diff)
downloadaports-fd6f66ca788471a9446350261d7bd1b48af94388.tar.bz2
aports-fd6f66ca788471a9446350261d7bd1b48af94388.tar.xz
main/open-iscsi*: moved to main
Diffstat (limited to 'testing')
-rw-r--r--testing/open-iscsi-grsec/APKBUILD59
-rw-r--r--testing/open-iscsi-grsec/CVE-2009-1297.patch31
-rw-r--r--testing/open-iscsi-grsec/Makefile.kernel.patch11
-rw-r--r--testing/open-iscsi-grsec/open-iscsi-2.0.871-makefile-cleanup.patch33
-rw-r--r--testing/open-iscsi/APKBUILD49
-rw-r--r--testing/open-iscsi/CVE-2009-1297.patch31
-rw-r--r--testing/open-iscsi/iscsid.confd13
-rw-r--r--testing/open-iscsi/iscsid.initd124
-rw-r--r--testing/open-iscsi/open-iscsi-2.0.871-makefile-cleanup.patch33
9 files changed, 0 insertions, 384 deletions
diff --git a/testing/open-iscsi-grsec/APKBUILD b/testing/open-iscsi-grsec/APKBUILD
deleted file mode 100644
index 1bda4a7f2e..0000000000
--- a/testing/open-iscsi-grsec/APKBUILD
+++ /dev/null
@@ -1,59 +0,0 @@
-# Maintainer: Leonardo Arena <rnalrd@gmail.com>
-
-_flavor=grsec
-_realname=open-iscsi
-_realver=2.0-871
-# source the kernel version
-if [ -f ../../main/linux-$_flavor/APKBUILD ]; then
- . ../../main/linux-$_flavor/APKBUILD
-fi
-_kver=$pkgver
-_kernelver=$pkgver-r$pkgrel
-_abi_release=$pkgver-${_flavor}
-_kpkgrel=$pkgrel
-_ksrc=/usr/src/linux-headers-${_abi_release}
-
-_iscsiver=2.0-871
-
-pkgname=${_realname}-${_flavor}
-pkgver=$_kver
-_mypkgrel=0
-pkgrel=$(($_kpkgrel + $_mypkgrel))
-pkgdesc="$_flavor kernel modules for open-iscsi $_iscsiver"
-url="http://www.open-iscsi.org"
-license="GPL-2"
-depends="linux-${_flavor}=${_kernelver}"
-install=
-makedepends="linux-${_flavor}-dev=${_kernelver}"
-subpackages=
-source="http://www.open-iscsi.org/bits/$_realname-$_realver.tar.gz
- Makefile.kernel.patch
- CVE-2009-1297.patch
- open-iscsi-2.0.871-makefile-cleanup.patch"
-
-_builddir="$srcdir/$_realname-$_realver"
-
-prepare() {
- cd "$_builddir"
- patch -p0 < ../../CVE-2009-1297.patch || return 1
- patch -p1 < ../../open-iscsi-2.0.871-makefile-cleanup.patch || return 1
- patch -p2 < ../../Makefile.kernel.patch || return 1
-}
-
-build() {
- cd "$_builddir"
- unset ARCH
- make KSRC="$_ksrc" kernel || return 1
-}
-
-package() {
- cd "$_builddir"
- make KSRC="$_ksrc" DESTDIR="$pkgdir" \
- INSTALL_MOD_DIR="extra/drivers/scsi" \
- install_kernel
-}
-
-md5sums="0c403e8c9ad41607571ba0e6e8ff196e open-iscsi-2.0-871.tar.gz
-c5289f800ceebf59319fea284d476cdf Makefile.kernel.patch
-d1584790b4e12f087e60089880b53d2b CVE-2009-1297.patch
-734300d7b7590dc9ae9b2fb7f5b51bf0 open-iscsi-2.0.871-makefile-cleanup.patch"
diff --git a/testing/open-iscsi-grsec/CVE-2009-1297.patch b/testing/open-iscsi-grsec/CVE-2009-1297.patch
deleted file mode 100644
index d1728fff7e..0000000000
--- a/testing/open-iscsi-grsec/CVE-2009-1297.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- utils.orig/iscsi_discovery 2009-10-26 23:09:08.000000000 +0100
-+++ utils/iscsi_discovery 2009-10-26 23:11:56.000000000 +0100
-@@ -104,24 +104,22 @@
-
- connected=0
- discovered=0
-- df=/tmp/discovered.$$
-
- dbg "starting discovery to $ip"
-- iscsiadm -m discovery --type sendtargets --portal ${ip}:${port} > ${df}
-- while read portal target
-+ disc="$(iscsiadm -m discovery --type sendtargets --portal ${ip}:${port})"
-+ echo "${disc}" | while read portal target
- do
- portal=${portal%,*}
- select_transport
-- done < ${df}
-+ done
-
-- discovered=$(cat ${df} | wc -l)
-+ discovered=$(echo "${disc}" | wc -l)
- if [ ${discovered} = 0 ]; then
- echo "failed to discover targets at ${ip}"
- exit 2
- else
- echo "discovered ${discovered} targets at ${ip}"
- fi
-- /bin/rm -f ${df}
- }
-
- try_login()
diff --git a/testing/open-iscsi-grsec/Makefile.kernel.patch b/testing/open-iscsi-grsec/Makefile.kernel.patch
deleted file mode 100644
index 552e31b47f..0000000000
--- a/testing/open-iscsi-grsec/Makefile.kernel.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/open-iscsi-2.0-871/kernel/Makefile
-+++ Makefile
-@@ -102,6 +102,8 @@
-
- linux_2_6_30: $(unpatch_code)
-
-+linux_2_6_32: $(unpatch_code)
-+
-
- do_unpatch_code:
- echo "Un-patching source code for use with linux-2.6.14 and up ..."
diff --git a/testing/open-iscsi-grsec/open-iscsi-2.0.871-makefile-cleanup.patch b/testing/open-iscsi-grsec/open-iscsi-2.0.871-makefile-cleanup.patch
deleted file mode 100644
index 6ca2a4eaba..0000000000
--- a/testing/open-iscsi-grsec/open-iscsi-2.0.871-makefile-cleanup.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Nuar open-iscsi-2.0-871.orig/usr/Makefile open-iscsi-2.0-871/usr/Makefile
---- open-iscsi-2.0-871.orig/usr/Makefile 2009-07-10 20:55:58.000000000 -0700
-+++ open-iscsi-2.0-871/usr/Makefile 2009-11-12 00:58:16.467960344 -0800
-@@ -48,14 +48,14 @@
- all: $(PROGRAMS)
-
- iscsid: $(COMMON_SRCS) $(IPC_OBJ) $(INITIATOR_SRCS) iscsid.o
-- $(CC) $(CFLAGS) $^ -o $@
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
-
- iscsiadm: $(COMMON_SRCS) $(FW_BOOT_SRCS) strings.o discovery.o iscsiadm.o
-- $(CC) $(CFLAGS) $^ -o $@
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
-
- iscsistart: $(IPC_OBJ) $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(FW_BOOT_SRCS) \
- iscsistart.o statics.o
-- $(CC) $(CFLAGS) -static $^ -o $@
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
- clean:
- rm -f *.o $(PROGRAMS) .depend $(LIBSYS)
-
-diff -Nuar open-iscsi-2.0-871.orig/utils/Makefile open-iscsi-2.0-871/utils/Makefile
---- open-iscsi-2.0-871.orig/utils/Makefile 2009-07-10 20:55:58.000000000 -0700
-+++ open-iscsi-2.0-871/utils/Makefile 2009-11-12 00:58:56.404623435 -0800
-@@ -6,7 +6,7 @@
- all: $(PROGRAMS)
-
- iscsi-iname: md5.o iscsi-iname.o
-- $(CC) $(CFLAGS) $^ $(DBM_LIB) -o $@
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(DBM_LIB) $^
-
- clean:
- rm -f *.o $(PROGRAMS) .depend
diff --git a/testing/open-iscsi/APKBUILD b/testing/open-iscsi/APKBUILD
deleted file mode 100644
index 37d5f37409..0000000000
--- a/testing/open-iscsi/APKBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# Maintainer: Leonardo Arena <rnalrd@gmail.com>
-pkgname=open-iscsi
-pkgver=2.0.871
-_realver=2.0-871
-pkgrel=3
-pkgdesc="High performance, transport independent, multi-platform iSCSI initiator"
-url="http://www.open-iscsi.org"
-license="GPL-2"
-depends=
-makedepends=
-install=""
-subpackages="$pkgname-doc"
-source="http://www.open-iscsi.org/bits/$pkgname-$_realver.tar.gz
- CVE-2009-1297.patch
- open-iscsi-2.0.871-makefile-cleanup.patch
- iscsid.initd
- iscsid.confd"
-
-_builddir="$srcdir"/$pkgname-$_realver
-
-prepare() {
- cd "$_builddir"
- patch -p0 < ../../CVE-2009-1297.patch || return 1
- patch -p1 < ../../open-iscsi-2.0.871-makefile-cleanup.patch || return 1
-}
-
-build() {
- cd "$_builddir"
- make user || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install_user
- mkdir -p $pkgdir/usr/bin
- mkdir -p $pkgdir/usr/sbin
- mv $pkgdir/sbin/iscsi-iname $pkgdir/usr/bin
- mv $pkgdir/sbin/iscsi_discovery $pkgdir/usr/bin
- mv $pkgdir/sbin/iscsiadm $pkgdir/usr/bin
- mv $pkgdir/sbin/iscsid $pkgdir/usr/sbin
- install -Dm755 ../../iscsid.initd "$pkgdir"/etc/init.d/iscsid
- install -Dm644 ../../iscsid.confd "$pkgdir"/etc/conf.d/iscsid
-}
-
-md5sums="0c403e8c9ad41607571ba0e6e8ff196e open-iscsi-2.0-871.tar.gz
-d1584790b4e12f087e60089880b53d2b CVE-2009-1297.patch
-734300d7b7590dc9ae9b2fb7f5b51bf0 open-iscsi-2.0.871-makefile-cleanup.patch
-3e89cb86395756dafebc4f1490f0de10 iscsid.initd
-b762b687d4628791b4362df22cf22d34 iscsid.confd"
diff --git a/testing/open-iscsi/CVE-2009-1297.patch b/testing/open-iscsi/CVE-2009-1297.patch
deleted file mode 100644
index d1728fff7e..0000000000
--- a/testing/open-iscsi/CVE-2009-1297.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- utils.orig/iscsi_discovery 2009-10-26 23:09:08.000000000 +0100
-+++ utils/iscsi_discovery 2009-10-26 23:11:56.000000000 +0100
-@@ -104,24 +104,22 @@
-
- connected=0
- discovered=0
-- df=/tmp/discovered.$$
-
- dbg "starting discovery to $ip"
-- iscsiadm -m discovery --type sendtargets --portal ${ip}:${port} > ${df}
-- while read portal target
-+ disc="$(iscsiadm -m discovery --type sendtargets --portal ${ip}:${port})"
-+ echo "${disc}" | while read portal target
- do
- portal=${portal%,*}
- select_transport
-- done < ${df}
-+ done
-
-- discovered=$(cat ${df} | wc -l)
-+ discovered=$(echo "${disc}" | wc -l)
- if [ ${discovered} = 0 ]; then
- echo "failed to discover targets at ${ip}"
- exit 2
- else
- echo "discovered ${discovered} targets at ${ip}"
- fi
-- /bin/rm -f ${df}
- }
-
- try_login()
diff --git a/testing/open-iscsi/iscsid.confd b/testing/open-iscsi/iscsid.confd
deleted file mode 100644
index 1c4cc40542..0000000000
--- a/testing/open-iscsi/iscsid.confd
+++ /dev/null
@@ -1,13 +0,0 @@
-# /etc/conf.d/iscsid
-
-# config file to use
-CONFIG_FILE=/etc/iscsi/iscsid.conf
-
-# you need to specify an initiatorname in the file
-INITIATORNAME_FILE=/etc/iscsi/initiatorname.iscsi
-
-# options to pass to iscsid
-OPTS="-i ${INITIATORNAME_FILE}"
-
-# Start automatic targets when iscsid is started
-AUTOSTARTTARGETS="yes"
diff --git a/testing/open-iscsi/iscsid.initd b/testing/open-iscsi/iscsid.initd
deleted file mode 100644
index 572b0a6ae5..0000000000
--- a/testing/open-iscsi/iscsid.initd
+++ /dev/null
@@ -1,124 +0,0 @@
-#!/sbin/runscript
-
-opts="${opts} starttargets stoptargets restarttargets"
-
-depend() {
- after modules
- use net
-}
-
-checkconfig() {
- if [ ! -e /etc/conf.d/${SVCNAME} ]; then
- eerror "Config file /etc/conf.d/${SVCNAME} does not exist!"
- return 1
- fi
- if [ ! -e "${CONFIG_FILE}" ]; then
- eerror "Config file ${CONFIG_FILE} does not exist!"
- return 1
- fi
- if [ ! -e ${INITIATORNAME_FILE} ] || [ ! "$(grep "^InitiatorName=iqn\." ${INITIATORNAME_FILE})" ]; then
- ewarn "${INITIATORNAME_FILE} should contain a string with your initiatior name."
- IQN=iqn.$(date +%Y-%m).$(hostname -f | awk 'BEGIN { FS=".";}{x=NF; while (x>0) {printf $x ;x--; if (x>0) printf ".";} print ""}'):openiscsi
- IQN=${IQN}-$(echo ${RANDOM}${RANDOM}${RANDOM}${RANDOM}${RANDOM} | md5sum | sed -e "s/\(.*\) -/\1/g" -e 's/ //g')
- ebegin "Creating InitiatorName ${IQN} in ${INITIATORNAME_FILE}"
- echo "InitiatorName=${IQN}" >> "${INITIATORNAME_FILE}"
- eend $?
- fi
-}
-
-do_modules() {
- msg="$1"
- shift
- modules="${1}"
- shift
- modopts="$@"
- for m in ${modules}
- do
- if [ -n "$(find /lib/modules/`uname -r` | grep ${m})" ]
- then
- ebegin "${msg} ${m}"
- modprobe ${modopts} ${m}
- ret=$?
- eend ${ret}
- if [ ${ret} -ne 0 ]; then
- return ${ret}
- fi
- else
- ebegin "${msg} ${m}: not found"
- return 1
- fi
- done
- return 0
-}
-
-start() {
- ebegin "Checking open-iSCSI configuration"
- checkconfig
- ret=$?
- if [ $ret -ne 0 ]; then
- eend 1
- return 1
- fi
- ebegin "Loading iSCSI modules"
- do_modules 'Loading' 'libiscsi scsi_transport_iscsi iscsi_tcp'
- ret=$?
- if [ $ret -ne 0 ]; then
- eend 1
- return 1
- fi
-
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --quiet --exec /usr/sbin/iscsid -- ${OPTS}
- ret=$?
- if [ $ret -ne 0 ]; then
- eend $?
- return $?
- fi
-
- # Start automatic targets when iscsid is started
- if [ "${AUTOSTARTTARGETS}" = "yes" ]; then
- starttargets
- return $?
- fi
- return 0
-}
-
-stop() {
- stoptargets
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --signal HUP --stop --quiet --exec /usr/sbin/iscsid #--pidfile $PID_FILE
- eend $?
-
- # ugly, but pid file is not removed by iscsid
- rm -f $PID_FILE
-
- do_modules 'Removing iSCSI modules' 'iscsi_tcp scsi_transport_iscsi libiscsi' '-r'
- eend $?
-}
-
-starttargets() {
- ebegin "Setting up iSCSI targets"
- /usr/bin/iscsiadm -m node --loginall=automatic
- ret=$?
- eend $ret
- return $ret
-}
-
-stoptargets() {
- ebegin "Disconnecting iSCSI targets"
- sync
- /usr/bin/iscsiadm -m node --logoutall=all
- ret=$?
- eend $ret
- return $ret
-}
-
-restarttargets() {
- stoptargets
- starttargets
-}
-
-status() {
- ebegin "Showing current active iSCSI sessions"
- /usr/bin/iscsiadm -m session
-}
diff --git a/testing/open-iscsi/open-iscsi-2.0.871-makefile-cleanup.patch b/testing/open-iscsi/open-iscsi-2.0.871-makefile-cleanup.patch
deleted file mode 100644
index 6ca2a4eaba..0000000000
--- a/testing/open-iscsi/open-iscsi-2.0.871-makefile-cleanup.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Nuar open-iscsi-2.0-871.orig/usr/Makefile open-iscsi-2.0-871/usr/Makefile
---- open-iscsi-2.0-871.orig/usr/Makefile 2009-07-10 20:55:58.000000000 -0700
-+++ open-iscsi-2.0-871/usr/Makefile 2009-11-12 00:58:16.467960344 -0800
-@@ -48,14 +48,14 @@
- all: $(PROGRAMS)
-
- iscsid: $(COMMON_SRCS) $(IPC_OBJ) $(INITIATOR_SRCS) iscsid.o
-- $(CC) $(CFLAGS) $^ -o $@
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
-
- iscsiadm: $(COMMON_SRCS) $(FW_BOOT_SRCS) strings.o discovery.o iscsiadm.o
-- $(CC) $(CFLAGS) $^ -o $@
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
-
- iscsistart: $(IPC_OBJ) $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(FW_BOOT_SRCS) \
- iscsistart.o statics.o
-- $(CC) $(CFLAGS) -static $^ -o $@
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
- clean:
- rm -f *.o $(PROGRAMS) .depend $(LIBSYS)
-
-diff -Nuar open-iscsi-2.0-871.orig/utils/Makefile open-iscsi-2.0-871/utils/Makefile
---- open-iscsi-2.0-871.orig/utils/Makefile 2009-07-10 20:55:58.000000000 -0700
-+++ open-iscsi-2.0-871/utils/Makefile 2009-11-12 00:58:56.404623435 -0800
-@@ -6,7 +6,7 @@
- all: $(PROGRAMS)
-
- iscsi-iname: md5.o iscsi-iname.o
-- $(CC) $(CFLAGS) $^ $(DBM_LIB) -o $@
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(DBM_LIB) $^
-
- clean:
- rm -f *.o $(PROGRAMS) .depend