aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-09-29 20:53:51 +0200
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-09-29 21:20:07 +0200
commit36f417888fe678fb950526840471e5d6b7c9d1a4 (patch)
tree7679a1cb4bcc4b8ad1e547fff3f7a1123b7f70c5 /testing
parent8518e6ebd46b7e03a7e92cce84852a4fa965db43 (diff)
downloadaports-36f417888fe678fb950526840471e5d6b7c9d1a4.tar.bz2
aports-36f417888fe678fb950526840471e5d6b7c9d1a4.tar.xz
testing/bam: new aport
Bam is a lightweight build system that uses Lua. It's used by Teeworlds, an incoming aport.
Diffstat (limited to 'testing')
-rw-r--r--testing/bam/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/bam/APKBUILD b/testing/bam/APKBUILD
new file mode 100644
index 0000000000..7a86d2fb78
--- /dev/null
+++ b/testing/bam/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer:
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=bam
+pkgver=0.4.0
+pkgrel=0
+pkgdesc='Fast and flexible build system using Lua'
+arch=all
+url=http://github.com/matricks/bam
+license='ZLIB'
+source="https://github.com/downloads/matricks/bam/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ sh make_unix.sh || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ install -Dm755 bam "$pkgdir"/usr/bin/bam || return 1
+ install -Dm755 license.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE \
+ || return 1
+}
+
+md5sums="2f8e8336b8884110e8a355b12c9fa58a bam-0.4.0.tar.gz"
+sha256sums="5e4e4920b4d265da582f66774e9b1ec8ddfbe75ddc028fba86c12f686ea18db3 bam-0.4.0.tar.gz"
+sha512sums="c599cdf3618d317a5d304febd2e59d1116fc5819cdaf49969fdc25f88ed8f3e25831861c0c7fea05059d8af7085b654a7732bd89086bc166661b932d168ee2ca bam-0.4.0.tar.gz"