aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-06-22 07:52:49 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-06-22 07:52:49 -0500
commit69537c3b22faa447175ea12224b6a94bc49704c8 (patch)
tree792999be6b3fc294cac8909b0484198d2b9f075c /testing
parent747733601de5b58bcc18e0748707e49257815f75 (diff)
downloadaports-69537c3b22faa447175ea12224b6a94bc49704c8.tar.bz2
aports-69537c3b22faa447175ea12224b6a94bc49704c8.tar.xz
testing/linux-pam: override default pam configuration
Diffstat (limited to 'testing')
-rw-r--r--testing/linux-pam/APKBUILD12
-rw-r--r--testing/linux-pam/other.pamd11
2 files changed, 20 insertions, 3 deletions
diff --git a/testing/linux-pam/APKBUILD b/testing/linux-pam/APKBUILD
index 4b7ecda3bd..dc0f76a0e5 100644
--- a/testing/linux-pam/APKBUILD
+++ b/testing/linux-pam/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=linux-pam
pkgver=1.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="pluggable authentication modules for linux"
url="http://www.kernel.org/pub/linux/libs/pam"
arch="all"
@@ -13,7 +13,8 @@ makedepends="$depends_dev bison flex"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-$pkgver.tar.bz2
- linux-pam-innetgr.patch"
+ linux-pam-innetgr.patch
+ other.pamd"
_builddir="$srcdir"/Linux-PAM-$pkgver
prepare() {
@@ -42,7 +43,12 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
+
+ # do not install pam.d files bundled with the source, they could be broken
+ rm -rf "$pkgdir"/etc/pam.d/*
+ cp "$srcdir"/other.pamd "$pkgdir"/etc/pam.d
}
md5sums="6db7fcb5db6253350e3a4648ceac40e7 Linux-PAM-1.1.3.tar.bz2
-c309401e103cc86e8b25557ff3eb0b53 linux-pam-innetgr.patch"
+c309401e103cc86e8b25557ff3eb0b53 linux-pam-innetgr.patch
+20ed7aa9c65942e4020a891b06ee5b76 other.pamd"
diff --git a/testing/linux-pam/other.pamd b/testing/linux-pam/other.pamd
new file mode 100644
index 0000000000..4912718496
--- /dev/null
+++ b/testing/linux-pam/other.pamd
@@ -0,0 +1,11 @@
+# basic PAM configuration for Alpine.
+
+auth required pam_env.so
+auth required pam_unix.so nullok_secure
+
+account required pam_unix.so
+
+password required pam_unix.so nullok obscure md5 sha512
+
+session required pam_limits.so
+session required pam_unix.so