aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-06 19:40:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-06 19:41:05 +0000
commit8d36e7d94c0c940d7eac811b442e210221e1275f (patch)
treef4ed6a9f8c69bd197613da3b789d9fbe6f6104c5 /testing
parentdbe47b47d727acd5341ecd135ef944399d62c9d0 (diff)
downloadaports-8d36e7d94c0c940d7eac811b442e210221e1275f.tar.bz2
aports-8d36e7d94c0c940d7eac811b442e210221e1275f.tar.xz
main/bluez: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/bluez/APKBUILD78
-rw-r--r--testing/bluez/bluetooth-conf.d7
-rw-r--r--testing/bluez/bluetooth-init.d31
-rw-r--r--testing/bluez/bluetooth.confd7
-rw-r--r--testing/bluez/bluetooth.initd32
5 files changed, 0 insertions, 155 deletions
diff --git a/testing/bluez/APKBUILD b/testing/bluez/APKBUILD
deleted file mode 100644
index 0e08eb9b17..0000000000
--- a/testing/bluez/APKBUILD
+++ /dev/null
@@ -1,78 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=bluez
-pkgver=4.91
-pkgrel=0
-pkgdesc="Tools for the Bluetooth protocol stack"
-url="http://www.bluez.org/"
-arch="all"
-license="GPL2"
-depends="consolekit"
-makedepends="dbus-dev gst-plugins-base-dev alsa-lib-dev libusb-compat-dev
- libnl-dev consolekit-dev"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-alsa
- $pkgname-cups $pkgname-gstreamer"
-source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2
- bluetooth.initd
- bluetooth.confd
- "
-
-_builddir="$srcdir"/$pkgname-$pkgver
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --libexecdir=/lib \
- --mandir=/usr/share/man \
- --enable-gstreamer \
- --enable-alsa \
- --enable-usb \
- --enable-tools \
- --enable-bccmd \
- --enable-hid2hci \
- --enable-dfutool \
- --enable-hidd \
- --enable-pand \
- --enable-dund \
- --enable-cups \
- --enable-configfiles \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make install DESTDIR="$pkgdir"
- install -Dm755 "$srcdir"/bluetooth.initd "$pkgdir"/etc/init.d/bluetooth
- install -Dm644 "$srcdir"/bluetooth.confd "$pkgdir"/etc/conf.d/bluetooth
- install -Dm755 test/simple-agent "$pkgdir"/usr/bin/bluez-simple-agent
-}
-
-libs() {
- pkgdesc="Libraries for Bluetooth protocol stack"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libbluetooth.so.* "$subpkgdir"/usr/lib/
-}
-
-alsa() {
- pkgdesc="Bluez plugin for ALSA"
- mkdir -p "$subpkgdir"/usr/share "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/share/alsa* "$subpkgdir"/usr/share/ || return 1
- mv "$pkgdir"/usr/lib/alsa* "$subpkgdir"/usr/lib/
-}
-
-cups() {
- pkgdesc="Bluez backend for CUPS"
- mkdir -p "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/lib/cups "$subpkgdir"/usr/lib/
-}
-
-gstreamer() {
- pkgdesc="Bluez plugin for gstreamer"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/gstreamer* \
- "$subpkgdir"/usr/lib/
-}
-md5sums="0a293ae6cf0d0e0bdd74fb65e655842a bluez-4.91.tar.bz2
-c511078403d7d27673581a8bb468b90b bluetooth.initd
-a159d897a057f4675548327329c4cc22 bluetooth.confd"
diff --git a/testing/bluez/bluetooth-conf.d b/testing/bluez/bluetooth-conf.d
deleted file mode 100644
index b0cc744415..0000000000
--- a/testing/bluez/bluetooth-conf.d
+++ /dev/null
@@ -1,7 +0,0 @@
-# Bluetooth configuraton file
-
-# Bind rfcomm devices (allowed values are "true" and "false")
-RFCOMM_ENABLE=true
-
-# Config file for rfcomm
-RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
diff --git a/testing/bluez/bluetooth-init.d b/testing/bluez/bluetooth-init.d
deleted file mode 100644
index 111902aaeb..0000000000
--- a/testing/bluez/bluetooth-init.d
+++ /dev/null
@@ -1,31 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/files/4.60/bluetooth-init.d,v 1.1 2010/02/01 19:47:46 pacho Exp $
-
-depend() {
- after coldplug
- need dbus localmount
-}
-
-start() {
- ebegin "Starting Bluetooth"
-
- udevadm trigger --subsystem-match=bluetooth
- eend $?
-
- if [ "${RFCOMM_ENABLE}" = "true" -a -x /usr/bin/rfcomm ]; then
- if [ -f "${RFCOMM_CONFIG}" ]; then
- ebegin " Starting rfcomm"
- /usr/bin/rfcomm -f "${RFCOMM_CONFIG}" bind all
- eend $?
- else
- ewarn "Not enabling rfcomm because RFCOMM_CONFIG does not exists"
- fi
- fi
-}
-
-stop() {
- ebegin "Shutting down Bluetooth"
- eend 0
-}
diff --git a/testing/bluez/bluetooth.confd b/testing/bluez/bluetooth.confd
deleted file mode 100644
index b0cc744415..0000000000
--- a/testing/bluez/bluetooth.confd
+++ /dev/null
@@ -1,7 +0,0 @@
-# Bluetooth configuraton file
-
-# Bind rfcomm devices (allowed values are "true" and "false")
-RFCOMM_ENABLE=true
-
-# Config file for rfcomm
-RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
diff --git a/testing/bluez/bluetooth.initd b/testing/bluez/bluetooth.initd
deleted file mode 100644
index ef25720bf6..0000000000
--- a/testing/bluez/bluetooth.initd
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/files/4.60/bluetooth-init.d,v 1.1 2010/02/01 19:47:46 pacho Exp $
-
-depend() {
- after coldplug
- need dbus localmount
-}
-
-start() {
- ebegin "Starting Bluetooth"
-
- if [ -x /sbin/udevadm ]; then
- udevadm trigger --subsystem-match=bluetooth --action=add
- eend $?
- fi
-
- if [ "${RFCOMM_ENABLE}" = "true" -a -x /usr/bin/rfcomm ]; then
- if [ -f "${RFCOMM_CONFIG}" ]; then
- /usr/bin/rfcomm -f "${RFCOMM_CONFIG}" bind all
- else
- ewarn "Not enabling rfcomm because RFCOMM_CONFIG does not exists"
- fi
- fi
- eend $?
-}
-
-stop() {
- ebegin "Shutting down Bluetooth"
- eend 0
-}