aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-10-02 14:39:41 +0300
committerTimo Teräs <timo.teras@iki.fi>2014-10-02 14:40:58 +0300
commit8b4939898592ffa22fb2ea436aa73258ada75fad (patch)
treefa6d737bda44529de2a08c72a78bac273da3a8d4 /testing
parent6e3ddd38a5e9950b23bd129b6c80bfbe56871c52 (diff)
downloadaports-8b4939898592ffa22fb2ea436aa73258ada75fad.tar.bz2
aports-8b4939898592ffa22fb2ea436aa73258ada75fad.tar.xz
testing/openvswitch: fix the stacksize patch
Remember to pass the attributes to pthread_create(), duh.
Diffstat (limited to 'testing')
-rw-r--r--testing/openvswitch/0001-ovs-thread-Set-stacksize-to-1M.patch19
-rw-r--r--testing/openvswitch/APKBUILD8
2 files changed, 12 insertions, 15 deletions
diff --git a/testing/openvswitch/0001-ovs-thread-Set-stacksize-to-1M.patch b/testing/openvswitch/0001-ovs-thread-Set-stacksize-to-1M.patch
index 57b1796c30..2a7ae57b30 100644
--- a/testing/openvswitch/0001-ovs-thread-Set-stacksize-to-1M.patch
+++ b/testing/openvswitch/0001-ovs-thread-Set-stacksize-to-1M.patch
@@ -14,11 +14,10 @@ Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
lib/ovs-thread.c | 15 +++++++++++++++
1 file changed, 15 insertions(+)
-diff --git a/lib/ovs-thread.c b/lib/ovs-thread.c
-index fe6fb43..8013220 100644
---- a/lib/ovs-thread.c
-+++ b/lib/ovs-thread.c
-@@ -32,6 +32,9 @@
+diff -ru openvswitch-2.3.0.orig/lib/ovs-thread.c openvswitch-2.3.0/lib/ovs-thread.c
+--- openvswitch-2.3.0.orig/lib/ovs-thread.c 2014-10-02 14:37:47.196714056 -0300
++++ openvswitch-2.3.0/lib/ovs-thread.c 2014-10-02 14:38:10.826714288 -0300
+@@ -28,6 +28,9 @@
#include "socket-util.h"
#include "util.h"
@@ -28,7 +27,7 @@ index fe6fb43..8013220 100644
#ifdef __CHECKER__
/* Omit the definitions in this file because they are somewhat difficult to
* write without prompting "sparse" complaints, without ugliness or
-@@ -339,6 +342,7 @@ ovs_thread_create(const char *name, void *(*start)(void *), void *arg)
+@@ -329,6 +332,7 @@
{
struct ovsthread_aux *aux;
pthread_t thread;
@@ -36,10 +35,11 @@ index fe6fb43..8013220 100644
int error;
forbid_forking("multiple threads exist");
-@@ -350,10 +354,21 @@ ovs_thread_create(const char *name, void *(*start)(void *), void *arg)
+@@ -340,10 +344,21 @@
aux->arg = arg;
ovs_strlcpy(aux->name, name, sizeof aux->name);
+- error = pthread_create(&thread, NULL, ovsthread_wrapper, aux);
+ error = pthread_attr_init(&attr);
+ if (error) {
+ ovs_abort(error, "pthread_attr_init failed");
@@ -49,7 +49,7 @@ index fe6fb43..8013220 100644
+ ovs_abort(error, "pthread_attr_setstacksize failed");
+ }
+
- error = pthread_create(&thread, NULL, ovsthread_wrapper, aux);
++ error = pthread_create(&thread, &attr, ovsthread_wrapper, aux);
if (error) {
ovs_abort(error, "pthread_create failed");
}
@@ -58,6 +58,3 @@ index fe6fb43..8013220 100644
return thread;
}
---
-2.1.0
-
diff --git a/testing/openvswitch/APKBUILD b/testing/openvswitch/APKBUILD
index 0e76c02cee..9cc2dabfa8 100644
--- a/testing/openvswitch/APKBUILD
+++ b/testing/openvswitch/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=openvswitch
pkgver=2.3.0
-pkgrel=3
+pkgrel=4
pkgdesc="A production quality, multilayer virtual switch - includes Kernel Modules for best performance."
url="http://openvswitch.org/"
arch="all"
@@ -79,7 +79,7 @@ f10a8ac784654bec359bda52779f16fe ovsdb-server.confd
2d1e0111ea62779f49e14d62678294b2 ovs-vswitchd.confd
ae128e5c349710c0fb3849b2d3b3aa40 ovs-modules.initd
6e17032bd6e7caf6e6e844b5a84d7080 musl-if_packet.patch
-2f993e1d2f013a7c53ab634bb05ecbe9 0001-ovs-thread-Set-stacksize-to-1M.patch"
+59fa9a6d293a25571562a5190ae559f2 0001-ovs-thread-Set-stacksize-to-1M.patch"
sha256sums="011052645cd4c7afee2732e87d45e589a0540ac7b7523027d3be2d7c7db7c899 openvswitch-2.3.0.tar.gz
b58a4bdab9ca035a9271067edadb19598985c55820f020d8aefe71b516a3e7f6 ovsdb-server.initd
d0d8a6a7256f4cc47ab1b9f9f7657202388133bcfff3668e7c1d4adbcc572261 ovsdb-server.confd
@@ -87,7 +87,7 @@ d0d8a6a7256f4cc47ab1b9f9f7657202388133bcfff3668e7c1d4adbcc572261 ovsdb-server.c
cc189d5ca24708ff775a4de312df3f611c65714724b8901ec6527c9e3f22e14a ovs-vswitchd.confd
94f4dba5e2ddedb9c91911b02dbfc41a5114e8a5066a8db3ef4444ebb5400173 ovs-modules.initd
d0e9e3e30b2943b10e7efa59c41c3bf8d5b599d55fc99198146bf4761df4d8ae musl-if_packet.patch
-7f0381c6d17a625d904fa84408e77270471935842111a134aa9ddb830e2d86ff 0001-ovs-thread-Set-stacksize-to-1M.patch"
+faf997814e89b0b5948c06050ef38051f0bc6b108958f76313263f77a724906c 0001-ovs-thread-Set-stacksize-to-1M.patch"
sha512sums="f3a665bc84d8a6e282928db61ae648a826f273e44e34311a60e6f0e74a6ab10c8410cb374f0ce80abe7c58b9559a97388cdbfe2ef28ac4bedd2f5e52b3cd6ed1 openvswitch-2.3.0.tar.gz
6d660c986666b3f3b052d5ff6a8555c8bf5234fee8c4740d70974b1ac00ee2a0711e931494556290e18fce820ce8f2d4a5f25e40e9c863da9b639c18c0515763 ovsdb-server.initd
b1588d076bbfc7ef2dd46fce8e46186f40cbbc4667697f7ac13ddc68e34568fdab315fde47838de7f6d32916853190336cfe3735f672ad7cb624ae14dbff55a5 ovsdb-server.confd
@@ -95,4 +95,4 @@ b1588d076bbfc7ef2dd46fce8e46186f40cbbc4667697f7ac13ddc68e34568fdab315fde47838de7
346aea099f51707d2b4fc9fdc8c1502582723fb4e00c4d5d1624b0378c94dfb76674fa95e2af894f36169df52109dbe441ee6a45aa744584d9e4c74d15a46c1d ovs-vswitchd.confd
e1f88ff11cd1d5a4025626acad49411e8a2d5d7caa20d0a63ef0422a9b1bb55b070843327d8bb209e1e915d2a3f1c3bcae911acf40e0a419bc6cce6250239232 ovs-modules.initd
1ebfb2629081cc0b34383e6c2f163f3c1d43da3a399b8ba8745871b77029d3b8fc21a287ff859a6a9cca2cb4885715458d4e4086cb6c17765ff7c898d4004850 musl-if_packet.patch
-0cd029f9712f4ae08af07b144f273df1b7d7641f57f97f94a48a990d5ffa6a289b9235d7744690678e7b2f4fdb7b7fd915b84dac46b927f48575a7f820515009 0001-ovs-thread-Set-stacksize-to-1M.patch"
+5fed04e68b58ab322154fa1cc4c4b63b08c22ed41f0b7713dbe8437f7cb4e9fd93c8aba524c2e5a46bba956da9439f5bfe5ba6fcdff2b98fa9bbcc748c5b64db 0001-ovs-thread-Set-stacksize-to-1M.patch"