aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-10 14:51:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-10 14:59:57 +0000
commitb4d995dcb961e5376db5844c581bbca3a4af7b41 (patch)
treeaa7b1b015d928e9d51d06e8053c25285d7aff518 /testing
parent28fdc5d08e4d6e4230ffe276a166c4b1dbba7c12 (diff)
downloadaports-b4d995dcb961e5376db5844c581bbca3a4af7b41.tar.bz2
aports-b4d995dcb961e5376db5844c581bbca3a4af7b41.tar.xz
main/raptor2: moved to main
Diffstat (limited to 'testing')
-rw-r--r--testing/raptor2/APKBUILD47
-rw-r--r--testing/raptor2/raptor-curl.patch12
2 files changed, 0 insertions, 59 deletions
diff --git a/testing/raptor2/APKBUILD b/testing/raptor2/APKBUILD
deleted file mode 100644
index 3d0f27e853..0000000000
--- a/testing/raptor2/APKBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=raptor2
-pkgver=2.0.14
-pkgrel=0
-pkgdesc="RDF parser toolkit for Redland"
-url="http://www.librdf.org/raptor"
-arch="all"
-license="GPL"
-depends=
-depends_dev="curl-dev libxml2-dev libxslt-dev yajl-dev"
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://download.librdf.org/source/raptor2-$pkgver.tar.gz"
-
-_builddir="$srcdir"/raptor2-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- rm "$pkgdir"/usr/lib/*.la
-}
-
-md5sums="d3e0b43866197a5367b781b25510f728 raptor2-2.0.14.tar.gz"
-sha256sums="cb447b7c684cbe60f1266d622691fd20fdcf7b91f4a470c6de5fc8e8961df1b2 raptor2-2.0.14.tar.gz"
-sha512sums="399e23f2c549df8f1d709d67129d3fcf7899a8cdcdd8071c165f2b4106f397cce05fc69a6d7b176857011bf95723c0909b6510eded12f82217f89925bc1ba7c2 raptor2-2.0.14.tar.gz"
diff --git a/testing/raptor2/raptor-curl.patch b/testing/raptor2/raptor-curl.patch
deleted file mode 100644
index e47a496c4c..0000000000
--- a/testing/raptor2/raptor-curl.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/raptor_internal.h b/src/raptor_internal.h
-index f7944db..d9c2068 100644
---- a/src/raptor_internal.h
-+++ b/src/raptor_internal.h
-@@ -852,7 +852,6 @@ int raptor_utf8_is_nfc(const unsigned char *input, size_t length);
-
- #ifdef RAPTOR_WWW_LIBCURL
- #include <curl/curl.h>
--#include <curl/types.h>
- #include <curl/easy.h>
- #endif
-