aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorPaul Onyschuk <blink@bojary.koba.pl>2011-08-03 16:13:22 +0200
committerPaul Onyschuk <blink@bojary.koba.pl>2011-08-03 16:13:22 +0200
commit006ce14a9a66c564def5d6a4dc6b6f8d7c70bc39 (patch)
tree8dc78a86e06a2d993de97bb166e70dac60b324f1 /testing
parentaaaafe88b73fec85efc1c1fd7aec13ade7b82120 (diff)
parentc504465e61a866c92c41e38ccc888d58abc73d09 (diff)
downloadaports-006ce14a9a66c564def5d6a4dc6b6f8d7c70bc39.tar.bz2
aports-006ce14a9a66c564def5d6a4dc6b6f8d7c70bc39.tar.xz
Merge remote-tracking branch 'upstream/master'
Diffstat (limited to 'testing')
-rw-r--r--testing/gcc/APKBUILD6
-rw-r--r--testing/graphviz/0001-clone-nameclash.patch87
-rw-r--r--testing/graphviz/APKBUILD101
-rw-r--r--testing/joe/APKBUILD40
-rw-r--r--testing/libc6/APKBUILD117
-rw-r--r--testing/libc6/nscd.initd18
-rw-r--r--testing/llvm/APKBUILD16
-rw-r--r--testing/llvm/llvm-uclibc-errno-fsckery.patch86
-rw-r--r--testing/pastebinc/APKBUILD41
-rw-r--r--testing/thunar-volman/APKBUILD36
-rw-r--r--testing/xfce4-cpugraph-plugin/APKBUILD44
11 files changed, 462 insertions, 130 deletions
diff --git a/testing/gcc/APKBUILD b/testing/gcc/APKBUILD
index a9600d2214..3126953de5 100644
--- a/testing/gcc/APKBUILD
+++ b/testing/gcc/APKBUILD
@@ -7,7 +7,7 @@ _specs_gcc_ver=4.4.3
_uclibc_abiver=0.9.32
-pkgrel=0
+pkgrel=2
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -28,6 +28,7 @@ if [ "$LANG_OBJC" != "off" ]; then
fi
if [ "$LANG_JAVA" != "off" ]; then
subpackages="$subpackages $pkgname-java libgcj"
+ makedepends="$makedepends paxctl"
fi
source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-core-$pkgver.tar.bz2
@@ -165,7 +166,7 @@ build() {
--build=${CBUILD} \
--host=${CHOST} \
--target=${CTARGET} \
- --with-pkgversion='Alpine' \
+ --with-pkgversion="Alpine ${pkgver}-r${pkgrel}" \
--disable-altivec \
--disable-checking \
--disable-fixed-point \
@@ -277,6 +278,7 @@ libgomp() {
java() {
pkgdesc="Java support for GCC"
+ paxctl -c -p -e -m "$pkgdir"/usr/libexec/gcc/*/*/ecj1 || return 1
mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/lib
cd "$pkgdir"/usr/bin
mv gcj gcj-dbtool gjavah gcjh jcf-dump "$subpkgdir"/usr/bin/
diff --git a/testing/graphviz/0001-clone-nameclash.patch b/testing/graphviz/0001-clone-nameclash.patch
new file mode 100644
index 0000000000..6222238d8d
--- /dev/null
+++ b/testing/graphviz/0001-clone-nameclash.patch
@@ -0,0 +1,87 @@
+From cb8bbbd3a48fa1f41965617852d11e02eb20b1f0 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 26 Jul 2011 12:41:21 +0000
+Subject: [PATCH] clone nameclash
+
+---
+ lib/gvpr/actions.c | 6 +++---
+ lib/gvpr/actions.h | 2 +-
+ lib/gvpr/compile.c | 2 +-
+ lib/gvpr/gvpr.c | 4 ++--
+ 4 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/lib/gvpr/actions.c b/lib/gvpr/actions.c
+index 05bfcd1..b3b4a60 100644
+--- a/lib/gvpr/actions.c
++++ b/lib/gvpr/actions.c
+@@ -380,7 +380,7 @@ Agraph_t *cloneG(Agraph_t * g, char* name)
+ * graph. Otherwise, create a clone subgraph of g.
+ * Assume obj != NULL.
+ */
+-Agobj_t *clone(Agraph_t * g, Agobj_t * obj)
++Agobj_t *cloneO(Agraph_t * g, Agobj_t * obj)
+ {
+ Agobj_t *nobj = 0;
+ Agedge_t *e;
+@@ -415,8 +415,8 @@ Agobj_t *clone(Agraph_t * g, Agobj_t * obj)
+ case AGINEDGE:
+ case AGOUTEDGE:
+ e = (Agedge_t *) obj;
+- t = (Agnode_t *) clone(g, OBJ(agtail(e)));
+- h = (Agnode_t *) clone(g, OBJ(aghead(e)));
++ t = (Agnode_t *) cloneO(g, OBJ(agtail(e)));
++ h = (Agnode_t *) cloneO(g, OBJ(aghead(e)));
+ name = agnameof (AGMKOUT(e));
+ nobj = (Agobj_t *) openEdge(g, t, h, name);
+ if (nobj)
+diff --git a/lib/gvpr/actions.h b/lib/gvpr/actions.h
+index 5c62a3b..4223c52 100644
+--- a/lib/gvpr/actions.h
++++ b/lib/gvpr/actions.h
+@@ -22,7 +22,7 @@ extern "C" {
+ #include "expr.h"
+
+ extern void nodeInduce(Agraph_t * selected);
+- extern Agobj_t *clone(Agraph_t * g, Agobj_t * obj);
++ extern Agobj_t *cloneO(Agraph_t * g, Agobj_t * obj);
+ extern Agraph_t *cloneG(Agraph_t * g, char* name);
+ extern Agobj_t *copy(Agraph_t * g, Agobj_t * obj);
+ extern int copyAttr(Agobj_t * obj, Agobj_t * obj1);
+diff --git a/lib/gvpr/compile.c b/lib/gvpr/compile.c
+index c157572..0914210 100644
+--- a/lib/gvpr/compile.c
++++ b/lib/gvpr/compile.c
+@@ -1087,7 +1087,7 @@ getval(Expr_t * pgm, Exnode_t * node, Exid_t * sym, Exref_t * ref,
+ error(ERROR_WARNING, "NULL object passed to clone()");
+ v.integer = 0;
+ } else
+- v.integer = PTR2INT(clone(gp, objp));
++ v.integer = PTR2INT(cloneO(gp, objp));
+ break;
+ case F_cloneG:
+ gp = INT2PTR(Agraph_t *, args[0].integer);
+diff --git a/lib/gvpr/gvpr.c b/lib/gvpr/gvpr.c
+index 0d47d70..9a1bfd1 100644
+--- a/lib/gvpr/gvpr.c
++++ b/lib/gvpr/gvpr.c
+@@ -803,7 +803,7 @@ addOutputGraph (Gpr_t* state, gvpropts* uopts)
+ Agraph_t* g = state->outgraph;
+
+ if ((agroot(g) == state->curgraph) && !uopts->ingraphs)
+- g = (Agraph_t*)clone (0, (Agobj_t *)g);
++ g = (Agraph_t*)cloneO (0, (Agobj_t *)g);
+
+ uopts->n_outgraphs++;
+ uopts->outgraphs = oldof(uopts->outgraphs,Agraph_t*,uopts->n_outgraphs,0);
+@@ -988,7 +988,7 @@ int gvpr (int argc, char *argv[], gvpropts * uopts)
+
+ /* begin graph */
+ if (incoreGraphs && (opts->compflags & CLONE))
+- state->curgraph = (Agraph_t*)clone (0, (Agobj_t*)(state->curgraph));
++ state->curgraph = (Agraph_t*)cloneO (0, (Agobj_t*)(state->curgraph));
+ state->curobj = (Agobj_t *) state->curgraph;
+ state->tvroot = 0;
+ if (bp->begg_stmt)
+--
+1.7.6
+
diff --git a/testing/graphviz/APKBUILD b/testing/graphviz/APKBUILD
new file mode 100644
index 0000000000..03b33aaccf
--- /dev/null
+++ b/testing/graphviz/APKBUILD
@@ -0,0 +1,101 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=graphviz
+pkgver=2.28.0
+pkgrel=0
+pkgdesc="Graph Visualization Tools"
+url="http://www.graphviz.org/"
+arch="all"
+license="EPL"
+depends=""
+depends_dev="zlib-dev libpng-dev jpeg-dev expat-dev freetype-dev bison m4 flex
+ fontconfig-dev libtool libsm-dev libxext-dev cairo-dev pango-dev
+ gmp-dev lua-dev gtk+-dev swig python-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc py-$pkgname:py lua-$pkgname:_lua
+ $pkgname-gtk $pkgname-graphs"
+source="http://www.graphviz.org/pub/graphviz/stable/SOURCES/graphviz-$pkgver.tar.gz
+ 0001-clone-nameclash.patch"
+
+_builddir="$srcdir"/graphviz-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ # use /usr/lib instead of /usr/lib64
+ sed -i -e 's/LIBPOSTFIX="64"/LIBPOSTFIX=/' configure || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-x \
+ --disable-static \
+ --disable-dependency-tracking \
+ --enable-lua=yes \
+ --without-mylibgd \
+ --with-ipsepcola \
+ --with-pangocairo \
+ --with-gdk-pixbuf \
+ --with-png \
+ --with-jpeg \
+ || return 1
+ if [ "$CARCH" = "x86_64" ]; then
+ # the configure script thinks we have sincos. we dont.
+ sed -i -e '/HAVE_SINCOS/d' config.h || return 1
+ fi
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" \
+ pkgconfigdir=/usr/lib/pkgconfig \
+ install || return 1
+ mkdir -p "$pkgdir"/usr/share/doc
+ mv "$pkgdir"/usr/share/graphviz/doc "$pkgdir"/usr/share/doc/graphviz || return 1
+ rm -f "$pkgdir"/usr/lib/*.la \
+ "$pkgdir"/usr/lib/graphviz/*.la \
+ "$pkgdir"/usr/lib/graphviz/*/*.la \
+ || return 1
+}
+
+py() {
+ pkgdesc="Python extension for graphviz"
+ mkdir -p "$subpkgdir"/usr/lib/graphviz \
+ "$subpkgdir"/usr/lib || return 1
+ mv "$pkgdir"/usr/lib/graphviz/python* \
+ "$subpkgdir"/usr/lib/graphviz || return 1
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
+_lua() {
+ pkgdesc="Lua extension for graphviz"
+ mkdir -p "$subpkgdir"/usr/lib/graphviz \
+ "$subpkgdir"/usr/lib/lua || return 1
+ mv "$pkgdir"/usr/lib/graphviz/lua \
+ "$subpkgdir"/usr/lib/graphviz || return 1
+ mv "$pkgdir"/usr/lib/lua "$subpkgdir"/usr/lib/
+}
+
+gtk() {
+ pkgdesc="Gtk extension for graphviz"
+ mkdir -p "$subpkgdir"/usr/lib/graphviz || return 1
+ mv "$pkgdir"/usr/lib/graphviz/libgvplugin_g?k* \
+ "$subpkgdir"/usr/lib/graphviz || return 1
+}
+
+graphs() {
+ pkgdesc="Demo graphs for graphviz"
+ mkdir -p "$subpkgdir"/usr/share/graphviz || return 1
+ mv "$pkgdir"/usr/share/graphviz/graphs \
+ "$subpkgdir"/usr/share/graphviz/
+}
+md5sums="8d26c1171f30ca3b1dc1b429f7937e58 graphviz-2.28.0.tar.gz
+bce8a9ae4c3a8c52c1bcf0e03d5ce364 0001-clone-nameclash.patch"
diff --git a/testing/joe/APKBUILD b/testing/joe/APKBUILD
new file mode 100644
index 0000000000..6ee1013bd9
--- /dev/null
+++ b/testing/joe/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Danilo Godec <danilo.godec@agenda.si>
+# Maintainer:
+pkgname=joe
+pkgver=3.7
+pkgrel=0
+pkgdesc="Full featured terminal-based screen editor"
+url="http://joe-editor.sourceforge.net/"
+arch="all"
+license="GPL"
+depends=""
+makedepends="ncurses-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/joe-editor/JOE%20sources/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr --sysconfdir=/etc || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+md5sums="66de1b073e869ba12abbfcde3885c577 joe-3.7.tar.gz"
+
diff --git a/testing/libc6/APKBUILD b/testing/libc6/APKBUILD
new file mode 100644
index 0000000000..2eb91a2192
--- /dev/null
+++ b/testing/libc6/APKBUILD
@@ -0,0 +1,117 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=libc6
+pkgver=2.14
+pkgrel=0
+svnrev=14663
+pkgdesc="Embedded GNU C Library"
+url="http://eglibc.org/"
+arch=""
+license="LGPL"
+depends=
+depends_dev="linux-headers>=2.6.18"
+provides="libiconv"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev
+ $pkgname-doc
+
+ gconv-modules:gconv
+ locales
+ nscd"
+options="!strip"
+source="http://dev.alpinelinux.org/~nenolod/eglibc-${pkgver}.r${svnrev}.tar.gz
+
+ glibc-2.12-hardened-pie.patch
+ glibc-2.10-hardened-configure-picdefault.patch
+ glibc-2.10-hardened-inittls-nosysenter.patch
+
+ chk_fail.c
+ stack_chk_fail.c
+
+ nscd.initd"
+
+_srcdir="$srcdir"/eglibc-$pkgver
+_builddir="$srcdir"/eglibc-build
+prepare() {
+ local i
+ cd "$_srcdir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ echo "slibdir=/lib" >> configparms
+
+ cp "$srcdir"/chk_fail.c "$_srcdir"/debug/chk_fail.c
+ cp "$srcdir"/stack_chk_fail.c "$_srcdir"/debug/stack_chk_fail.c
+
+ mkdir "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+
+ export CFLAGS="$CFLAGS -fno-stack-protector"
+
+ "$_srcdir"/configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --with-headers=/usr/include \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-kernel=2.6.18 \
+ --enable-add-ons=nptl,libidn \
+ --disable-profile \
+ --enable-bind-now \
+ --with-tls \
+ --with-__thread \
+ --without-zoneinfo \
+ --without-cvs \
+ --without-gd \
+ --with-pkgversion="Alpine EGLIBC ${pkgver}-r${pkgrel} [svn r${svnrev}]" \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install_root="$pkgdir" install || return 1
+}
+
+gconv() {
+ pkgdesc="GNU iconv character modules"
+
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/iconv "$subpkgdir"/usr/lib
+}
+
+locales() {
+ pkgdesc="Common files for locale support"
+
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/* "$subpkgdir"/usr/share
+}
+
+nscd() {
+ pkgdesc="Cache daemon for NIS/DNS"
+
+ mkdir -p "$subpkgdir"/var/db/nscd
+ mkdir -p "$subpkgdir"/var/run/nscd
+
+ install -Dm 755 "$srcdir"/nscd.initd "$subpkgdir"/etc/init.d/nscd
+ install -Dm 644 "$srcdir"/libc/nscd/nscd.conf "$subpkgdir"/etc/nscd.conf
+
+ mkdir -p "$subpkgdir"/usr/sbin
+ mv "$pkgdir"/usr/sbin/nscd "$subpkgdir"/usr/sbin
+}
+
+md5sums="c6de1455fcef3487ee42c14349a72cf4 eglibc-2.14.r14663.tar.gz
+03ffc414f8eb9f1fcb93325008f5ecd7 glibc-2.12-hardened-pie.patch
+8bca42eb8f6d117107ab8e356566b805 glibc-2.10-hardened-configure-picdefault.patch
+d3b50eec50099791bf2f0c10b605ff7c glibc-2.10-hardened-inittls-nosysenter.patch
+1b31d2c7a39298da10e3840076514823 chk_fail.c
+6a6b9992c76a9bece219eb00a16d7549 stack_chk_fail.c
+ff0b0069eeb662145d287d7f98c79447 nscd.initd"
diff --git a/testing/libc6/nscd.initd b/testing/libc6/nscd.initd
new file mode 100644
index 0000000000..949c49e82a
--- /dev/null
+++ b/testing/libc6/nscd.initd
@@ -0,0 +1,18 @@
+#!/sbin/runscript
+
+DAEMON=/usr/sbin/nscd
+
+start() {
+ ebegin "Starting nscd"
+ # remove stale files
+ rm -f /var/db/nscd/* /var/run/nscd/* 2>/dev/null
+ start-stop-daemon --start --exec $DAEMON
+ eend $?
+}
+
+stop () {
+ ebegin "Stopping nscd"
+ start-stop-daemon --stop --quiet \
+ --pidfile=/var/run/nscd/nscd.pid
+ eend $?
+}
diff --git a/testing/llvm/APKBUILD b/testing/llvm/APKBUILD
index fb96a8c547..92f70b9231 100644
--- a/testing/llvm/APKBUILD
+++ b/testing/llvm/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=llvm
-pkgver=2.8
+pkgver=2.9
pkgrel=0
pkgdesc="low level virtual machine compiler system"
-arch="all"
+arch="x86"
url="http://llvm.org/"
license="UOI-NCSA"
depends=
@@ -13,7 +13,7 @@ install=
subpackages="$pkgname-dev $pkgname-doc"
source="http://llvm.org/releases/$pkgver/llvm-$pkgver.tgz
http://llvm.org/releases/$pkgver/clang-$pkgver.tgz
- llvm-uclibc-errno-fsckery.patch"
+ "
_builddir="$srcdir"/build
@@ -44,6 +44,11 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info
+
+ # configure gets it wrong. We do have error_t
+ sed -i -e 's/.*undef HAVE_ERROR_T.*/#define HAVE_ERROR_T 1/' \
+ -e '/define error_t/d' \
+ ./include/llvm/Config/config.h || return 1
make || return 1
}
@@ -52,6 +57,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="220d361b4d17051ff4bb21c64abe05ba llvm-2.8.tgz
-10e14c901fc3728eecbd5b829e011b59 clang-2.8.tgz
-089441aa2369c90a0fd0edaa311cb7d6 llvm-uclibc-errno-fsckery.patch"
+md5sums="793138412d2af2c7c7f54615f8943771 llvm-2.9.tgz
+634de18d04b7a4ded19ec4c17d23cfca clang-2.9.tgz"
diff --git a/testing/llvm/llvm-uclibc-errno-fsckery.patch b/testing/llvm/llvm-uclibc-errno-fsckery.patch
deleted file mode 100644
index a7335f2684..0000000000
--- a/testing/llvm/llvm-uclibc-errno-fsckery.patch
+++ /dev/null
@@ -1,86 +0,0 @@
---- llvm-2.8/lib/Support/CommandLine.cpp
-+++ llvm-2.8.mod/lib/Support/CommandLine.cpp
-@@ -31,7 +31,10 @@
- #include "llvm/ADT/StringMap.h"
- #include "llvm/ADT/Twine.h"
- #include "llvm/Config/config.h"
--#include <cerrno>
-+
-+#include <asm-generic/errno-base.h>
-+extern __thread int errno;
-+
- #include <cstdlib>
- using namespace llvm;
- using namespace cl;
---- llvm-2.8/lib/Support/raw_ostream.cpp
-+++ llvm-2.8.mod/lib/Support/raw_ostream.cpp
-@@ -22,7 +22,10 @@
- #include "llvm/System/Signals.h"
- #include "llvm/ADT/STLExtras.h"
- #include <cctype>
--#include <cerrno>
-+
-+#include <asm-generic/errno-base.h>
-+extern __thread int errno;
-+
- #include <sys/stat.h>
- #include <sys/types.h>
-
---- llvm-2.8/lib/System/Errno.cpp
-+++ llvm-2.8.mod/lib/System/Errno.cpp
-@@ -14,13 +14,11 @@
- #include "llvm/System/Errno.h"
- #include "llvm/Config/config.h" // Get autoconf configuration settings
-
-+extern __thread int errno;
-+
- #if HAVE_STRING_H
- #include <string.h>
-
--#if HAVE_ERRNO_H
--#include <errno.h>
--#endif
--
- //===----------------------------------------------------------------------===//
- //=== WARNING: Implementation here must contain only TRULY operating system
- //=== independent code.
-@@ -29,11 +27,9 @@
- namespace llvm {
- namespace sys {
-
--#if HAVE_ERRNO_H
- std::string StrError() {
- return StrError(errno);
- }
--#endif // HAVE_ERRNO_H
-
- std::string StrError(int errnum) {
- const int MaxErrStrLen = 2000;
---- llvm-2.8/lib/System/Unix/Unix.h
-+++ llvm-2.8.mod/lib/System/Unix/Unix.h
-@@ -24,7 +24,10 @@
- #include <cstdlib>
- #include <cstdio>
- #include <cstring>
--#include <cerrno>
-+
-+#include <asm-generic/errno-base.h>
-+extern __thread int errno;
-+
- #include <string>
- #include <algorithm>
-
---- llvm-2.8/utils/TableGen/TGLexer.cpp
-+++ llvm-2.8.mod/utils/TableGen/TGLexer.cpp
-@@ -19,7 +19,10 @@
- #include <cstdio>
- #include <cstdlib>
- #include <cstring>
--#include <cerrno>
-+
-+#include <asm-generic/errno-base.h>
-+extern __thread int errno;
-+
- using namespace llvm;
-
- TGLexer::TGLexer(SourceMgr &SM) : SrcMgr(SM) {
diff --git a/testing/pastebinc/APKBUILD b/testing/pastebinc/APKBUILD
new file mode 100644
index 0000000000..d40962f0b7
--- /dev/null
+++ b/testing/pastebinc/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Jeremy Thomerson <jeremy@thomersonfamily.com>
+# Maintainer: Jeremy Thomerson <jeremy@thomersonfamily.com>
+pkgname=pastebinc
+pkgver=0.9
+pkgrel=0
+pkgdesc="utility to pipe data into a paste on pastebin.com or a similar site"
+url="https://github.com/jthomerson/pastebinc"
+arch="all"
+license="ASL 2.0"
+depends=
+depends_dev=
+makedepends="wget glib-dev curl-dev"
+install=""
+subpackages=""
+source="saveas-https://github.com/jthomerson/pastebinc/tarball/RELEASE_0.9-BETA/$pkgname-$pkgver-$pkgrel.tar.gz"
+_builddir="$srcdir/jthomerson-pastebinc-8dbb86b"
+
+makeparams="VERSION=$pkgver-$pkgrel CONFDIR=/etc/pastebinc"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make $makeparams clean || return 1
+ make $makeparams || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make $makeparams DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="a1620a9d04ecb79f42ede3768987567a pastebinc-0.9-0.tar.gz"
diff --git a/testing/thunar-volman/APKBUILD b/testing/thunar-volman/APKBUILD
deleted file mode 100644
index e092d537d1..0000000000
--- a/testing/thunar-volman/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=thunar-volman
-pkgver=0.6.0
-pkgrel=0
-pkgdesc="Thunar extension for volumes management"
-url="http://goodies.xfce.org/projects/thunar-plugins/thunar-volman"
-arch="all"
-license="GPL"
-depends=
-makedepends="thunar-dev exo-dev udev-dev libxfce4ui-dev libnotify-dev"
-install=
-subpackages=
-source="http://archive.xfce.org/src/apps/thunar-volman/${pkgver%.*}/thunar-volman-$pkgver.tar.bz2"
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
- # apply patches here
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install
-}
-
-md5sums="2f166662dd100d5195da238af417f305 thunar-volman-0.6.0.tar.bz2"
diff --git a/testing/xfce4-cpugraph-plugin/APKBUILD b/testing/xfce4-cpugraph-plugin/APKBUILD
new file mode 100644
index 0000000000..a69bd26683
--- /dev/null
+++ b/testing/xfce4-cpugraph-plugin/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-cpugraph-plugin
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="CPU monitor for the Xfce panel"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
+arch="all"
+license="GPLv2+"
+depends=""
+makedepends="libxfcegui4-dev xfce4-panel-dev"
+install=""
+subpackages=""
+source="http://archive.xfce.org/src/panel-plugins/xfce4-cpugraph-plugin/1.0/xfce4-cpugraph-plugin-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/xfce4-cpugraph-plugin-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="ff551087b1f61c47b8746e8687c572aa xfce4-cpugraph-plugin-1.0.1.tar.bz2"