aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2009-02-12 09:24:35 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2009-02-12 09:24:35 +0000
commitdcd5b5be2cbd0a0505dc4b20fdeef4fef06ce8dc (patch)
tree45febbc2fbb58b2cd8fd00e7a53ad5ffca134563 /testing
parentf9e132166ed98a4bf79f2defd8acbdf2315fe0e9 (diff)
parenta2e7b0043cd02246557d9743e4ca725ac0013b2e (diff)
downloadaports-dcd5b5be2cbd0a0505dc4b20fdeef4fef06ce8dc.tar.bz2
aports-dcd5b5be2cbd0a0505dc4b20fdeef4fef06ce8dc.tar.xz
Merge commit 'ncopa/master'
Diffstat (limited to 'testing')
-rw-r--r--testing/apcupsd/APKBUILD26
-rw-r--r--testing/apcupsd/apcupsd.initd37
-rw-r--r--testing/fetch-crl/APKBUILD31
-rw-r--r--testing/kvm/APKBUILD33
-rw-r--r--testing/kvm/kvm-82-uclibc.patch14
-rw-r--r--testing/mysql/APKBUILD42
-rw-r--r--testing/mysql/mysql.initd38
-rw-r--r--testing/mysql/mysql.mycnf49
-rw-r--r--testing/nagios/APKBUILD55
-rw-r--r--testing/nagios/lighttpd-nagios.conf29
-rw-r--r--testing/nagios/nagios.confd9
-rw-r--r--testing/nagios/nagios.initd38
-rw-r--r--testing/openvcp/APKBUILD40
-rw-r--r--testing/openvcp/openvcpd-0.4-rc1-makefile.patch46
-rw-r--r--testing/openvcp/openvcpd-0.4-rc1-posix-shell.patch21
-rw-r--r--testing/ucsniff/APKBUILD27
-rw-r--r--testing/util-linux-ng/APKBUILD33
17 files changed, 568 insertions, 0 deletions
diff --git a/testing/apcupsd/APKBUILD b/testing/apcupsd/APKBUILD
new file mode 100644
index 0000000000..03c280f8a2
--- /dev/null
+++ b/testing/apcupsd/APKBUILD
@@ -0,0 +1,26 @@
+pkgname=apcupsd
+pkgver=3.14.5
+pkgrel=0
+pkgdesc="A Daemon to control APC UPSes"
+subpackages="$pkgname-doc"
+url="http://www.apcupsd.org"
+license="GPL-2"
+depends="uclibc util-linux-ng"
+makedepends="g++"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ apcupsd.initd
+ "
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-usb
+ make || return 1
+ make DESTDIR=$pkgdir install
+ install -D -m755 "$srcdir"/apcupsd.initd "$pkgdir"/etc/init.d/apcupsd
+}
+
+md5sums="4ac73ec91d8ab56f3fac894e172567c4 apcupsd-3.14.5.tar.gz
+d276b567fd8dfb9e2a74e533b25de031 apcupsd.initd"
diff --git a/testing/apcupsd/apcupsd.initd b/testing/apcupsd/apcupsd.initd
new file mode 100644
index 0000000000..43868f75dd
--- /dev/null
+++ b/testing/apcupsd/apcupsd.initd
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/apcupsd/files/apcupsd.init.2,v 1.1 2009/01/15 15:21:11 flameeyes Exp $
+
+INSTANCE="${SVCNAME#*.}"
+if [ -z "${INSTANCE}" ] || [ "${SVCNAME}" = "apcupsd" ]; then
+ INSTANCE="apcupsd"
+fi
+
+depend() {
+ use net
+}
+
+start() {
+ rm -f /etc/apcupsd/powerfail
+
+ export SERVICE="${SVCNAME}"
+
+ ebegin "Starting APC UPS daemon"
+ start-stop-daemon \
+ --start --pidfile "/var/run/${SVCNAME}.pid" \
+ --exec /sbin/apcupsd -- \
+ -f "/etc/apcupsd/${INSTANCE}.conf" \
+ -P "/var/run/${SVCNAME}.pid"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping APC UPS daemon"
+ start-stop-daemon \
+ --stop --pidfile "/var/run/${SVCNAME}.pid" \
+ --retry TERM/5/TERM/5 \
+ --exec /sbin/apcupsd
+ eend $?
+}
+
diff --git a/testing/fetch-crl/APKBUILD b/testing/fetch-crl/APKBUILD
new file mode 100644
index 0000000000..5d1bf5d945
--- /dev/null
+++ b/testing/fetch-crl/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=fetch-crl
+pkgver=2.7.0
+pkgrel=0
+pkgdesc="Tool to keep Certificate Revocation Lists (CRLs) up-to-date"
+url="http://dist.eugridpma.info/distribution/util/fetch-crl/"
+license="custom"
+subpackages="$pkgname-doc"
+source="
+ http://dist.eugridpma.info/distribution/util/$pkgname/$pkgname-$pkgver.tar.gz
+ "
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ sed -i -e 's:etc/sysconfig:etc/conf.d:g' \
+ edg-fetch-crl fetch-crl.cron fetch-crl.8
+ sed -i -e 's:bin/bash:bin/sh:' fetch-crl.cron
+
+ _r=$pkgname-$pkgver
+ install -m755 -D edg-fetch-crl "$pkgdir"/usr/sbin/fetch-crl
+ install -m644 -D fetch-crl.sysconfig "$pkgdir"/etc/conf.d/fetch-crl
+
+ install -m644 -D fetch-crl.8 "$pkgdir"/usr/share/man/man8/fetch-crl.8
+ install -m644 -D README "$pkgdir"/usr/share/doc/$_r/README
+ install -m644 -D CHANGES "$pkgdir"/usr/share/doc/$_r/CHANGES
+ install -m755 -D fetch-crl.cron "$pkgdir"/usr/share/doc/$_r/fetch-crl.periodic
+}
+
+md5sums="6b0ba042ac3d155f1cd9c7b0baf3c708 fetch-crl-2.7.0.tar.gz"
diff --git a/testing/kvm/APKBUILD b/testing/kvm/APKBUILD
new file mode 100644
index 0000000000..ccac7e5ed9
--- /dev/null
+++ b/testing/kvm/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=kvm
+pkgver=83
+pkgrel=0
+pkgdesc="kernel-based virtual machine"
+url="http://kvm.qumranet.com"
+license='GPL'
+depends="uclibc"
+makedepends="ncurses-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ kvm-82-uclibc.patch
+ "
+subpackages=""
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ for i in ../*.patch; do
+ msg "Applying $i"
+ patch -p1 < $i || return 1;
+ done
+
+ ./configure --prefix=/usr \
+ --disable-gfx-check \
+ --disable-sdl \
+ --qemu-ldflags=-nopie
+
+ make libkvm || return 1
+ make qemu || return 1
+ make DESTDIR="$pkgdir"/ kcmd="#" install
+}
+
+md5sums="dfb3cc36029d84e83c5006c600337754 kvm-83.tar.gz
+c439025cbfe89b35c2ae78aa481eb93f kvm-82-uclibc.patch"
diff --git a/testing/kvm/kvm-82-uclibc.patch b/testing/kvm/kvm-82-uclibc.patch
new file mode 100644
index 0000000000..488be77d8d
--- /dev/null
+++ b/testing/kvm/kvm-82-uclibc.patch
@@ -0,0 +1,14 @@
+--- kvm-82.orig/qemu/configure Wed Jan 14 13:40:28 2009
++++ kvm-82/qemu/configure Wed Jan 14 13:41:28 2009
+@@ -1068,7 +1068,10 @@
+ cat > $TMPC <<EOF
+ #include <signal.h>
+ #include <time.h>
+-int main(void) { clockid_t id; return clock_gettime(id, NULL); }
++int main(void) { clockid_t id; timer_t tid;
++ return clock_gettime(id, NULL) + timer_delete(tid);
++}
++
+ EOF
+
+ rt=no
diff --git a/testing/mysql/APKBUILD b/testing/mysql/APKBUILD
new file mode 100644
index 0000000000..bef9f32d24
--- /dev/null
+++ b/testing/mysql/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+pkgname=mysql
+pkgver=5.0.75
+pkgrel=2
+pkgdesc="A fast SQL database server"
+url="http://www.mysql.com/"
+license='GPL'
+depends="readline openssl uclibc++"
+makedepends="libtool uclibc++-dev readline-dev openssl-dev"
+source="http://sunsite.informatik.rwth-aachen.de/mysql/Downloads/MySQL-5.0/${pkgname}-${pkgver}.tar.gz
+$pkgname.initd
+$pkgname.mycnf"
+subpackages="$pkgname-doc $pkgname-dev $pkgname-test"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ export CXX=g++-uc
+ ./configure --prefix=/usr --libexecdir=/usr/sbin \
+ --localstatedir=/var/lib/mysql \
+ --disable-assembler --with-pthread \
+ --without-raid --without-libwrap \
+ --without-pstack --without-docs \
+ --without-embedded-server --with-openssl \
+ --without-mysqlfs --without-vio \
+ --without-bench --without-debug \
+ --with-innodb --mandir=/usr/share/man || return 1
+ make || return 1
+ make -j1 DESTDIR="$pkgdir/" install
+ install -Dm 755 "$startdir"/$pkgname.initd $pkgdir/etc/init.d/$pkgname
+ install -Dm 644 "$startdir"/$pkgname.mycnf $pkgdir/etc/mysql/my.cnf
+ install -dDo mysql $pkgdir/var/log/mysql
+ install -dDo mysql $pkgdir/var/run/mysqld
+}
+
+test() {
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/mysql-test "$subpkgdir"/usr/
+}
+
+md5sums="a234f0a60a7f8c290d9875cba3a2c5a2 mysql-5.0.75.tar.gz
+3ce9827b22d8fbbb29d83a91cbe98ffc mysql.initd
+ca0e193da25d2f10e41334c6d83fa859 mysql.mycnf"
diff --git a/testing/mysql/mysql.initd b/testing/mysql/mysql.initd
new file mode 100644
index 0000000000..8f841646b8
--- /dev/null
+++ b/testing/mysql/mysql.initd
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/dev-db/mysql/files/mysql.init,v 1.7 2004/07/14 21:41:15 agriffis Exp $
+
+depend() {
+ need net
+ use dns
+}
+
+checkconfig() {
+ if [ ! -f /etc/mysql/my.cnf ] ; then
+ eerror "No /etc/mysql/my.cnf file exists!"
+ fi
+
+ dir=`my_print_defaults -c /etc/mysql/my.cnf mysqld | grep -- --datadir | sed -e "s|^.*=\(.*\)|\1|"`
+
+ if [ ! -d $dir/mysql ] ; then
+ eerror "You dont appear to have the mysql database installed yet."
+ eerror "Please run /usr/bin/mysql_install_db --user=mysql to have this done..."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting mysqld"
+ /usr/bin/mysqld_safe --defaults-file=/etc/mysql/my.cnf >/dev/null 2>&1 &
+ eend $?
+}
+
+stop () {
+ ebegin "Stopping mysqld"
+ start-stop-daemon --stop --quiet \
+ --pidfile=/var/run/mysqld/mysqld.pid --retry 20
+ eend $?
+}
+
diff --git a/testing/mysql/mysql.mycnf b/testing/mysql/mysql.mycnf
new file mode 100644
index 0000000000..a84c56933a
--- /dev/null
+++ b/testing/mysql/mysql.mycnf
@@ -0,0 +1,49 @@
+# /etc/mysql/my.cnf: The global mysql configuration file.
+# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/dev-db/mysql/files/my.cnf,v 1.5 2008/11/14 01:49:37 robbat2 Exp $
+#
+# This file can be simultaneously placed in three places:
+# 1. /etc/mysql/my.cnf to set global options.
+# 2. /var/lib/mysql/my.cnf to set server-specific options.
+# 3. ~/.my.cnf to set user-specific options.
+#
+# One can use all long options that the program supports.
+# Run the program with --help to get a list of them.
+#
+# The following values assume you have at least 32M RAM!
+
+[client]
+#password = my_password
+port = 3306
+socket = /var/run/mysqld/mysqld.sock
+
+[safe_mysqld]
+err-log = /var/log/mysql/mysql.err
+
+[mysqld]
+#skip-networking
+skip-innodb
+innodb_file_per_table
+user = mysql
+pid-file = /var/run/mysqld/mysqld.pid
+socket = /var/run/mysqld/mysqld.sock
+port = 3306
+log = /var/log/mysql/mysql.log
+basedir = /usr
+datadir = /var/lib/mysql
+tmpdir = /tmp
+language = /usr/share/mysql/english
+skip-locking
+set-variable = key_buffer=16M
+set-variable = max_allowed_packet=1M
+set-variable = thread_stack=128K
+
+[mysqldump]
+quick
+set-variable = max_allowed_packet=1M
+
+[mysql]
+#no-auto-rehash # faster start of mysql but no tab completition
+
+[isamchk]
+set-variable = key_buffer=16M
+
diff --git a/testing/nagios/APKBUILD b/testing/nagios/APKBUILD
new file mode 100644
index 0000000000..ede82bbde4
--- /dev/null
+++ b/testing/nagios/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Carlo Landmeter <clandmeter at gmail>
+# Maintainer: Carlo Landmeter <clandmeter at gmail>
+pkgname=nagios
+pkgver=3.1.0
+pkgrel=0
+pkgdesc="Popular monitoring tool"
+url="http://www.nagios.org/"
+license="GPL-2"
+depends="gd perl"
+makedepends="gd-dev pkgconfig perl-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+nagios.confd
+nagios.initd
+lighttpd-nagios.conf"
+subpackages="${pkgname}-web"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/nagios \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share/nagios \
+ --localstatedir=/var \
+ --bindir=/usr/sbin \
+ --sbindir=/usr/lib/nagios/cgi-bin \
+ --datadir=/usr/share/nagios/htdocs \
+ --libexecdir=/usr/lib/nagios/plugins \
+ --localstatedir=/var/nagios \
+ --with-nagios-user=nobody \
+ --with-nagios-group=nobody \
+ --enable-embedded-perl \
+ --with-perlcache
+ make all || return 1
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install-config
+ make DESTDIR="$pkgdir" install-commandmode
+
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+
+web() {
+ #depends="php lighttpd"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/share "$subpkgdir"/usr/
+ install -m644 -D "$srcdir"/lighttpd-nagios.conf "$subpkgdir"/etc/lighttpd-nagios.conf
+}
+
+md5sums="02d3b0e13f772481d0ac9e00bdc3e979 nagios-3.1.0.tar.gz
+431dfe7403323e247a88b97beade5d78 nagios.confd
+73fe73c8e31b8a59b5f3206bc90a74e8 nagios.initd
+d63c36f47d26f1f71ae2faf272eec640 lighttpd-nagios.conf"
diff --git a/testing/nagios/lighttpd-nagios.conf b/testing/nagios/lighttpd-nagios.conf
new file mode 100644
index 0000000000..cb7081d841
--- /dev/null
+++ b/testing/nagios/lighttpd-nagios.conf
@@ -0,0 +1,29 @@
+###
+# Sample nagios lighttpd config
+###
+
+server.modules += ("mod_cgi")
+server.modules += ("mod_auth")
+server.modules += ("mod_alias")
+
+auth.require += ( "/nagios" =>
+ (
+ "method" => "digest",
+ "realm" => "nagios",
+ "require" => "valid-user"
+ )
+)
+
+$HTTP["url"] =~ "^/nagios/cgi-bin/" {
+ dir-listing.activate = "disable"
+ cgi.assign = (
+ ".pl" => "/usr/bin/perl",
+ ".cgi" => ""
+ )
+}
+
+alias.url += (
+ "/nagios/cgi-bin" => "/usr/lib/nagios/cgi-bin",
+ "/nagios" => "/usr/share/nagios/htdocs"
+)
+
diff --git a/testing/nagios/nagios.confd b/testing/nagios/nagios.confd
new file mode 100644
index 0000000000..0abb80c6e8
--- /dev/null
+++ b/testing/nagios/nagios.confd
@@ -0,0 +1,9 @@
+# Sample conf.d file for alpine linux
+
+#
+# Specify daemon $OPTS here.
+#
+
+OPTS=""
+USER="nobody"
+GROUP="nobody"
diff --git a/testing/nagios/nagios.initd b/testing/nagios/nagios.initd
new file mode 100644
index 0000000000..ce4410305c
--- /dev/null
+++ b/testing/nagios/nagios.initd
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+
+# Sample init.d file for alpine linux.
+
+NAME=nagios
+DAEMON=/usr/sbin/$NAME
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ${NAME}"
+ start-stop-daemon --start --quiet --background \
+ --make-pidfile --pidfile /var/run/${NAME}.pid \
+ --exec ${DAEMON} -- ${OPTS} /etc/nagios/nagios.cfg
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${NAME}"
+ start-stop-daemon --stop --quiet \
+ --exec ${DAEMON} \
+ --pidfile /var/run/${NAME}.pid \
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ${NAME}"
+ if ! service_started "${NAME}" ; then
+ eend 1 "${NAME} is not started"
+ return 1
+ fi
+ start-stop-daemon --stop --oknodo --signal HUP \
+ --exec ${DAEMON} --pidfile /var/run/${NAME}.pid
+ eend $?
+}
+
diff --git a/testing/openvcp/APKBUILD b/testing/openvcp/APKBUILD
new file mode 100644
index 0000000000..ea24882fbd
--- /dev/null
+++ b/testing/openvcp/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter <clandmeter at gmail>
+# Maintainer: Carlo Landmeter <clandmeter at gmail>
+pkgname=openvcpd
+pkgver="0.4_rc1"
+_myver="0.4-rc1"
+pkgrel=0
+pkgdesc="vserver control panel daemon"
+url="http://openvcp.org/"
+license="GPL"
+depends="sqlite libxml2"
+makedepends="libxml2-dev pkgconfig util-vserver-dev iptables-dev sqlite-dev libpcap-dev autoconf"
+source="http://files.openvcp.org/${pkgname}-${_myver}.tar.gz
+ $pkgname-0.4-rc1-makefile.patch
+ $pkgname-0.4-rc1-posix-shell.patch
+ "
+
+build() {
+ cd "$srcdir/$pkgname-$_myver"
+ for i in ../*.patch; do
+ msg "Applying $i"
+ patch -p1 < $i || return 1
+ done
+ autoconf
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+ mkdir -p "$pkgdir"/usr/bin/
+ mkdir -p "$pkgdir"/etc/
+ make DESTDIR="$pkgdir" install
+
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="18725ca88753e0a5c42af849347934c0 openvcpd-0.4-rc1.tar.gz
+fb1802bf62ebc524a836b38683825b25 openvcpd-0.4-rc1-makefile.patch
+b27f708c81a27bbf03f4c111b4b1f9f8 openvcpd-0.4-rc1-posix-shell.patch"
diff --git a/testing/openvcp/openvcpd-0.4-rc1-makefile.patch b/testing/openvcp/openvcpd-0.4-rc1-makefile.patch
new file mode 100644
index 0000000000..a7a26e52cb
--- /dev/null
+++ b/testing/openvcp/openvcpd-0.4-rc1-makefile.patch
@@ -0,0 +1,46 @@
+--- a/Makefile.in Wed Feb 4 10:55:05 2009
++++ b/Makefile.in Wed Feb 4 10:57:25 2009
+@@ -3,8 +3,9 @@
+ datadir = @datarootdir@
+ sysconfdir = @sysconfdir@
+
++REV:=$(shell svnversion 2>/dev/null | sed 's/M//')
+ CC=@CC@
+-CFLAGS=@CFLAGS@ @DEFS@ -DOPENVCP_CONFIG=\"$(sysconfdir)/openvcpd.conf\" -DOPENVCP_DATA=\"$(datadir)/openvcpd\" -Ilib/ -Isrc/ -rdynamic -DREVISION=\"`svnversion | sed 's/M//'`\"
++CFLAGS=@CFLAGS@ @DEFS@ -DOPENVCP_CONFIG=\"$(sysconfdir)/openvcpd.conf\" -DOPENVCP_DATA=\"$(datadir)/openvcpd\" -Ilib/ -Isrc/ -rdynamic -DREVISION=\"$(REV)\"
+ LDFLAGS=@LDFLAGS@
+ LIBS=@LIBS@
+
+@@ -39,22 +40,24 @@
+ @rm -f parse_ipfmlogs
+
+ install:
+- mkdir -p $(datadir)/openvcpd
+- cp openvcpd $(bindir)/openvcpd
+- cp parse_ipfmlogs $(bindir)/parse_ipfmlogs
++ mkdir -p "$(DESTDIR)/$(datadir)"/openvcpd \
++ "$(DESTDIR)/$(bindir)" \
++ "$(DESTDIR)/$(sysconfdir)"
++ cp openvcpd "$(DESTDIR)/$(bindir)"/openvcpd
++ cp parse_ipfmlogs "$(DESTDIR)/$(bindir)"/parse_ipfmlogs
+
+- @if (test -e $(sysconfdir)/openvcpd.conf); then \
++ @if (test -e "$(DESTDIR)/$(sysconfdir)"/openvcpd.conf); then \
+ echo "Configuration File exists. Please check for updates of the configurationfile"; \
+ else \
+ cfgdir=`vserver-info 2>&1 | grep 'cfg-Directory:' | awk -F: '{ print $$2 }' | cut -c2-`; \
+ rootdir=`vserver-info 2>&1 | grep 'vserver-Rootdir:' | awk -F: '{ print $$2 }' | cut -c2-`; \
+ rundir=`vserver-info 2>&1 | grep 'pkgstate-Directory:' | awk -F: '{ print $$2 }' | cut -c2-`; \
+ echo "CONF: $$cfgdir, $$rootdir, $$rundir"; \
+- cat openvcpd.conf | sed s#'CONFIGDIR'#$$cfgdir# | sed s#'ROOTDIR'#$$rootdir# | sed s#'RUNDIR'#$$rundir# > $(sysconfdir)/openvcpd.conf; \
++ cat openvcpd.conf | sed s#'CONFIGDIR'#$$cfgdir# | sed s#'ROOTDIR'#$$rootdir# | sed s#'RUNDIR'#$$rundir# > $(DESTDIR)/$(sysconfdir)/openvcpd.conf; \
+ echo "Configuration File created ($(sysconfdir)/openvcpd.conf)"; \
+ fi \
+
+ uninstall:
+- rm -rf $(datadir)/openvcpd
+- rm -f $(bindir)/openvcpd
+- rm -f $(sysconfdir)/openvcpd.conf
++ rm -rf "$(DESTDIR)/$(datadir)"/openvcpd
++ rm -f "$(DESTDIR)/$(bindir)"/openvcpd
++ rm -f "$(DESTDIR)/$(sysconfdir)"/openvcpd.conf
diff --git a/testing/openvcp/openvcpd-0.4-rc1-posix-shell.patch b/testing/openvcp/openvcpd-0.4-rc1-posix-shell.patch
new file mode 100644
index 0000000000..492e6b0331
--- /dev/null
+++ b/testing/openvcp/openvcpd-0.4-rc1-posix-shell.patch
@@ -0,0 +1,21 @@
+--- a/configure.ac Wed Feb 4 10:11:07 2009
++++ b/configure.ac Wed Feb 4 10:23:07 2009
+@@ -67,15 +67,15 @@
+ fi
+
+ if test "x$with_ipv6" != xno; then
+- CFLAGS+=" -DIPV6_SUPPORT"
++ CFLAGS="$CFLAGS -DIPV6_SUPPORT"
+ fi
+
+ xmlflags=`pkg-config libxml-2.0 --cflags`
+-if test "$xmlflags" == ""; then
++if test "$xmlflags" = ""; then
+ AC_MSG_ERROR([libxml2 headers not found])
+ fi
+
+-CFLAGS+=" $xmlflags"
++CFLAGS="$CFLAGS $xmlflags"
+
+ AC_CONFIG_FILES([Makefile])
+ AC_OUTPUT
diff --git a/testing/ucsniff/APKBUILD b/testing/ucsniff/APKBUILD
new file mode 100644
index 0000000000..5ce323ba7f
--- /dev/null
+++ b/testing/ucsniff/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Mika Havela <mika.havela@gmail.com>
+pkgname=ucsniff
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="VoIP Security Assessment tool"
+url="http://ucsniff.sourceforge.net"
+license="GPLv3"
+depends="libpcap libnet zlib alsa-lib libltdl"
+makedepends="libpcap-dev libnet-dev zlib-dev"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --disable-gtk \
+ --disable-nls \
+ --without-iconv || return 1
+
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="64f12c353744dcf6c8710b4704cadfbe ucsniff-1.0.0.tar.gz"
diff --git a/testing/util-linux-ng/APKBUILD b/testing/util-linux-ng/APKBUILD
new file mode 100644
index 0000000000..f8c8e135cb
--- /dev/null
+++ b/testing/util-linux-ng/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Leonardo Arena <rnalrd@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=util-linux-ng
+pkgver=2.14.1
+pkgrel=1
+pkgdesc="Random collection of Linux utilities"
+arch=""
+url="http://kernel.org/~kzak/util-linux-ng/"
+license="GPL-2 GPL Public Domain"
+depends="uclibc e2fsprogs libuuid zlib"
+makedepends="e2fsprogs-dev zlib-dev"
+install=
+source="http://www.kernel.org/pub/linux/utils/util-linux-ng/v2.14/$pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-doc"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -e 's/versionsort/alphasort/g'\
+ -e 's/strverscmp.h/dirent.h/g' \
+ -i mount/lomount.c
+
+ ./configure --prefix=/usr \
+ --disable-nls \
+ --disable-kill \
+ --enable-init \
+ --without-ncurses \
+ --without-pam
+
+ make || return 1
+ make install DESTDIR=$pkgdir
+}
+
+md5sums="17bafd53cf242accd716d2306a2c6582 util-linux-ng-2.14.1.tar.gz"