aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-05-21 13:40:12 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-23 11:40:36 +0000
commit086e95610c9bcf980ed93b84d14570f76fd4858b (patch)
tree23196807cffa568353ca67d0de39e1316a62abd4 /testing
parentf40ed1a244e1da311850edc856a0e74464bdb372 (diff)
downloadaports-086e95610c9bcf980ed93b84d14570f76fd4858b.tar.bz2
aports-086e95610c9bcf980ed93b84d14570f76fd4858b.tar.xz
testing/R: enable most of the USE flags and add -dev dependencies
R users often plots graphs, so they need all these USE flags for graphics stuff.
Diffstat (limited to 'testing')
-rw-r--r--testing/R/APKBUILD32
-rw-r--r--testing/R/R.post-install8
2 files changed, 26 insertions, 14 deletions
diff --git a/testing/R/APKBUILD b/testing/R/APKBUILD
index 1e6b823177..9c89f61112 100644
--- a/testing/R/APKBUILD
+++ b/testing/R/APKBUILD
@@ -3,15 +3,19 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=R
pkgver=3.3.0
-pkgrel=2
+pkgrel=3
pkgdesc="Language and environment for statistical computing"
url="https://www.r-project.org"
arch="x86_64 x86"
license="GPL-2 GPL-3 LGPL-2.1"
depends=""
-makedepends="bzip2-dev curl-dev>=7.28 gfortran lapack-dev pcre-dev>=8.10 perl
- readline-dev xz-dev zlib-dev
+depends_dev="gcc gfortran icu-dev lapack-dev libjpeg-turbo libpng-dev make
+ pcre-dev>=8.10 readline-dev xz-dev zlib-dev
"
+makedepends="$depends_dev bzip2-dev cairo-dev curl-dev>=7.28 libxmu-dev
+ openjdk8-jre-base pango-dev perl tiff-dev tk-dev
+ "
+install="$pkgname.post-install"
subpackages="
$pkgname-mathlib
$pkgname-mathlib-dev:mathlib_dev
@@ -36,19 +40,19 @@ build() {
rdocdir=/usr/share/doc/R \
rincludedir=/usr/include/R \
rsharedir=/usr/share/R \
- --enable-R-shlib \
- --disable-java \
--disable-nls \
+ --enable-R-shlib \
+ --enable-java \
+ --without-recommended-packages \
--with-blas \
+ --with-cairo \
+ --with-ICU \
+ --with-jpeglib \
--with-lapack \
- --without-tcltk \
- --without-cairo \
- --without-libpng \
- --without-jpeglib \
- --without-libtiff \
- --without-recommended-packages \
- --without-ICU \
- --without-x \
+ --with-libpng \
+ --with-libtiff \
+ --with-tcltk \
+ --with-x \
|| return 1
make || return 1
@@ -74,7 +78,7 @@ package() {
# Remove some useless files (COPYING is duplicated, it will be
# in -doc, don't worry).
- rm "$destdir"/etc/javaconf "$destdir"/COPYING "$destdir"/SVN-REVISION
+ rm "$destdir"/COPYING "$destdir"/SVN-REVISION
mkdir -p "$pkgdir"/etc/R
diff --git a/testing/R/R.post-install b/testing/R/R.post-install
new file mode 100644
index 0000000000..f4603051e1
--- /dev/null
+++ b/testing/R/R.post-install
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+cat <<EOF
+*
+* If you want to install R packages from CRAN that contains native extensions,
+* then you must also install R-dev.
+*
+EOF