aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2015-01-20 14:25:01 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2015-01-20 14:25:01 +0000
commit38b2a6e4a99e1cf43d2db12a8c89176bcf537fe5 (patch)
treefedcc802578a486c654b06d5237b8c2ecc9117d7 /testing
parentef4f468980f78719d7ce14676b772590d0492270 (diff)
downloadaports-38b2a6e4a99e1cf43d2db12a8c89176bcf537fe5.tar.bz2
aports-38b2a6e4a99e1cf43d2db12a8c89176bcf537fe5.tar.xz
testing/libmemcached: moved to main
Diffstat (limited to 'testing')
-rw-r--r--testing/libmemcached/APKBUILD55
-rw-r--r--testing/libmemcached/musl-fixes.patch58
2 files changed, 0 insertions, 113 deletions
diff --git a/testing/libmemcached/APKBUILD b/testing/libmemcached/APKBUILD
deleted file mode 100644
index 50d91670d9..0000000000
--- a/testing/libmemcached/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=libmemcached
-pkgver=1.0.18
-pkgrel=0
-pkgdesc="Client library and command line tools for memcached server"
-url="http://libmemcached.org/"
-arch="all"
-license="BSD"
-depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="https://launchpad.net/libmemcached/${pkgver%.*}/${pkgver}/+download/libmemcached-${pkgver}.tar.gz
- musl-fixes.patch
- "
-
-_builddir="$srcdir"/libmemcached-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --disable-static \
- --disable-sasl \
- --enable-libmemcachedprotocol \
- --enable-memaslap \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- rm "$pkgdir"/usr/lib/*.la || return 1
- return 0
-}
-
-md5sums="b3958716b4e53ddc5992e6c49d97e819 libmemcached-1.0.18.tar.gz
-de32e3cbd74c0bef8c49d50cf57ae764 musl-fixes.patch"
-sha256sums="e22c0bb032fde08f53de9ffbc5a128233041d9f33b5de022c0978a2149885f82 libmemcached-1.0.18.tar.gz
-188bc487122570ba681ec2781633a368abe5bb1613d0727235c767c25d3b155d musl-fixes.patch"
-sha512sums="2d95fea63b8b6dc7ded42c3a88a54aad74d5a1d417af1247144dae4a88c3b639a3aabc0c2b66661ff69a7609a314efaaae236e10971af9c428a4bca0a0101585 libmemcached-1.0.18.tar.gz
-ff8f59d2b6d3b7d1d110ff3f1d03dbceba3a000271e69f465ffd02e77c0a092e6904b19ac4aea624a0622cec6a16ecd048f46107e011cb9011027ef71265aaf5 musl-fixes.patch"
diff --git a/testing/libmemcached/musl-fixes.patch b/testing/libmemcached/musl-fixes.patch
deleted file mode 100644
index eb2a6bc980..0000000000
--- a/testing/libmemcached/musl-fixes.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-diff --git a/libhashkit/fnv_64.cc b/libhashkit/fnv_64.cc
-index 68e4dd0..64656b7 100644
---- a/libhashkit/fnv_64.cc
-+++ b/libhashkit/fnv_64.cc
-@@ -37,8 +37,9 @@
-
-
- #include <libhashkit/common.h>
-+#include <limits.h>
-
--#if __WORDSIZE == 64 && defined(HAVE_FNV64_HASH)
-+#if (LONG_BITS == 64) && defined(HAVE_FNV64_HASH)
-
- /* FNV hash'es lifted from Dustin Sallings work */
- static uint64_t FNV_64_INIT= 0xcbf29ce484222325;
-diff --git a/libhashkit/has.cc b/libhashkit/has.cc
-index 843e32e..4153e5e 100644
---- a/libhashkit/has.cc
-+++ b/libhashkit/has.cc
-@@ -37,6 +37,7 @@
-
-
- #include <libhashkit/common.h>
-+#include <limits.h>
-
- bool libhashkit_has_algorithm(const hashkit_hash_algorithm_t algo)
- {
-@@ -44,7 +45,7 @@ bool libhashkit_has_algorithm(const hashkit_hash_algorithm_t algo)
- {
- case HASHKIT_HASH_FNV1_64:
- case HASHKIT_HASH_FNV1A_64:
--#if __WORDSIZE == 64 && defined(HAVE_FNV64_HASH)
-+#if (LONG_BITS == 64) && defined(HAVE_FNV64_HASH)
- return true;
- #else
- return false;
-diff --git a/libtest/cmdline.cc b/libtest/cmdline.cc
-index 29a22de..161c646 100644
---- a/libtest/cmdline.cc
-+++ b/libtest/cmdline.cc
-@@ -61,7 +61,7 @@ using namespace libtest;
- #include <algorithm>
- #include <stdexcept>
-
--#ifndef __USE_GNU
-+#ifndef _GNU_SOURCE
- static char **environ= NULL;
- #endif
-
-@@ -201,7 +201,7 @@ Application::error_t Application::run(const char *args[])
-
- fatal_assert(posix_spawnattr_setsigmask(&spawnattr, &mask) == 0);
-
--#if defined(POSIX_SPAWN_USEVFORK) || defined(__linux__)
-+#if defined(POSIX_SPAWN_USEVFORK) || defined(__GLIBC__)
- // Use USEVFORK on linux
- flags |= POSIX_SPAWN_USEVFORK;
- #endif