aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2015-05-15 09:16:47 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2015-05-15 09:16:47 +0000
commit74e4cfc6ea67c2cf96e9175d4db7bab3fb57cf1f (patch)
treefe4ef034fa1af29090a2341bdacb657d2cf040e6 /testing
parentcad7f9f0921730e257ecb0f0949cee0e49fa2fb2 (diff)
downloadaports-74e4cfc6ea67c2cf96e9175d4db7bab3fb57cf1f.tar.bz2
aports-74e4cfc6ea67c2cf96e9175d4db7bab3fb57cf1f.tar.xz
testing/owncloud-client: new aport
The ownCloud Desktop Client is a tool to synchronize files from ownCloud Server with your computer Fixes #4189
Diffstat (limited to 'testing')
-rw-r--r--testing/owncloud-client/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/owncloud-client/APKBUILD b/testing/owncloud-client/APKBUILD
new file mode 100644
index 0000000000..fa534bcc82
--- /dev/null
+++ b/testing/owncloud-client/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=owncloud-client
+pkgver=1.8.1
+pkgrel=0
+pkgdesc="ownCloud Desktop Client"
+url="https://github.com/owncloud/client"
+arch="all"
+license="GPL2"
+depends=
+depends_dev=
+makedepends="$depends_dev cmake qt5-qttools-dev qt5-qtwebkit-dev qtkeychain-dev"
+install=
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/owncloud/client/archive/v1.8.1.tar.gz"
+
+
+_builddir="$srcdir"/client-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ mkdir build
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir/build"
+ cmake ..\
+ -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc/$pkgname
+ make all || return 1
+}
+
+package() {
+ cd "$_builddir/build"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="1730025ec2f922946fa4ebfda819f0f7 owncloud-client-1.8.1.tar.gz"
+sha256sums="3a30da888ca9705892b4e7b313ad0aeb4525fb97b83453540a147841f7f136bc owncloud-client-1.8.1.tar.gz"
+sha512sums="f3b99ddbb64871a6e05144f5c2129323e368da6c62adad1a3810915ad4777a950636fb0deda4014b2ba27a738c03b0654ec95a6ade4afcb4dd6df0cfbaecce78 owncloud-client-1.8.1.tar.gz"