aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2015-04-22 13:30:07 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2015-04-22 13:30:07 +0000
commit8b784408322a73bccdd074b85ea6c7b5081a6349 (patch)
treee944e6b70ba8b1e930743d677f151a291f7f830f /testing
parent1868876a2296b151e49065552892f72ee7a22820 (diff)
downloadaports-8b784408322a73bccdd074b85ea6c7b5081a6349.tar.bz2
aports-8b784408322a73bccdd074b85ea6c7b5081a6349.tar.xz
testing/patchwork: add prepare() function
Diffstat (limited to 'testing')
-rw-r--r--testing/patchwork/APKBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/testing/patchwork/APKBUILD b/testing/patchwork/APKBUILD
index 8e1b695068..8d7ca43fbb 100644
--- a/testing/patchwork/APKBUILD
+++ b/testing/patchwork/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=patchwork
pkgver=0_git20150420
-pkgrel=3
+pkgrel=4
pkgdesc="Web-based patch tracking system "
url="http://jk.ozlabs.org/projects/patchwork/"
arch="noarch"
@@ -19,6 +19,16 @@ giturl="git://ozlabs.org/home/jk/git/patchwork"
disturl="dev.alpinelinux.org:/archive/$pkgname/"
_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
build() {
cd "$_builddir"
return 0