aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-18 21:24:37 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-18 21:24:37 +0200
commit92d22870232cf5a979cd41c42a221f15ef43db37 (patch)
tree513407a97c1e80950e365e91a5ecf5a25441e8b8 /testing
parent2f2883cc10692bcb0db5997907b081268fad8d79 (diff)
downloadaports-92d22870232cf5a979cd41c42a221f15ef43db37.tar.bz2
aports-92d22870232cf5a979cd41c42a221f15ef43db37.tar.xz
testing/wxgtk: move to community
Diffstat (limited to 'testing')
-rw-r--r--testing/wxgtk/APKBUILD79
-rw-r--r--testing/wxgtk/config-allow-musl.patch21
-rw-r--r--testing/wxgtk/gcc6.patch39
3 files changed, 0 insertions, 139 deletions
diff --git a/testing/wxgtk/APKBUILD b/testing/wxgtk/APKBUILD
deleted file mode 100644
index 7148a5c44b..0000000000
--- a/testing/wxgtk/APKBUILD
+++ /dev/null
@@ -1,79 +0,0 @@
-# Contributor: Pavel Kalian <pavel@kalian.cz>
-# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
-pkgname=wxgtk
-pkgver=3.0.2
-pkgrel=0
-pkgdesc="GTK2 port of wxWidgets GUI library"
-url="http://www.wxwidgets.org/"
-arch="all"
-license="wxWidgets"
-depends=""
-depends_dev="gtk+2.0-dev mesa-dev zlib-dev tiff-dev libjpeg-turbo-dev expat-dev
- libsm-dev"
-makedepends="$depends_dev glu-dev sdl-dev gst-plugins-base0.10-dev
- gstreamer0.10-dev gconf-dev"
-install=""
-subpackages="$pkgname-dev $pkgname-lang $pkgname-media $pkgname-base"
-source="https://github.com/wxWidgets/wxWidgets/releases/download/v${pkgver}/wxWidgets-${pkgver}.tar.bz2
- config-allow-musl.patch
- gcc6.patch"
-
-builddir="$srcdir/wxWidgets-$pkgver"
-
-build() {
-cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --with-sdl \
- --with-opengl \
- --enable-unicode \
- --enable-aui \
- --enable-no_deps \
- --enable-shared \
- --enable-sound \
- --enable-mediactrl \
- --disable-rpath \
- --disable-optimise \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-dev() {
- default_dev
- mv "$pkgdir"/usr/lib/wx/config "$subpkgdir"/usr/lib/wx/ || return 1
- mv "$pkgdir"/usr/bin/wxrc* "$subpkgdir"/usr/bin/ || return 1
- mv "$pkgdir"/usr/share/bakefile "$subpkgdir"/usr/share/ || return 1
-}
-
-media() {
- pkdesc="Multimedia add-on for the wxWidgets library"
-
- mkdir -p "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/lib/libwx_gtk2u_media-*.so.* "$subpkgdir"/usr/lib/
-}
-
-base() {
- pkgdesc="Non-GUI support classes from the wxWidgets library"
- mkdir -p "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/lib/libwx_baseu-*.so.* \
- "$pkgdir"/usr/lib/libwx_baseu_net-*.so.* \
- "$pkgdir"/usr/lib/libwx_baseu_xml-*.so.* \
- "$subpkgdir"/usr/lib/
-}
-
-md5sums="ba4cd1f3853d0cd49134c5ae028ad080 wxWidgets-3.0.2.tar.bz2
-4e830ce35be68f904b80c34093153350 config-allow-musl.patch
-f624f8a0c1163a1376d43f5b57c5f39a gcc6.patch"
-sha256sums="346879dc554f3ab8d6da2704f651ecb504a22e9d31c17ef5449b129ed711585d wxWidgets-3.0.2.tar.bz2
-0517cf79f2d2bdc9132e5da2e4717f37b002bf09de77ee5dbe7a46447dee92cb config-allow-musl.patch
-6e659eb4f1cfbfe31e0da0c8719e496e16efa5be36265388a639964e4b39cf78 gcc6.patch"
-sha512sums="098f79863103f3be0b7e21e4f0f1b34ab5277ef0033c1ef1387a9c673b0e0b76a2d732b183fa11b22cfcbbfdb7a4884f243d12f65cd49baa1772852307b393c4 wxWidgets-3.0.2.tar.bz2
-dbe80fbf36afe26bbec66d93842ae849eb29e33d05b762f7eb90f933db7bd415ff174a18c9acb7e71221e9ca9fd70c0c3cebe1fd0f77f348182ddb1a640b4f62 config-allow-musl.patch
-6da02b4cdd6e4d33cfd8da5554f1400e2ccb33de7fa12d9da23a8eeac52c724fa339d2e1d413abf5f4590cf0514cf9a8d951589d3e498aae936ab10caf93f585 gcc6.patch"
diff --git a/testing/wxgtk/config-allow-musl.patch b/testing/wxgtk/config-allow-musl.patch
deleted file mode 100644
index 8e471e11ef..0000000000
--- a/testing/wxgtk/config-allow-musl.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- wxWidgets-3.0.2/config.sub
-+++ config.sub
-@@ -125,7 +125,7 @@
- maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\2/'`
- case $maybe_os in
- nto-qnx* | linux-gnu* | linux-android* | linux-dietlibc | linux-newlib* | \
-- linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
-+ linux-uclibc* | linux-musl* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
- knetbsd*-gnu* | netbsd*-gnu* | \
- kopensolaris*-gnu* | \
- storm-chaos* | os2-emx* | rtmk-nova*)
-@@ -1352,6 +1352,9 @@
- -linux-dietlibc)
- os=-linux-dietlibc
- ;;
-+ -linux-musl)
-+ os=-linux-musl
-+ ;;
- -linux*)
- os=`echo $os | sed -e 's|linux|linux-gnu|'`
- ;;
diff --git a/testing/wxgtk/gcc6.patch b/testing/wxgtk/gcc6.patch
deleted file mode 100644
index 119175c624..0000000000
--- a/testing/wxgtk/gcc6.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 73e9e18ea09ffffcaac50237def0d9728a213c02 Mon Sep 17 00:00:00 2001
-From: Scott Talbert <swt@techie.net>
-Date: Sat, 20 Feb 2016 00:08:14 -0500
-Subject: [PATCH] Fix STC compilation with GCC6
-
-Use std::abs() from <cmath> instead of abs() from <math.h> to avoid problems
-with ambiguous overloads.
-
-Closes #17147.
-
-Closes https://github.com/wxWidgets/wxWidgets/pull/222
----
- src/stc/scintilla/src/Editor.cxx | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/src/stc/scintilla/src/Editor.cxx b/src/stc/scintilla/src/Editor.cxx
-index cd72953..2081df2 100644
---- a/src/stc/scintilla/src/Editor.cxx
-+++ b/src/stc/scintilla/src/Editor.cxx
-@@ -11,6 +11,7 @@
- #include <ctype.h>
- #include <assert.h>
-
-+#include <cmath>
- #include <string>
- #include <vector>
- #include <map>
-@@ -5841,9 +5842,9 @@ void Editor::GoToLine(int lineNo) {
- }
-
- static bool Close(Point pt1, Point pt2) {
-- if (abs(pt1.x - pt2.x) > 3)
-+ if (std::abs(pt1.x - pt2.x) > 3)
- return false;
-- if (abs(pt1.y - pt2.y) > 3)
-+ if (std::abs(pt1.y - pt2.y) > 3)
- return false;
- return true;
- }