aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJean-Louis Fuchs <ganwell@fangorn.ch>2017-10-03 20:54:00 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-10-20 07:09:33 +0000
commit4654b5649c209b327774906ed888269ea84f4bd8 (patch)
treec047eec77e9b9f97fe99fa2e34f0335f40d7ec6d /testing
parent9b0882821333917b5ac26466fd02d844be11029c (diff)
downloadaports-4654b5649c209b327774906ed888269ea84f4bd8.tar.bz2
aports-4654b5649c209b327774906ed888269ea84f4bd8.tar.xz
community/py3-pyo: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-pyo/APKBUILD31
-rw-r--r--testing/py3-pyo/portaudio-only.patch14
-rw-r--r--testing/py3-pyo/remove-O3.patch12
3 files changed, 0 insertions, 57 deletions
diff --git a/testing/py3-pyo/APKBUILD b/testing/py3-pyo/APKBUILD
deleted file mode 100644
index 7f444072bb..0000000000
--- a/testing/py3-pyo/APKBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
-# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
-pkgname=py3-pyo
-_pkgname=pyo
-pkgver=0.8.7
-pkgrel=0
-pkgdesc="dedicated Python module for digital signal processing"
-url="http://ajaxsoundstudio.com/software/pyo/"
-arch="all"
-license="GPL"
-options="!check"
-depends="python3 python3-tkinter"
-makedepends="python3-dev portaudio-dev libsndfile-dev"
-source="http://ajaxsoundstudio.com/downloads/${_pkgname}_${pkgver}-src.tar.bz2
- portaudio-only.patch
- remove-O3.patch"
-builddir="$srcdir/${_pkgname}_${pkgver}-src"
-
-build() {
- cd "$builddir"
- python3 setup.py build --minimal
-}
-
-package() {
- cd "$builddir"
- python3 setup.py install --root="$pkgdir" --optimize=1
-}
-
-sha512sums="da4d80bf507f47680415712dc1092b3fafba53d344ad6944b362d5d44bd730a5789174a6d8d0b561e78ce6d9f0916064185102c57791ba986981d8cd388ad84d pyo_0.8.7-src.tar.bz2
-b3c3a659df4b9de9982898d2a6cc7462e88ee2b1c4ecac2b49a8220e42cf1c2fb583a7ca722cb2e77bed0e0b6fe3a70d88bda807ee46c9b096fe3e34514b5420 portaudio-only.patch
-bc4d319ba491b02828b3e061daa23be1421def8331550d68be18a08831526a1a890ddf76210df38bfed104ad1c1a24ac7c45770d212e308fdadb2d657c7cd333 remove-O3.patch"
diff --git a/testing/py3-pyo/portaudio-only.patch b/testing/py3-pyo/portaudio-only.patch
deleted file mode 100644
index 1a12a937d6..0000000000
--- a/testing/py3-pyo/portaudio-only.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ruN a/setup.py b/setup.py
---- a/setup.py 2017-08-29 21:04:01.704564192 +0200
-+++ b/setup.py 2017-08-29 21:04:30.369416183 +0200
-@@ -99,7 +99,9 @@
- if '--minimal' in sys.argv:
- minimal_build = True
- sys.argv.remove('--minimal')
-- libraries = []
-+ macros.append(('USE_PORTAUDIO', None))
-+ ad_files.append("ad_portaudio.c")
-+ libraries = ["portaudio"]
- else:
- minimal_build = False
- # portaudio
diff --git a/testing/py3-pyo/remove-O3.patch b/testing/py3-pyo/remove-O3.patch
deleted file mode 100644
index 513289a4c6..0000000000
--- a/testing/py3-pyo/remove-O3.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN a/setup.py b/setup.py
---- a/setup.py 2017-08-29 21:11:55.290997348 +0200
-+++ b/setup.py 2017-08-29 21:12:13.690639738 +0200
-@@ -89,7 +89,7 @@
- sys.argv.remove('--fast-compile')
- oflag = "-O0"
- else:
-- oflag = "-O3"
-+ oflag = "-Os"
-
- # Specific audio drivers source files to compile
- ad_files = []