aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorSteve McMaster <code@mcmaster.io>2017-08-19 17:04:10 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2017-08-25 21:05:05 +0000
commit53f015d9a9a57bca88e056902252a26d2cecacf8 (patch)
treee16667dc729bf5e3cdcbe25d28df373815d6ec51 /testing
parent20f49dd3ab3d6cdbe63ccebd7ef0af3938a42ac5 (diff)
downloadaports-53f015d9a9a57bca88e056902252a26d2cecacf8.tar.bz2
aports-53f015d9a9a57bca88e056902252a26d2cecacf8.tar.xz
community/suricata: Move from testing to community
Diffstat (limited to 'testing')
-rw-r--r--testing/suricata/APKBUILD62
-rw-r--r--testing/suricata/suricata.confd31
-rw-r--r--testing/suricata/suricata.initd65
-rw-r--r--testing/suricata/suricata.logrotate11
4 files changed, 0 insertions, 169 deletions
diff --git a/testing/suricata/APKBUILD b/testing/suricata/APKBUILD
deleted file mode 100644
index 115f025ad2..0000000000
--- a/testing/suricata/APKBUILD
+++ /dev/null
@@ -1,62 +0,0 @@
-# Contributor: Steve McMaster <code@mcmaster.io>
-# Maintainer: Steve McMaster <code@mcmaster.io>
-pkgname=suricata
-pkgver=4.0.0
-pkgrel=0
-pkgdesc="High performance Network IDS, IPS and Network Security Monitoring engine"
-url="https://suricata-ids.org/"
-# luajit is not available for disabled arches
-arch="all !s390x"
-license="GPL-2"
-makedepends="automake autoconf libtool libhtp-dev>=0.5.25 libcap-ng-dev
- file-dev luajit-dev geoip-dev pcre-dev yaml-dev libpcap-dev hiredis-dev
- libnet-dev libnetfilter_queue-dev libnfnetlink-dev jansson-dev python2
- nss-dev nspr-dev"
-subpackages="$pkgname-doc"
-source="http://www.openinfosecfoundation.org/download/$pkgname-$pkgver.tar.gz
- $pkgname.confd
- $pkgname.initd
- $pkgname.logrotate
- "
-builddir="$srcdir/$pkgname-$pkgver"
-
-prepare() {
- cd "$builddir"
- autoreconf -vif || return 1
-}
-
-build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --enable-non-bundled-htp \
- --enable-nfqueue \
- --disable-gccmarch-native \
- --enable-hiredis \
- --enable-geoip \
- --enable-gccprotect \
- --enable-pie \
- --enable-luajit \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
- make DESTDIR="$pkgdir" install-full || return 1
-
- cd "$srcdir"
- install -D -m 755 ../$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- install -D -m 644 ../$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
- install -D -m 644 ../$pkgname.logrotate "$pkgdir"/etc/logrotate.d/$pkgname
-}
-sha512sums="1dd386c36a74d1ab6bfa33db1dbde0dbe4f0045dc80f3304ece6b67a630b2a3eacf0b24e76f4501c55bf5ca65a7b54380da202425ca3873a06b3b5f759261453 suricata-4.0.0.tar.gz
-ed7c78a80192f3f3ed433330df323beccb6079b5413289b9e9faa3fceea2c536de93de7372968d8605abd1618d73c9319ee39d86b16eed22e7313c8667252f5d suricata.confd
-67770d953095c22bdf2786641c7f4ec402fa1093a743090278811d223fa5ff3e5987680c84e1117df8fd59306c100256b45cc3b2807a1c2296e31a7485d14b07 suricata.initd
-4f76a35bcde78c9860701897fe19bb84cc46bbc429124c4cb2e94cf3330f00ebe8067c0d7f3f83478e9b95323adb947e5081658f455657c4d03c682abe707534 suricata.logrotate"
diff --git a/testing/suricata/suricata.confd b/testing/suricata/suricata.confd
deleted file mode 100644
index 9585bdc681..0000000000
--- a/testing/suricata/suricata.confd
+++ /dev/null
@@ -1,31 +0,0 @@
-# Config file for /etc/init.d/suricata*
-
-# Where config files are stored. Default:
-
-# SURICATA_DIR="/etc/suricata"
-
-# Pass options to each suricata service.
-# You can launch more than one service at the same time with different options.
-# This can be useful in a multi-queue gateway, for example.
-# You can expand on the Suricata inline example found at:
-# https://redmine.openinfosecfoundation.org/projects/suricata/wiki/Setting_up_IPSinline_for_Linux
-# Instead of configuring iptables to send traffic to just one queue, you can configure it to "load balance"
-# on several queues. You can then have a Suricata instance processing traffic for each queue.
-# This should help improve performance on the gateway/firewall.
-# Suppose you configured iptables to use queues 0 and 1. You can now do the following:
-# ln -s /etc/init.d/suricata /etc/init.d/suricata.q0
-# ln -s /etc/init.d/suricata /etc/init.d/suricata.q1
-# cp /etc/suricata/suricata.yaml /etc/suricata/suricata-q0.yaml
-# cp /etc/suricata/suricata.yaml /etc/suricata/suricata-q1.yaml
-# mkdir /var/log/suricata/q{0,1}
-# Edit both suricata-q{0,1}.yaml files and set values accordingly (eg. set the suricata.log file path to
-# a dedicated dir in the section "logging:outputs:-file").
-# You can then define the following options here:
-
-# SURICATA_OPTS[q0]="-q 0 -l /var/log/suricata/q0"
-# SURICATA_OPTS[q1]="-q 1 -l /var/log/suricata/q1"
-
-# If you want to use ${SURICATA_DIR}/suricata.yaml and start the service with /etc/init.d/suricata
-# then you can set:
-
-SURICATA_OPTIONS="--af-packet"
diff --git a/testing/suricata/suricata.initd b/testing/suricata/suricata.initd
deleted file mode 100644
index e39312f377..0000000000
--- a/testing/suricata/suricata.initd
+++ /dev/null
@@ -1,65 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-SURICATA_DIR=${SURICATA_DIR:-/etc/suricata}
-SURICATA=${SVCNAME#*.}
-if [ -n "${SURICATA}" ] && [ ${SVCNAME} != "suricata" ]; then
- SURICATACONF="${SURICATA_DIR}/suricata-${SURICATA}.yaml"
- SURICATAPID="/var/run/suricata/suricata.${SURICATA}.pid"
-else
- SURICATACONF="${SURICATA_DIR}/suricata.yaml"
- SURICATAPID="/var/run/suricata/suricata.pid"
-fi
-SURICATAOPTS=${SURICATA_OPTIONS}
-
-extra_commands="checkconfig"
-extra_started_commands="reload"
-
-depend() {
- need net
- after firewall
-}
-
-checkconfig() {
- if [ ! -e ${SURICATACONF} ] ; then
- eerror "You need to create ${SURICATACONF} to run ${SVCNAME}."
- return 1
- fi
-}
-
-start() {
- checkconfig || return 1
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --quiet --exec /usr/bin/suricata \
- -- --pidfile ${SURICATAPID} -D ${SURICATAOPTS} \
- -c ${SURICATACONF} >/dev/null 2>&1
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --quiet --pidfile ${SURICATAPID} >/dev/null 2>&1
- einfon "Waiting for ${SVCNAME} to shut down. This can take a while..."
- echo
- # max wait: 5 minutes as it can take quite a while on some systems with heavy traffic
- cnt=300
- while [ -f ${SURICATAPID} ]; do
- cnt=$(expr $cnt - 1)
- if [ $cnt -lt 1 ] ; then
- echo
- eend 1 "Failed."
- break
- fi
- sleep 1
- echo -ne "$cnt seconds left before we give up\r"
- done
- eend $?
-}
-
-reload() {
- checkconfig || return 1
- ebegin "Reloading ${SVCNAME}"
- start-stop-daemon --signal HUP --pidfile ${SURICATAPID}
-}
diff --git a/testing/suricata/suricata.logrotate b/testing/suricata/suricata.logrotate
deleted file mode 100644
index f09690a792..0000000000
--- a/testing/suricata/suricata.logrotate
+++ /dev/null
@@ -1,11 +0,0 @@
-/var/log/suricata/*.log /var/log/suricata/*.json
-{
- rotate 3
- missingok
- nocompress
- create
- sharedscripts
- postrotate
- /bin/kill -HUP $(cat /var/run/suricata/suricata.pid)
- endscript
-}