aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-06-30 00:14:21 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-06-30 00:14:53 +0200
commit66790ac3afeb2fe0dca14337a9e036c792b8e9cc (patch)
tree18be3230125870b61dcbb5aedfd5ecbe263d8614 /testing
parent430209682f76651efadf255116830965ed295d5c (diff)
downloadaports-66790ac3afeb2fe0dca14337a9e036c792b8e9cc.tar.bz2
aports-66790ac3afeb2fe0dca14337a9e036c792b8e9cc.tar.xz
testing/py-ldap3: new aport
https://github.com/cannatag/ldap3 A strictly RFC 4510 conforming LDAP V3 pure Python client
Diffstat (limited to 'testing')
-rw-r--r--testing/py-ldap3/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/py-ldap3/APKBUILD b/testing/py-ldap3/APKBUILD
new file mode 100644
index 0000000000..d0a08fd98c
--- /dev/null
+++ b/testing/py-ldap3/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=py-ldap3
+_pkgname=ldap3
+pkgver=2.2.3
+pkgrel=0
+pkgdesc="A strictly RFC 4510 conforming LDAP V3 pure Python client"
+url="https://github.com/cannatag/ldap3"
+arch="noarch"
+license="LGPL3"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-$_pkgname:_subpackage py3-$_pkgname:_subpackage"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cannatag/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+options="!check" # tests need running LDAP server
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_subpackage() {
+ local python="python${subpkgname:2:1}"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="5b67f8f2008f389a481d738070dc2ef445c85c70e4e2b1e5e8555763c6fae581802abdd085d56adbe42c22f49744af358850dc167407170080f7e3497b31963b py-ldap3-2.2.3.tar.gz"