aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-04 09:40:57 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-04 09:40:57 +0000
commite5f2b2aa996b15345d561e3e942b70ef1ab3a161 (patch)
tree695e489e360fd443f5d8f2a2563d8938eaaa29a5 /testing
parent6f8f403f2894dcca1eb797753457b699dc4ce0d2 (diff)
downloadaports-e5f2b2aa996b15345d561e3e942b70ef1ab3a161.tar.bz2
aports-e5f2b2aa996b15345d561e3e942b70ef1ab3a161.tar.xz
testing/lua-rapidjson: produce i586 code
Diffstat (limited to 'testing')
-rw-r--r--testing/lua-rapidjson/APKBUILD9
-rw-r--r--testing/lua-rapidjson/disable-c-cxx-flag-march.patch13
2 files changed, 19 insertions, 3 deletions
diff --git a/testing/lua-rapidjson/APKBUILD b/testing/lua-rapidjson/APKBUILD
index 662c483914..b67b28b0e9 100644
--- a/testing/lua-rapidjson/APKBUILD
+++ b/testing/lua-rapidjson/APKBUILD
@@ -2,14 +2,16 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=lua-rapidjson
pkgver=0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="A JSON module for Lua based on the very fast RapidJSON library"
url="https://github.com/xpol/lua-rapidjson"
arch="all"
license="MIT"
makedepends="cmake rapidjson-dev"
subpackages=""
-source="$pkgname-$pkgver.tar.gz::https://github.com/xpol/$pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/xpol/$pkgname/archive/v$pkgver.tar.gz
+ disable-c-cxx-flag-march.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
_luaversions="5.1 5.2 5.3"
@@ -61,4 +63,5 @@ _subpackage() {
"$subpkgdir"/$install_cmod/rapidjson.so
}
-sha512sums="eb07792d01d6bf32d2ccec244fd5f55ce3e66b356b8e61f0dd86b7e6c4a5a582ab8cb64e2af1f79628e85409e60bf2edd05e2bff12be4987650d948baf246ef3 lua-rapidjson-0.5.0.tar.gz"
+sha512sums="eb07792d01d6bf32d2ccec244fd5f55ce3e66b356b8e61f0dd86b7e6c4a5a582ab8cb64e2af1f79628e85409e60bf2edd05e2bff12be4987650d948baf246ef3 lua-rapidjson-0.5.0.tar.gz
+9bfe86c75765d0684f33b660129c3ab90629b8518b05d14aa99ea15e6eb39dcb0a56e9a705f2dcae0f463e7ed92c8759628b0fbdaeee43aff34ac7e5b6c6bf10 disable-c-cxx-flag-march.patch"
diff --git a/testing/lua-rapidjson/disable-c-cxx-flag-march.patch b/testing/lua-rapidjson/disable-c-cxx-flag-march.patch
new file mode 100644
index 0000000000..eb9a8d900d
--- /dev/null
+++ b/testing/lua-rapidjson/disable-c-cxx-flag-march.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -33,8 +33,8 @@
+ set(PLAT "linux")
+ set(LINK_FLAGS "-shared")
+ endif(APPLE)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -Wall -fPIC -march=native")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g -Wall -fPIC -march=native")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -Wall -fPIC")
++ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g -Wall -fPIC")
+ else(UNIX)
+ if(WIN32)
+ set(PLAT "win32")