aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2014-07-11 17:17:22 +0300
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2014-07-11 17:23:02 +0300
commit2f4fe7a3dec8be69a248e4086b4c99f9135541e7 (patch)
tree7510224b4f187bc2d9eb4b2e5ca2d538acc0a9bf /testing
parent56b3caa54422c3e2a4e924dd51c07b346f62068b (diff)
downloadaports-2f4fe7a3dec8be69a248e4086b4c99f9135541e7.tar.bz2
aports-2f4fe7a3dec8be69a248e4086b4c99f9135541e7.tar.xz
main/lua-stringy: upgrade to 0.4 and support Lua 5.2
Diffstat (limited to 'testing')
-rw-r--r--testing/lua5.2-stringy/0001-use-memcmp-for-startswith-endswith.patch78
-rw-r--r--testing/lua5.2-stringy/APKBUILD43
-rw-r--r--testing/lua5.2-stringy/stringy-memcmp.patch64
3 files changed, 0 insertions, 185 deletions
diff --git a/testing/lua5.2-stringy/0001-use-memcmp-for-startswith-endswith.patch b/testing/lua5.2-stringy/0001-use-memcmp-for-startswith-endswith.patch
deleted file mode 100644
index 4680a05615..0000000000
--- a/testing/lua5.2-stringy/0001-use-memcmp-for-startswith-endswith.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From 86e4e9d16befd02230a699f045afdd68a47f6122 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 12 Oct 2011 20:57:55 +0200
-Subject: [PATCH] use memcmp for startswith/endswith
-
-This fixes an uninitialized variable bug and should be faster since
-most libc has optimized memcmp()
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- stringy/stringy.c | 43 +++++++++++++------------------------------
- 1 files changed, 13 insertions(+), 30 deletions(-)
-
-diff --git a/stringy/stringy.c b/stringy/stringy.c
-index 3341b87..aa9a2a2 100644
---- a/stringy/stringy.c
-+++ b/stringy/stringy.c
-@@ -65,44 +65,27 @@ static int endswith(lua_State *L) {
-
- size_t token_len;
- const char *token = luaL_checklstring(L, 2, &token_len);
-+ int end = 0;
-
-- int ti = token_len, si = string_len, end = 1;
-- if(token_len <= string_len){
-- while(ti > 0) {
-- if(string[--si] != token[--ti]){
-- end = 0;
-- break;
--
-- }
-- }
-- }
-- else {
-- end = 0;
-+ if(token_len <= string_len) {
-+ string += string_len - token_len;
-+ end = memcmp(string, token, token_len) == 0;
- }
- lua_pushboolean(L, end);
- return 1;
- }
-
- static int startswith(lua_State *L) {
-- const char *string = luaL_checkstring(L, 1);
-- int string_len = lua_objlen(L, 1);
-+ size_t string_len;
-+ const char *string = luaL_checklstring(L, 1, &string_len);
-+
-+ size_t token_len;
-+ const char *token = luaL_checklstring(L, 2, &token_len);
-+ int start = 0;
-+
-+ if (token_len <= string_len)
-+ start = memcmp(string, token, token_len) == 0;
-
-- const char *token = luaL_checkstring(L, 2);
-- int token_len = lua_objlen(L, 2);
-- int i, start = 1;
-- // please make this less ugly...
-- if(token_len <= string_len){
-- while(i < token_len) {
-- if(string[i] != token[i]){
-- start = 0;
-- break;
-- }
-- i++;
-- }
-- }
-- else {
-- start = 0;
-- }
- lua_pushboolean(L, start);
- return 1;
- }
---
-1.7.7
-
diff --git a/testing/lua5.2-stringy/APKBUILD b/testing/lua5.2-stringy/APKBUILD
deleted file mode 100644
index 0e19d07199..0000000000
--- a/testing/lua5.2-stringy/APKBUILD
+++ /dev/null
@@ -1,43 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-_luaver=5.2
-pkgname=lua${_luaver}-stringy
-pkgver=0.4
-pkgrel=1
-pkgdesc="Lua string utility library"
-url="https://code.google.com/p/bpbio/downloads/list"
-arch="all"
-license="MIT"
-depends=""
-makedepends="lua${_luaver}-dev"
-install=""
-subpackages=""
-source="lua-projects-$pkgver.tar.gz::https://github.com/brentp/lua-projects/archive/$pkgver.tar.gz"
-
-_builddir="$srcdir"/lua-projects-$pkgver/stringy
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- make CC="${CC:-gcc}" CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" \
- LUA_PC="lua$_luaver" LUA="lua$_luaver" || return 1
-}
-
-package() {
- local _lualibdir=/usr/lib/lua/$_luaver
- cd "$_builddir"
- mkdir -p "$pkgdir"/$_lualibdir
- cp stringy.so "$pkgdir"/$_lualibdir/
-}
-
-md5sums="cac1787756fe42151d7b60df9f19c9e3 lua-projects-0.4.tar.gz"
-sha256sums="72a800d2e3e1cc13fbf458ad5cbc06b8ea705afedfe72221dbe9e7cec935721e lua-projects-0.4.tar.gz"
-sha512sums="7bcd5449a99e5e1633e9cd1175208f1cde65a8dddbd9a06726c16518805387a5d3809fc7644fae090c4f3e948ed1364911e12d923fc26dbf5378c8adb1a07b3a lua-projects-0.4.tar.gz"
diff --git a/testing/lua5.2-stringy/stringy-memcmp.patch b/testing/lua5.2-stringy/stringy-memcmp.patch
deleted file mode 100644
index d9019b79cc..0000000000
--- a/testing/lua5.2-stringy/stringy-memcmp.patch
+++ /dev/null
@@ -1,64 +0,0 @@
---- ./stringy.c.orig
-+++ ./stringy.c
-@@ -8,49 +8,27 @@
-
-
- static int endswith(lua_State *L) {
-- const char *string = luaL_checkstring(L, 1);
-- int string_len = lua_objlen(L, 1);
-+ size_t string_len, token_len;
-+ const char *string = luaL_checklstring(L, 1, &string_len);
-+ const char *token = luaL_checklstring(L, 2, &token_len);
-+ int end = 0;
-
-- const char *token = luaL_checkstring(L, 2);
-- int token_len = lua_objlen(L, 2);
--
-- int ti = token_len, si = string_len, end = 1;
- if(token_len <= string_len){
-- while(ti > 0) {
-- if(string[--si] != token[--ti]){
-- end = 0;
-- break;
--
-- }
-- }
-+ string += string_len - token_len;
-+ end = memcmp(string, token, token_len) == 0;
- }
-- else {
-- end = 0;
-- }
- lua_pushboolean(L, end);
- return 1;
- }
-
- static int startswith(lua_State *L) {
-- const char *string = luaL_checkstring(L, 1);
-- int string_len = lua_objlen(L, 1);
-+ size_t string_len, token_len;
-+ const char *string = luaL_checklstring(L, 1, &string_len);
-+ const char *token = luaL_checklstring(L, 2, &token_len);
-+ int start = 0;
-
-- const char *token = luaL_checkstring(L, 2);
-- int token_len = lua_objlen(L, 2);
-- int i, start = 1;
-- // please make this less ugly...
-- if(token_len <= string_len){
-- while(i < token_len) {
-- if(string[i] != token[i]){
-- start = 0;
-- break;
-- }
-- i++;
-- }
-- }
-- else {
-- start = 0;
-- }
-+ if(token_len <= string_len)
-+ start = memcmp(string, token, token_len) == 0;
- lua_pushboolean(L, start);
- return 1;
- }