aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2010-12-30 23:51:22 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-01-01 22:00:04 -0600
commite5ac3befd715790e9be23909458b4db5b1d8921d (patch)
tree12b8435502d82b7dd37d098fd4634735651ab80c /testing
parentb6fc756fdef7522cc740448075192a31591ee10a (diff)
downloadaports-e5ac3befd715790e9be23909458b4db5b1d8921d.tar.bz2
aports-e5ac3befd715790e9be23909458b4db5b1d8921d.tar.xz
testing/indent: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/indent/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/indent/APKBUILD b/testing/indent/APKBUILD
new file mode 100644
index 0000000000..2c9d0cfbe0
--- /dev/null
+++ b/testing/indent/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=indent
+pkgver=2.2.10
+pkgrel=0
+pkgdesc="indenting utility"
+url="http://www.gnu.org/software/indent/"
+license="GPL"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-doc"
+source="http://astromirror.uchicago.edu/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+arch="all"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="be35ea62705733859fbf8caf816d8959 indent-2.2.10.tar.gz"