aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-01-10 11:56:59 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-01-10 11:56:59 +0000
commit02971fb71d77ec11f24b66b6c18d5b95c103c3b4 (patch)
tree8e73cd9c075a595921e3114e34b8ca37d6904aff /testing
parent0702519f6bae6e283939c17ec121c30e829d5981 (diff)
downloadaports-02971fb71d77ec11f24b66b6c18d5b95c103c3b4.tar.bz2
aports-02971fb71d77ec11f24b66b6c18d5b95c103c3b4.tar.xz
testing/icingaweb2: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/icingaweb2/APKBUILD76
1 files changed, 76 insertions, 0 deletions
diff --git a/testing/icingaweb2/APKBUILD b/testing/icingaweb2/APKBUILD
new file mode 100644
index 0000000000..cb365bb875
--- /dev/null
+++ b/testing/icingaweb2/APKBUILD
@@ -0,0 +1,76 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=icingaweb2
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="Web Interface for Icinga2"
+url="http://www.icinga.org"
+arch="noarch"
+license="GPL"
+depends="php php-gd php-ldap php-intl php-pgsql php-mysql php-gettext php-ctype icinga2"
+depends_dev=""
+makedepends="$depends_dev"
+pkggroups="www-data"
+install=""
+subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/${pkgname}/archive/v${pkgver}.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ return 0
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir/etc/$pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/webapps/$pkgname"
+ mkdir -p "$pkgdir/var/log/$pkgname"
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname"
+ cp -r application doc library modules public bin "$pkgdir"/usr/share/webapps/$pkgname
+ ln -s /usr/share/webapps/icingaweb2/bin/icingacli "$pkgdir"/usr/bin/icingacli
+ cp -r etc/schema "$pkgdir"/usr/share/$pkgname
+ chmod 2770 "$pkgdir"/etc/$pkgname
+ chmod 750 "$pkgdir"/var/log/$pkgname
+ chgrp -R $pkggroups "$pkgdir"/etc/$pkgname
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/icingaweb2/LICENSE"
+
+ cat >"$pkgdir"/usr/share/doc/$pkgname/README.alpine <<EOF
+You need to change the owner of log dir according with the user of your webserver:
+
+For nginx, as example:
+ # chown -R nginx /var/log/icingaweb2
+
+For Apache:
+ # chown -R apache /var/log/icingaweb2
+
+For lighttpd:
+ # chown -R lighttpd /var/log/icingaweb2
+
+Also, you may remove the user of your webserver from group 'icingacmd' if no other icinga web interface is installed.
+EOF
+}
+
+bashcomp() {
+ depends="bash"
+ pkgdesc="Bash completions for $pkgname"
+ arch="noarch"
+ cd "$_builddir"
+ mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
+ mv etc/bash_completion.d/icingacli "$subpkgdir"/usr/share/bash-completion/completions/icingacli
+}
+
+md5sums="8b2e8ad789b5cf31f5fac38a7513a301 icingaweb2-2.1.0.tar.gz"
+sha256sums="1fa15efe4056eca4012358d009da1b90c4b4dd3e18d446de33eeaa48728389fd icingaweb2-2.1.0.tar.gz"
+sha512sums="fa694bdaba51b82c33b8fd726807df4c626cd944f1d2949cc8768df3e9bbebdb78888f6aaeba2e88f1f843dab8608d69e1b69f6630e438ab9854d3c8b99f4502 icingaweb2-2.1.0.tar.gz"