aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2012-10-12 15:21:27 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2012-10-12 15:21:37 +0200
commit7768da3902655d7882ab9016a538b06df28bedcc (patch)
treebba784e5ac328f2dcd044279e9c3a18650b9a429 /testing
parent231dd7925050964f9185e54565b8c20868ca3d66 (diff)
downloadaports-7768da3902655d7882ab9016a538b06df28bedcc.tar.bz2
aports-7768da3902655d7882ab9016a538b06df28bedcc.tar.xz
testing/faenza-icon-theme: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/faenza-icon-theme/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/faenza-icon-theme/APKBUILD b/testing/faenza-icon-theme/APKBUILD
new file mode 100644
index 0000000000..7a17bdc8af
--- /dev/null
+++ b/testing/faenza-icon-theme/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+
+pkgname=faenza-icon-theme
+pkgver=1.2
+pkgrel=0
+pkgdesc="Icon theme designed for Equinox GTK theme"
+url="http://gnome-look.org/content/show.php/Faenza?content=128143"
+license="GPL3"
+arch="noarch"
+depends=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+_themes="Faenza Faenza-Ambiance Faenza-Dark Faenza-Darker Faenza-Darkest Faenza-Radiance"
+source="http://ppa.launchpad.net/tiheum/equinox/ubuntu/pool/main/f/${pkgname}/${pkgname}_${pkgver}.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "${pkgdir}"/usr/share/icons
+ local theme
+ for theme in $_themes; do
+ cp -rf $theme "${pkgdir}"/usr/share/icons/
+ done;
+ # set the Linux Dristributor and start menu logo
+ for theme in Faenza Faenza-Dark; do
+ for size in 22 24 32 48 64 96; do
+ cd "${pkgdir}"/usr/share/icons/${theme}/places/${size}/
+ ln -sf distributor-logo.png distributor-logo-alpinelinux.png
+ ln -sf start-here.png start-here-alpinelinux.png
+ done;
+ cd "${pkgdir}"/usr/share/icons/${theme}/places/scalable/
+ ln -sf distributor-logo.svg distributor-logo-alpinelinux.svg
+ ln -sf start-here.svg start-here-alpinelinux.svg
+ ln -sf start-here.svg start-here-alpinelinux-symbolic.svg start-here-synbolic.svg
+ done;
+}
+md5sums="eae3e09a92c4dfd2749b3c46355194fb faenza-icon-theme_1.2.tar.gz"