aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-04-23 10:04:23 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-04-23 10:04:23 +0200
commitcd463e40cd7a1572c3a6c5d0d02e0a3ac2f0f65f (patch)
tree453afa3d32b249a5b401bba57d615426e1cc9224 /testing
parent78e5e1a4aa06c998b94dfe1de9a8ec879cecfa1c (diff)
downloadaports-cd463e40cd7a1572c3a6c5d0d02e0a3ac2f0f65f.tar.bz2
aports-cd463e40cd7a1572c3a6c5d0d02e0a3ac2f0f65f.tar.xz
testing/patchwork: add pwclient subpkg
Diffstat (limited to 'testing')
-rw-r--r--testing/patchwork/0001-pwclient-set-default-url-to-alpine-patchwork.patch25
-rw-r--r--testing/patchwork/APKBUILD24
2 files changed, 43 insertions, 6 deletions
diff --git a/testing/patchwork/0001-pwclient-set-default-url-to-alpine-patchwork.patch b/testing/patchwork/0001-pwclient-set-default-url-to-alpine-patchwork.patch
new file mode 100644
index 0000000000..511e9042f1
--- /dev/null
+++ b/testing/patchwork/0001-pwclient-set-default-url-to-alpine-patchwork.patch
@@ -0,0 +1,25 @@
+From 304b9f210a6edccc33b5ead321b43f02884aca62 Mon Sep 17 00:00:00 2001
+From: Carlo Landmeter <clandmeter@gmail.com>
+Date: Thu, 23 Apr 2015 10:01:18 +0200
+Subject: [PATCH] pwclient set default url to alpine patchwork
+
+---
+ apps/patchwork/bin/pwclient | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/apps/patchwork/bin/pwclient b/apps/patchwork/bin/pwclient
+index 2a80981..b1adad3 100755
+--- a/apps/patchwork/bin/pwclient
++++ b/apps/patchwork/bin/pwclient
+@@ -35,7 +35,7 @@ import re
+ # This script will check the PW_XMLRPC_URL environment variable
+ # for the URL to access. If that is unspecified, it will fallback to
+ # the hardcoded default value specified here.
+-DEFAULT_URL = "http://patchwork/xmlrpc/"
++DEFAULT_URL = "http://patchwork.alpinelinux.org/xmlrpc/"
+ CONFIG_FILE = os.path.expanduser('~/.pwclientrc')
+
+ class Filter:
+--
+2.3.5
+
diff --git a/testing/patchwork/APKBUILD b/testing/patchwork/APKBUILD
index 8d7ca43fbb..7a1eb129cb 100644
--- a/testing/patchwork/APKBUILD
+++ b/testing/patchwork/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=patchwork
pkgver=0_git20150420
-pkgrel=4
+pkgrel=5
pkgdesc="Web-based patch tracking system "
url="http://jk.ozlabs.org/projects/patchwork/"
arch="noarch"
@@ -11,10 +11,12 @@ depends="py-django1.5 py-django-registration git"
depends_dev=""
makedepends="$depends_dev"
install=""
-subpackages="$pkgname-doc $pkgname-apache2-wsgi:apache2_wsgi $pkgname-mysql $pkgname-postgresql"
+subpackages="$pkgname-doc $pkgname-apache2-wsgi:apache2_wsgi $pkgname-mysql
+ $pkgname-postgresql pwclient:pwclient"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
0001-support-busybox-readlink.patch
- 0001-use-webapps-dir-structure.patch"
+ 0001-use-webapps-dir-structure.patch
+ 0001-pwclient-set-default-url-to-alpine-patchwork.patch"
giturl="git://ozlabs.org/home/jk/git/patchwork"
disturl="dev.alpinelinux.org:/archive/$pkgname/"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -67,12 +69,22 @@ postgresql() {
mkdir -p "$subpkgdir"
}
+pwclient() {
+ pkgdesc="command-line client for patchwork"
+ depends="python"
+ install -Dm775 "$pkgdir"/usr/share/webapps/patchwork/apps/patchwork/bin/pwclient \
+ "$subpkgdir"/usr/bin/pwclient || return 1
+}
+
md5sums="d327c8ca2f219f597855afadaa520c1d patchwork-0_git20150420.tar.gz
597e39e9742fa8352b3d34f59f8d404e 0001-support-busybox-readlink.patch
-629ebd3fa8ed122b319a73161367c9c1 0001-use-webapps-dir-structure.patch"
+629ebd3fa8ed122b319a73161367c9c1 0001-use-webapps-dir-structure.patch
+82d64c7d30a19789798af8630b7b4da7 0001-pwclient-set-default-url-to-alpine-patchwork.patch"
sha256sums="769f6839f4e25321ecedaf8e7561e1a5e71e2fdb942c33aefb0798f651ed0914 patchwork-0_git20150420.tar.gz
b87b6ab985e30e75d641d31cfae76420eb3dc5e90b7484f217dd92454e3495af 0001-support-busybox-readlink.patch
-6266599432e20b2c638023417346d94840e4fbaaedd1899895904315376ad50f 0001-use-webapps-dir-structure.patch"
+6266599432e20b2c638023417346d94840e4fbaaedd1899895904315376ad50f 0001-use-webapps-dir-structure.patch
+dc188344123594add1a3140e8f02d8fc453b06dc0237110f11e7d43791b9a00d 0001-pwclient-set-default-url-to-alpine-patchwork.patch"
sha512sums="5e0f93afa3d9afbb97a7e44e355f0f6fae87e77ea8a7d960637984f8f33751a0acd937efc583e6ec6405ca3ff7eb86d100b8ae66e565961afac572fd72587a25 patchwork-0_git20150420.tar.gz
09fc0d88ce766bce53a0789276e6ad3e52049771e3945ae6a9e6b61cc706f5a44d398de5ae23055b2d205fd3844b84fca538617142e194c5ca149263b9afa0bb 0001-support-busybox-readlink.patch
-429df7faef59701d3754b001a0834fe4a91c13f20a2f50d407d21b145f167ce241fea046e8c251b1993c2e8b7e0aeb29bf69227446ca2236db0e5dd576f38477 0001-use-webapps-dir-structure.patch"
+429df7faef59701d3754b001a0834fe4a91c13f20a2f50d407d21b145f167ce241fea046e8c251b1993c2e8b7e0aeb29bf69227446ca2236db0e5dd576f38477 0001-use-webapps-dir-structure.patch
+1a5007f28ca7f1ed98dfa7c43e4388d76833d6f80b102e30f850517d8ceb1c86277c0c9c048a8987ede20001bc208e2be8147d20ec9354216bd2e751c72ebc97 0001-pwclient-set-default-url-to-alpine-patchwork.patch"