aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 12:30:02 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 13:00:04 +0000
commitd6d38dc6bf326fe55513628786326191caa5922e (patch)
tree328f3cc0a759cca91436f5e6c9011895d4476082 /testing
parenta082773b9d06ab7dd28ae42cc267faaaa764b5ee (diff)
downloadaports-d6d38dc6bf326fe55513628786326191caa5922e.tar.bz2
aports-d6d38dc6bf326fe55513628786326191caa5922e.tar.xz
community/vpcs: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/vpcs/APKBUILD36
-rw-r--r--testing/vpcs/musl-fixes.patch26
2 files changed, 0 insertions, 62 deletions
diff --git a/testing/vpcs/APKBUILD b/testing/vpcs/APKBUILD
deleted file mode 100644
index 9a6023ff3f..0000000000
--- a/testing/vpcs/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=vpcs
-pkgver=0.8
-pkgrel=0
-pkgdesc="Simple virtual PC simulator"
-url="http://sourceforge.net/projects/vpcs/"
-arch="x86 x86_64"
-license="BSD"
-depends=""
-depends_dev=""
-makedepends="$depends_dev linux-headers bsd-compat-headers"
-install=""
-subpackages=""
-source="https://github.com/GNS3/${pkgname}/archive/v${pkgver}beta1.tar.gz
- musl-fixes.patch"
-
-builddir="$srcdir"/$pkgname-${pkgver}beta1/src
-build() {
- cd "$builddir"
-# patch -p2 < "$srcdir"/header-fixes.fix
- ./mk.sh $(getconf LONG_BIT)
-}
-
-package() {
- cd "$builddir"
- mkdir -p "$pkgdir/usr/bin"
- install -Dm755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
-}
-
-md5sums="c02fa7181e6a66403318b3680368ae53 v0.8beta1.tar.gz
-307cad46d45a35688e1e839eb46c4244 musl-fixes.patch"
-sha256sums="769358f29353001f6eb374a49fe6569b36b46b2730166e8e11633c6dbdaaff92 v0.8beta1.tar.gz
-9ed5548a0b0346ac976ea4758ab166bc5006f8b85a8d18caa6a9839712d38d44 musl-fixes.patch"
-sha512sums="9d090613c3d59c9952d89739eb4fbdcf67f45f26e19e2999d94f82b5f026cc263265f33eea7db56d6fae8c59d4b954ee184d4bfe80d7dd22ae08c5d6f9090486 v0.8beta1.tar.gz
-b0ffc373e436e93a959b3d0ce30de9415cad1e761aae27444d1c99ac585cab9676d939143248d55334e1e0cefcbfa2ae75943fd74eec2221d7292f349aa334c7 musl-fixes.patch"
diff --git a/testing/vpcs/musl-fixes.patch b/testing/vpcs/musl-fixes.patch
deleted file mode 100644
index d0b5c80dc5..0000000000
--- a/testing/vpcs/musl-fixes.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git src/remote.c src/remote.c
-index ba971fb..56a19de 100644
---- src/remote.c
-+++ src/remote.c
-@@ -34,6 +34,8 @@
- #include <sys/ioctl.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
-+#include <netinet/tcp.h>
-+#include <sys/types.h>
- #include <arpa/inet.h>
-
- #include <net/if.h>
-
-diff --git src/hv.c src/hv.c
-index bea2636..bf5cc07 100644
---- src/hv.c
-+++ src/hv.c
-@@ -42,7 +42,6 @@
- #include <fcntl.h>
-
- #include <libgen.h>
--#include <getopt.h>
- #include <pthread.h>
- #include <termios.h>
-