aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-01 12:07:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-01 12:07:21 +0000
commitfc784608066dc70bfae6c8c59cb970078bea66b9 (patch)
treeef7d9436c8698ff69a37ef49295adeab85648cd1 /testing
parent08128327595196f596dc72d540059184aec03e16 (diff)
downloadaports-fc784608066dc70bfae6c8c59cb970078bea66b9.tar.bz2
aports-fc784608066dc70bfae6c8c59cb970078bea66b9.tar.xz
testing/perl-http-body: new aport
HTTP::Body perl module http://search.cpan.org/dist/HTTP-Body/
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-http-body/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/perl-http-body/APKBUILD b/testing/perl-http-body/APKBUILD
new file mode 100644
index 0000000000..e8a266e6b2
--- /dev/null
+++ b/testing/perl-http-body/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-http-body
+pkgver=1.12
+pkgrel=0
+pkgdesc="HTTP::Body perl module"
+url="http://search.cpan.org/dist/HTTP-Body/"
+arch="noarch"
+license="GPLv2 or Artistic"
+depends="perl perl-http-message perl-uri"
+makedepends="perl-dev perl-test-deep"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/G/GE/GETTY/HTTP-Body-$pkgver.tar.gz"
+
+_builddir="$srcdir"/HTTP-Body-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make && make test || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="6546d9a91362b06b67264f374f0b2fab HTTP-Body-1.12.tar.gz"