aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-06-09 12:42:38 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-06-09 12:42:38 +0000
commit0a3659917d0b121c5cba3d7f3a98bde5fa353f9b (patch)
treec15c8f87a4c33126bd2cc83015037d9c37c1ada6 /testing
parenta06c430fdc74dc63845c922dc75255afdbb1b887 (diff)
downloadaports-0a3659917d0b121c5cba3d7f3a98bde5fa353f9b.tar.bz2
aports-0a3659917d0b121c5cba3d7f3a98bde5fa353f9b.tar.xz
testing/py-urllib3: upgrade to 1.21.1
Diffstat (limited to 'testing')
-rw-r--r--testing/py-urllib3/APKBUILD46
1 files changed, 33 insertions, 13 deletions
diff --git a/testing/py-urllib3/APKBUILD b/testing/py-urllib3/APKBUILD
index 7bd5887cfb..99aaa36706 100644
--- a/testing/py-urllib3/APKBUILD
+++ b/testing/py-urllib3/APKBUILD
@@ -2,29 +2,49 @@
# Maintainer: Yura Kushnir <kushnir.yura@gmail.com>
pkgname=py-urllib3
_pkgname=${pkgname/py-/}
-pkgver=1.18
+pkgver=1.21.1
pkgrel=0
pkgdesc="HTTP library with thread-safe connection pooling, file post, and more."
url="https://github.com/shazow/urllib3"
arch="noarch"
license="MIT"
-depends=""
-depends_dev=""
-makedepends="$depends_dev py-setuptools"
-install=""
-subpackages=""
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="$pkgname-$pkgver.zip::https://github.com/shazow/urllib3/archive/$pkgver.zip"
-_builddir="$srcdir"/$_pkgname-$pkgver
+builddir="$srcdir"/$_pkgname-$pkgver
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
build() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py build
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --root="$pkgdir" --optimize=1
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
}
-md5sums="a5c3fd74a8d72803b0a9b19bdcb4d99f py-urllib3-1.18.zip"
-sha256sums="24b0213a304ebd4da902dfdcc5a9cc6abff788f6f10e85aea5f77b463bb72e15 py-urllib3-1.18.zip"
-sha512sums="535639543c5258be236f2098c74d0e089687a82f9c39c77d967da5e57f5cdc42506375bf4ee5ee209b57f9b0a4e56144a38e3addff6754ff380fe3fc20b5aaab py-urllib3-1.18.zip"
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="01750e8f970d7cb31c155f2294172fdab8cbd311787b44a1d6dedb40b1b5e21d5c694f5f2ca3e24c68751f596f4ad6f3b9876d2614c46dde72b66c081b96a220 py-urllib3-1.21.1.zip"