aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMitch Tishmack <mitch.tishmack@gmail.com>2017-01-29 17:22:56 -0600
committerTimo Teräs <timo.teras@iki.fi>2017-02-21 06:41:18 +0000
commit53cbf43b38c812ae66cd36838514fc6324120618 (patch)
treeada3e365446addd121a356c85ddc06fe1e0a98d5 /testing
parentaf7ac9fbe296060f2ea7a5067edb298e7c31a3a2 (diff)
downloadaports-53cbf43b38c812ae66cd36838514fc6324120618.tar.bz2
aports-53cbf43b38c812ae66cd36838514fc6324120618.tar.xz
testing/ucl: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/ucl/0001-Static-assert.patch34
-rw-r--r--testing/ucl/APKBUILD31
2 files changed, 65 insertions, 0 deletions
diff --git a/testing/ucl/0001-Static-assert.patch b/testing/ucl/0001-Static-assert.patch
new file mode 100644
index 0000000000..bdf4900384
--- /dev/null
+++ b/testing/ucl/0001-Static-assert.patch
@@ -0,0 +1,34 @@
+From: Robert Luberda <robert@debian.org>
+Date: Sat, 2 Jul 2016 22:23:20 +0200
+Subject: Switch to _Static_assert
+
+Use _Static_assert for compile-time assertion to fix
+build failures with gcc-6 (closes: #811707)
+---
+ acc/acc_defs.h | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/acc/acc_defs.h b/acc/acc_defs.h
+index 866b7bd..5ee3761 100644
+--- a/acc/acc_defs.h
++++ b/acc/acc_defs.h
+@@ -87,6 +87,9 @@
+
+ /* This can be put into a header file but may get ignored by some compilers. */
+ #if !defined(ACC_COMPILE_TIME_ASSERT_HEADER)
++# define ACC_COMPILE_TIME_ASSERT_HEADER(e) _Static_assert(e, #e);
++#endif
++#if !defined(ACC_COMPILE_TIME_ASSERT_HEADER)
+ # if (ACC_CC_AZTECC || ACC_CC_ZORTECHC)
+ # define ACC_COMPILE_TIME_ASSERT_HEADER(e) extern int __acc_cta[1-!(e)];
+ # elif (ACC_CC_DMC || ACC_CC_SYMANTECC)
+@@ -100,6 +103,9 @@
+
+ /* This must appear within a function body. */
+ #if !defined(ACC_COMPILE_TIME_ASSERT)
++# define ACC_COMPILE_TIME_ASSERT(e) _Static_assert(e, #e);
++#endif
++#if !defined(ACC_COMPILE_TIME_ASSERT)
+ # if (ACC_CC_AZTECC)
+ # define ACC_COMPILE_TIME_ASSERT(e) {typedef int __acc_cta_t[1-!(e)];}
+ # elif (ACC_CC_DMC || ACC_CC_PACIFICC || ACC_CC_SYMANTECC || ACC_CC_ZORTECHC)
diff --git a/testing/ucl/APKBUILD b/testing/ucl/APKBUILD
new file mode 100644
index 0000000000..096d3e8851
--- /dev/null
+++ b/testing/ucl/APKBUILD
@@ -0,0 +1,31 @@
+#-*-mode: Shell-script; coding: utf-8;-*-
+# Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
+pkgname=ucl
+pkgver=1.03
+pkgrel=0
+pkgdesc="Portable lossless data compression library written in ANSI C"
+url="http://www.oberhumer.com/opensource/ucl/"
+arch="all"
+license="gpl"
+makedepends="file"
+source="
+ http://www.oberhumer.com/opensource/$pkgname/download/$pkgname-$pkgver.tar.gz
+ 0001-Static-assert.patch
+"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr --enable-shared --enable-static || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="852bd691d8abc75b52053465846fba34 ucl-1.03.tar.gz
+e852ab6af348477e6c6b3f1ee41b2200 0001-Static-assert.patch"
+sha256sums="b865299ffd45d73412293369c9754b07637680e5c826915f097577cd27350348 ucl-1.03.tar.gz
+b0269e9f934e23a5992acffe193a27892cd47d91a7e0d65cb6a91e2131896a65 0001-Static-assert.patch"
+sha512sums="7dd1824d01b4bb41ee03bbceddc634a9f7f910d235e5cca163d783680d6743f0f3cc309bbbcc1e094d897d549d3805a555f9093b4d77805443d896dd1862aa34 ucl-1.03.tar.gz
+24a34de871fcfa919985afc29c60496b1f0e730550e8387f212a5229f32ccade4178d1221574d86c36d025c08b3b5ed6d236f2b4d740436afe0451ae9050f890 0001-Static-assert.patch"