aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-10-20 11:29:56 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-10-20 11:30:14 +0200
commit60dc4be870fa1d8f3e174620bdb695026388630b (patch)
tree534f5c2fa6ffff53a1f7573bde98c1e7d0cfc234 /testing
parent31d806ce2e862aa477e94bb2b976b7e8258ebc1f (diff)
downloadaports-60dc4be870fa1d8f3e174620bdb695026388630b.tar.bz2
aports-60dc4be870fa1d8f3e174620bdb695026388630b.tar.xz
testing/xfce4-mailwatch-plugin: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/xfce4-mailwatch-plugin/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/xfce4-mailwatch-plugin/APKBUILD b/testing/xfce4-mailwatch-plugin/APKBUILD
new file mode 100644
index 0000000000..27df38fa80
--- /dev/null
+++ b/testing/xfce4-mailwatch-plugin/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=xfce4-mailwatch-plugin
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="a multi-protocol, multi-mailbox mail watcher"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-mailwatch-plugin"
+arch="all"
+license="GPL-v2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev intltool libx11-dev glib-dev gtk+2.0-dev
+ xfce4-panel-dev libxfce4ui-dev exo-dev libgcrypt-dev gnutls-dev"
+install=""
+subpackages="$pkgname-lang"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-mailwatch-plugin/1.2/xfce4-mailwatch-plugin-$pkgver.tar.bz2"
+builddir="$srcdir/xfce4-mailwatch-plugin-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-ssl \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="7263114ec0f2987a3aff15afeeb45577 xfce4-mailwatch-plugin-1.2.0.tar.bz2"
+sha256sums="624acc8229a8593c0dfeb28f883f4958119a715cc81cecdbaf29efc8ab1edcad xfce4-mailwatch-plugin-1.2.0.tar.bz2"
+sha512sums="6f5128b2341ab275427e02b1ef063cb2fdcf4027f5c47cfc0ed26086462eb0e9f7353441ea1b9380b91a892414934203b781445f604d67200786e3dd85183a83 xfce4-mailwatch-plugin-1.2.0.tar.bz2"