aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorPrzemyslaw Pawelczyk <przemoc@zoho.com>2016-11-16 15:13:30 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2016-11-17 12:21:57 +0100
commitb1b50f22f93ff5ee29be93ac3aa3df3e0ac8d14e (patch)
tree3c68f849ff900254e27e5162bf143e46963a34c9 /testing
parent7f4d842ad53d9054053706374fdcf2343a909ef2 (diff)
downloadaports-b1b50f22f93ff5ee29be93ac3aa3df3e0ac8d14e.tar.bz2
aports-b1b50f22f93ff5ee29be93ac3aa3df3e0ac8d14e.tar.xz
testing/rhash: New aport.
http://rhash.anz.ru/ RHash is a console utility for calculation and verification of magnet links and a wide range of hash sums like CRC32, MD4, MD5, SHA1, SHA256, SHA512, SHA3, AICH, ED2K, Tiger, DC++ TTH, BitTorrent BTIH, GOST R 34.11-94, RIPEMD-160, HAS-160, EDON-R, Whirlpool and Snefru.
Diffstat (limited to 'testing')
-rw-r--r--testing/rhash/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/rhash/APKBUILD b/testing/rhash/APKBUILD
new file mode 100644
index 0000000000..9d3c2f3ab7
--- /dev/null
+++ b/testing/rhash/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Przemyslaw Pawelczyk <przemoc@zoho.com>
+pkgname=rhash
+pkgver=1.3.4
+pkgrel=0
+pkgdesc="Utility for calculation and verification of hash sums and magnet links"
+url="http://rhash.anz.ru/"
+arch="all"
+license="custom"
+depends=
+depends_dev=""
+makedepends="$depends_dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-src.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ make \
+ || return 1
+}
+
+package() {
+ cd "$builddir"
+ make install \
+ DESTDIR="$pkgdir" \
+ PREFIX=/usr \
+ || return 1
+}
+
+md5sums="0b51010604659e9e99f6307b053ba13b rhash-1.3.4.tar.gz"
+sha256sums="406662c4703bd4cb1caae26f32700951a5e12adf39f141d3f40e0b461b1e9e49 rhash-1.3.4.tar.gz"
+sha512sums="a78be309011798d5e55023eb93f898c10254a42270288fa5ec68ad446b5f3d001e8c6f893683e5171e3858c86d45ce2ce16eefde1173209e1925420c27a7ff7a rhash-1.3.4.tar.gz"