aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorHasse Hagen Johansen <hasse-docker@hagenjohansen.dk>2016-02-21 11:10:34 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-02-25 12:22:29 +0100
commitdacff0b394eb656de164164cd80eb8711291961b (patch)
tree33ed4cec805c8065e968bd22278d3ed954a2bd7f /testing
parent9c7cec05a18597c72ddf5f28bf11571216549964 (diff)
downloadaports-dacff0b394eb656de164164cd80eb8711291961b.tar.bz2
aports-dacff0b394eb656de164164cd80eb8711291961b.tar.xz
testing/libhdhomerun: new aport
http://www.silicondust.com/support/downloads/linux/ Library for Silicon Dust HD HomeRun
Diffstat (limited to 'testing')
-rw-r--r--testing/libhdhomerun/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/libhdhomerun/APKBUILD b/testing/libhdhomerun/APKBUILD
new file mode 100644
index 0000000000..99c596be51
--- /dev/null
+++ b/testing/libhdhomerun/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Hasse Hagen Johansen <hasse-docker@hagenjohansen.dk>
+# Maintainer: Hasse Hagen Johansen <hasse-docker@hagenjohansen.dk>
+pkgname=libhdhomerun
+pkgver=20150826
+pkgrel=0
+pkgdesc="Library for Silicon Dust HD HomeRun"
+url="http://www.silicondust.com/support/downloads/linux/"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://download.silicondust.com/hdhomerun/${pkgname}_${pkgver}.tgz"
+
+_builddir=
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cd libhdhomerun
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ cd src/libhdhomerun
+ install -Dm755 hdhomerun_config "$pkgdir"/usr/bin/hdhomerun_config
+ install -Dm444 libhdhomerun.so "$pkgdir"/usr/lib/libhdhomerun.so
+ install -d "$pkgdir"/usr/include/libhdhomerun
+ install -D *.h "$pkgdir"/usr/include/libhdhomerun
+ install -Dm644 lgpl.txt "$pkgdir"/usr/share/licenses/$pkgname/lgpl.txt
+}
+
+md5sums="05f9a9e1fc8f6ec004b399034775cab0 libhdhomerun_20150826.tgz"
+sha256sums="907dfbd1eb82aebd8b09e7c00c21a02433e6baaacf4a4f99aa2511b1d5244baf libhdhomerun_20150826.tgz"
+sha512sums="9b401c1649dc8c32ea9019b732631f9213cb66c43771aa148fa318202fc11739c005c474be6a77a6a7807818b5179f77debb5b2d2411d865cc87bb3d7ab629a6 libhdhomerun_20150826.tgz"