aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-25 00:30:26 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-25 00:59:44 -0300
commit06eca9ee2a3e68337ba35f8bb4c2c66591e0d68c (patch)
treed98d88e0303759dc7ed9f841a258459e7a42373e /testing
parent6a459c186381eb09599e211cc3b7b3d65b52fddd (diff)
downloadaports-06eca9ee2a3e68337ba35f8bb4c2c66591e0d68c.tar.bz2
aports-06eca9ee2a3e68337ba35f8bb4c2c66591e0d68c.tar.xz
testing/ocaml-num: upgrade to 1.2
Diffstat (limited to 'testing')
-rw-r--r--testing/ocaml-num/APKBUILD9
-rw-r--r--testing/ocaml-num/install-findlib.patch125
2 files changed, 2 insertions, 132 deletions
diff --git a/testing/ocaml-num/APKBUILD b/testing/ocaml-num/APKBUILD
index 450736b45a..a60307e15a 100644
--- a/testing/ocaml-num/APKBUILD
+++ b/testing/ocaml-num/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: alpine-mips-patches <info@mobile-stream.com>
pkgname=ocaml-num
_pkgname=num
-pkgver=1.1
+pkgver=1.2
pkgrel=0
pkgdesc="Arbitray-precision rational arithmetic for OCaml"
url="https://github.com/ocaml/num"
@@ -12,13 +12,11 @@ depends="ocaml-runtime"
makedepends="ocaml ocaml-compiler-libs ocaml-findlib"
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/ocaml/$_pkgname/archive/v$pkgver.tar.gz
- install-findlib.patch
install-DESTDIR.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
make
}
@@ -27,8 +25,6 @@ check() {
}
package() {
- cd "$builddir"
-
local _libdir="usr/lib/ocaml"
mkdir -p "$pkgdir/$_libdir"
@@ -56,6 +52,5 @@ dev() {
done
}
-sha512sums="e7ee54e83eaab15ee879c5bb6deb0d76a3adf1ffd2cbd3f93cda63e7bc7b3a90313b94b4be078ecddaeee90a8a98a986d80c2fd6f1ad38faa35a318f77ec890e ocaml-num-1.1.tar.gz
-d07720ba5c0c26d31e4fb054d8d3fd6ab4cd9c0496ccf110efe77ecd17e5a0c8c68b8cade42a1cecb1adc74773b04ced8b08032e9b7a8c7e6e4a722501933c28 install-findlib.patch
+sha512sums="cf6b5e026d82235e9ed2cc31cbe1bf29171964a364c6ff23aaf0cc864f646002ce2be5b7296488f1568c7b2166d298298cd086f26fb10b52863dbf78f8b23844 ocaml-num-1.2.tar.gz
536ca5a1b0d76d9e6f1f33a560974bbebaebdcc020040631bb79d93748313691f8681cc6b43dc77a3dee78feb723b68e6220fa76b8276ad2577f23edd04aa15a install-DESTDIR.patch"
diff --git a/testing/ocaml-num/install-findlib.patch b/testing/ocaml-num/install-findlib.patch
deleted file mode 100644
index 5d0c99151c..0000000000
--- a/testing/ocaml-num/install-findlib.patch
+++ /dev/null
@@ -1,125 +0,0 @@
-diff --git a/.gitignore b/.gitignore
-index 6acd3bc..4802fdc 100644
---- a/.gitignore
-+++ b/.gitignore
-@@ -8,3 +8,6 @@
- *.cmx[as]
- *.cmti
- *.annot
-+src/META
-+test/test.byt
-+test/test.exe
-diff --git a/Changelog b/Changelog
-index 791b18b..72a3999 100644
---- a/Changelog
-+++ b/Changelog
-@@ -1,3 +1,9 @@
-+- GPR#6: provide findlib-install target to install everything using ocamlfind
-+- Issue#3: make sur the stublibs/ directory exists before installing DLLs
-+ inside it.
-+- Issue#4: wrong DLL file names for Win32 ports, causing errors at
-+ installation time.
-+
- Release 1.1 (2017-10-13):
-
- - Install .cmx files as well.
-diff --git a/Makefile b/Makefile
-index 6a5d08f..b40e588 100644
---- a/Makefile
-+++ b/Makefile
-@@ -14,8 +14,16 @@ install:
- $(MAKE) -C src install
- $(MAKE) -C toplevel install
-
-+findlib-install:
-+ $(MAKE) -C src findlib-install
-+ $(MAKE) -C toplevel install
-+
- uninstall:
- $(MAKE) -C src uninstall
- $(MAKE) -C toplevel uninstall
-
--.PHONY: all test clean install uninstall
-+findlib-uninstall:
-+ $(MAKE) -C src findlib-uninstall
-+ $(MAKE) -C toplevel uninstall
-+
-+.PHONY: all test clean install uninstall findlib-install findlib-uninstall
-diff --git a/src/META b/src/META.in
-similarity index 72%
-rename from src/META
-rename to src/META.in
-index 66ac170..b5678b7 100644
---- a/src/META
-+++ b/src/META.in
-@@ -1,6 +1,8 @@
- # This META is the one provided by findlib when the "num" library was
- # part of the core OCaml distribution. For backward compatibility,
--# it installs into OCaml's standard library directory, not in a subdirectory
-+# it is installed into OCaml's standard library directory. If the
-+# directory line below is removed, then it's installed in a
-+# subdirectory, as normal for a findlib package.
-
- requires = "num.core"
- requires(toploop) = "num.core,num-top"
-diff --git a/src/Makefile b/src/Makefile
-index 97dc074..8a88035 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -5,6 +5,7 @@ OCAMLMKLIB=ocamlmklib
- OCAMLFIND=ocamlfind
- INSTALL_DATA=install -m 644
- INSTALL_DLL=install
-+INSTALL_DIR=install -d
- STDLIBDIR=$(shell $(OCAMLC) -where)
-
- include $(STDLIBDIR)/Makefile.config
-@@ -75,29 +76,43 @@ nat_stubs.$(O): bng.h nat.h
-
- TOINSTALL=nums.cma libnums.$(A) $(CMIS) $(CMIS:.cmi=.mli) $(CMIS:.cmi=.cmti)
- ifneq "$(ARCH)" "none"
--TOINSTALL+=nums.cmxa nums.$(A) $(CMIS:.cmi=.cmx)
-+TOINSTALL+=nums.cmxa nums.$(A) $(CMXS)
- endif
- ifeq "$(NATDYNLINK)" "true"
- TOINSTALL+=nums.cmxs
- endif
--TOINSTALL_STUBS=dllnums.$(SO)
-+ifeq "$(SUPPORTS_SHARED_LIBRARIES)" "true"
-+TOINSTALL_STUBS=dllnums$(EXT_DLL)
-+else
-+TOINSTALL_STUBS=
-+endif
-
- install:
-+ cp META.in META
- $(OCAMLFIND) install num META
-+ rm -f META
- $(INSTALL_DATA) $(TOINSTALL) $(STDLIBDIR)
- ifeq "$(SUPPORTS_SHARED_LIBRARIES)" "true"
-+ $(INSTALL_DIR) $(STDLIBDIR)/stublibs
- $(INSTALL_DLL) $(TOINSTALL_STUBS) $(STDLIBDIR)/stublibs
- endif
-
--uninstall:
-+findlib-install:
-+ grep -Fv '^' META.in > META
-+ $(OCAMLFIND) install num META $(TOINSTALL) $(TOINSTALL_STUBS)
-+ rm -f META
-+
-+findlib-uninstall:
-+ $(OCAMLFIND) remove num
-+
-+uninstall: findlib-uninstall
- cd $(STDLIBDIR) && rm -f $(TOINSTALL)
- ifeq "$(SUPPORTS_SHARED_LIBRARIES)" "true"
- cd $(STDLIBDIR)/stublibs && rm -f $(TOINSTALL_STUBS)
- endif
-- $(OCAMLFIND) remove num
-
- clean:
-- rm -f *.cm[ioxta] *.cmx[as] *.cmti *.$(O) *.$(A) *.$(SO)
-+ rm -f *.cm[ioxta] *.cmx[as] *.cmti *.$(O) *.$(A) *$(EXT_DLL)
-
- depend:
- $(OCAMLDEP) -slash *.mli *.ml > .depend