aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-23 21:57:56 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-23 21:58:54 +0100
commit0adb5cd4c407e2984018e98010b5ec4e9c908ec5 (patch)
treee6b863ba93d81bb42cc4adcb1998c3667bd6ef53 /testing
parentd75c4d16ff00f0cfba4d2cf49da91c8b73402219 (diff)
downloadaports-0adb5cd4c407e2984018e98010b5ec4e9c908ec5.tar.bz2
aports-0adb5cd4c407e2984018e98010b5ec4e9c908ec5.tar.xz
community/ttyd: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/ttyd/APKBUILD41
-rw-r--r--testing/ttyd/fix-cmake.patch20
2 files changed, 0 insertions, 61 deletions
diff --git a/testing/ttyd/APKBUILD b/testing/ttyd/APKBUILD
deleted file mode 100644
index ab93672a9e..0000000000
--- a/testing/ttyd/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-pkgname=ttyd
-pkgver=1.3.1
-pkgrel=0
-pkgdesc="Share your terminal over the web"
-url="https://tsl0922.github.io/ttyd"
-arch="all"
-license="MIT"
-# Note: vim is needed for tool xxd.
-makedepends="cmake json-c-dev bsd-compat-headers libressl-dev libwebsockets-dev
- vim zlib-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/tsl0922/$pkgname/archive/$pkgver.tar.gz
- fix-cmake.patch"
-builddir="$srcdir/$pkgname-$pkgver"
-
-build() {
- cd "$builddir"
-
- mkdir -p build && cd build
- cmake .. \
- -DCMAKE_BUILD_TYPE=MinSizeRel \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_VERBOSE_MAKEFILE=TRUE \
- || return 1
- make
-}
-
-check() {
- cd "$builddir"/build
-
- ./ttyd --version >/dev/null
-}
-
-package() {
- cd "$builddir"/build
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="9b03955fcd08ba4b8981445d26cacd042f7f995a2a7773b0a657520a857b59f4fe363f9a5bafdc5b22397c9aede64b8a207c65c2093528d54c0a2a3260fffd9c ttyd-1.3.1.tar.gz
-677f71abfec9e74db8f7976e6cb8c4eba052df71162390fa26e7c31f064a179d8587f07088eb0a5ada507a345b11af8d663162c77aad5e7fd129503eb15f83af fix-cmake.patch"
diff --git a/testing/ttyd/fix-cmake.patch b/testing/ttyd/fix-cmake.patch
deleted file mode 100644
index 274bfcb7ef..0000000000
--- a/testing/ttyd/fix-cmake.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-find_package doesn't find Libwebsockets (with capital "L"). Eventually it finds
-libwebsockets with pkg-config, but includes libwebsockets.a on the path first,
-so the resulting library links libwebsockets statically.
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -13,11 +13,11 @@
- set(SOURCE_FILES src/server.c src/http.c src/protocol.c src/utils.c)
-
- find_package(OpenSSL REQUIRED)
--find_package(Libwebsockets ${LIBWEBSOCKETS_MIN_VERSION} QUIET)
-+find_package(libwebsockets ${LIBWEBSOCKETS_MIN_VERSION} QUIET)
-
- find_package(PkgConfig)
-
--if(Libwebsockets_FOUND)
-+if(libwebsockets_FOUND)
- set(LIBWEBSOCKETS_INCLUDE_DIR ${LIBWEBSOCKETS_INCLUDE_DIR} ${LIBWEBSOCKETS_INCLUDE_DIRS})
- else() # try to find libwebsockets with pkg-config
- pkg_check_modules(Libwebsockets REQUIRED libwebsockets>=${LIBWEBSOCKETS_MIN_VERSION})