aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-04-09 12:32:50 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2020-04-09 12:34:56 +0200
commit0f49d5a17bdbc0fcb5f4f4f338a4682c077d40da (patch)
treea85f0b164a836470a8c69478a7105a837952c843 /testing
parent9186a6f36134a6413c2fe245155f621eb8d0f175 (diff)
downloadaports-0f49d5a17bdbc0fcb5f4f4f338a4682c077d40da.tar.bz2
aports-0f49d5a17bdbc0fcb5f4f4f338a4682c077d40da.tar.xz
testing/openocd: modernize APKBUILD
Diffstat (limited to 'testing')
-rw-r--r--testing/openocd/APKBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/testing/openocd/APKBUILD b/testing/openocd/APKBUILD
index 765263f8f7..81d7850210 100644
--- a/testing/openocd/APKBUILD
+++ b/testing/openocd/APKBUILD
@@ -7,16 +7,11 @@ pkgdesc="Free and Open On-Chip Debugging, In-System Programming and Boundary-Sca
url="http://openocd.org/"
arch="all"
license="GPL-2.0-only,GPL-2.0-or-later,GPL-3.0-only"
-depends=""
-depends_dev=""
makedepends="libftdi1-dev libusb-dev hidapi-dev libtool"
-install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://downloads.sourceforge.net/project/openocd/openocd/$pkgver/openocd-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -32,11 +27,10 @@ build() {
}
check() {
- make -C "$builddir" check
+ make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}